mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: glibc-for-bootstrap: Fix patch.
This is a follow-up to d08f5299e6
.
* gnu/packages/patches/glibc-bootstrap-system.patch: Update.
This commit is contained in:
parent
73b67eeea4
commit
923bb70a1b
1 changed files with 13 additions and 2 deletions
|
@ -3,8 +3,10 @@ and popen(3) need to be tweaked to use the right shell. For the bootstrap
|
||||||
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
|
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
|
||||||
instead uses the hard-coded absolute file name of `bash'.
|
instead uses the hard-coded absolute file name of `bash'.
|
||||||
|
|
||||||
|
In addition, status should be initialized to 0 and not -1.
|
||||||
|
|
||||||
diff --git a/libio/iopopen.c b/libio/iopopen.c
|
diff --git a/libio/iopopen.c b/libio/iopopen.c
|
||||||
index ebc381ed..e0d3ed1b 100644
|
index ebc381ed7c..e0d3ed1bc3 100644
|
||||||
--- a/libio/iopopen.c
|
--- a/libio/iopopen.c
|
||||||
+++ b/libio/iopopen.c
|
+++ b/libio/iopopen.c
|
||||||
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
|
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
|
||||||
|
@ -17,9 +19,18 @@ index ebc381ed..e0d3ed1b 100644
|
||||||
(char *) command, NULL }, __environ) != 0)
|
(char *) command, NULL }, __environ) != 0)
|
||||||
return false;
|
return false;
|
||||||
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
|
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
|
||||||
index a03f478f..9530404e 100644
|
index a03f478fc7..94da6facf3 100644
|
||||||
--- a/sysdeps/posix/system.c
|
--- a/sysdeps/posix/system.c
|
||||||
+++ b/sysdeps/posix/system.c
|
+++ b/sysdeps/posix/system.c
|
||||||
|
@@ -101,7 +101,7 @@ cancel_handler (void *arg)
|
||||||
|
static int
|
||||||
|
do_system (const char *line)
|
||||||
|
{
|
||||||
|
- int status = -1;
|
||||||
|
+ int status = 0;
|
||||||
|
int ret;
|
||||||
|
pid_t pid;
|
||||||
|
struct sigaction sa;
|
||||||
@@ -145,7 +145,7 @@ do_system (const char *line)
|
@@ -145,7 +145,7 @@ do_system (const char *line)
|
||||||
__posix_spawnattr_setflags (&spawn_attr,
|
__posix_spawnattr_setflags (&spawn_attr,
|
||||||
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
|
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
|
||||||
|
|
Loading…
Reference in a new issue