mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: efibootmgr: Update to 18.
* gnu/packages/linux.scm (efibootmgr): Update to 18. [source]: Delete snippet, modules and patches fields. * gnu/packages/patches/efibootmgr-remove-extra-decl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
parent
9f3a929828
commit
923d23a23c
3 changed files with 8 additions and 45 deletions
|
@ -1051,7 +1051,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dstat-skip-devices-without-io.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
%D%/packages/patches/dynaconf-unvendor-deps.patch \
|
||||
%D%/packages/patches/efibootmgr-remove-extra-decl.patch \
|
||||
%D%/packages/patches/efivar-211.patch \
|
||||
%D%/packages/patches/eigen-fix-strict-aliasing-bug.patch \
|
||||
%D%/packages/patches/einstein-build.patch \
|
||||
|
|
|
@ -7266,7 +7266,7 @@ (define-public efivar
|
|||
(define-public efibootmgr
|
||||
(package
|
||||
(name "efibootmgr")
|
||||
(version "17")
|
||||
(version "18")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
|
@ -7275,16 +7275,7 @@ (define-public efibootmgr
|
|||
(commit version)))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "1niicijxg59rsmiw3rsjwy4bvi1n42dynvm01lnp9haixdzdpq03"))
|
||||
(patches (search-patches "efibootmgr-remove-extra-decl.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
;; Cast the first argument to the correct type. Extracted
|
||||
;; from upstream commit e8ce9fecebd15adb4.
|
||||
(substitute* '("src/efibootdump.c" "src/efibootmgr.c")
|
||||
(("efidp_format_device_path\\(text_path,")
|
||||
"efidp_format_device_path((unsigned char *)text_path,"))))))
|
||||
(base32 "1j19m3dngcb7jl88ib32phbh5r7c02dhhakq8jk6z7y408c111hd"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
@ -7299,12 +7290,12 @@ (define-public efibootmgr
|
|||
;; nothing else is specified on the command line.
|
||||
"EFIDIR=gnu")
|
||||
#$(if (%current-target-system)
|
||||
#~(list
|
||||
(string-append "CC=" #$(cc-for-target))
|
||||
(string-append "PKG_CONFIG=" #$(pkg-config-for-target))
|
||||
(string-append "EXTRAINCDIRS="
|
||||
#$(this-package-input "efivar") "/include"))
|
||||
#~'()))
|
||||
#~(list
|
||||
(string-append "CC=" #$(cc-for-target))
|
||||
(string-append "PKG_CONFIG=" #$(pkg-config-for-target))
|
||||
(string-append "EXTRAINCDIRS="
|
||||
#$(this-package-input "efivar") "/include"))
|
||||
#~'()))
|
||||
#:phases #~(modify-phases %standard-phases (delete 'configure))))
|
||||
(native-inputs
|
||||
(list pkg-config))
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From 99b578501643377e0b1994b2a068b790d189d5ad Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Wed, 13 Jun 2018 09:41:01 -0400
|
||||
Subject: [PATCH] remove extra decl
|
||||
|
||||
Signed-off-by: Peter Jones <pjones@redhat.com>
|
||||
---
|
||||
src/efibootmgr.c | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/src/efibootmgr.c b/src/efibootmgr.c
|
||||
index de38f01..4e1a680 100644
|
||||
--- a/src/efibootmgr.c
|
||||
+++ b/src/efibootmgr.c
|
||||
@@ -1536,9 +1536,6 @@ parse_opts(int argc, char **argv)
|
||||
"invalid numeric value %s\n",
|
||||
optarg);
|
||||
}
|
||||
- /* XXX efivar-36 accidentally doesn't have a public
|
||||
- * header for this */
|
||||
- extern int efi_set_verbose(int verbosity, FILE *errlog);
|
||||
efi_set_verbose(opts.verbose - 2, stderr);
|
||||
break;
|
||||
case 'V':
|
||||
--
|
||||
2.24.0
|
||||
|
Loading…
Reference in a new issue