mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: rapidcheck: Fix pkg-config libs.
Using rapidcheck as a dependency in a project currently results in a linker error, because the pkg-config file is missing relevant linker flags. * gnu/packages/patches/rapidcheck-fix-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/check.scm (rapidcheck)[patches]: Use it here.
This commit is contained in:
parent
786eb92c0f
commit
93ceb2d901
3 changed files with 29 additions and 0 deletions
|
@ -2077,6 +2077,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/qtwayland-cleanup-callbacks.patch \
|
||||
%D%/packages/patches/ragel-char-signedness.patch \
|
||||
%D%/packages/patches/randomjungle-disable-static-build.patch \
|
||||
%D%/packages/patches/rapidcheck-fix-libs.patch \
|
||||
%D%/packages/patches/raptor2-heap-overflow.patch \
|
||||
%D%/packages/patches/ratpoints-sturm_and_rp_private.patch \
|
||||
%D%/packages/patches/ratpoison-shell.patch \
|
||||
|
|
|
@ -3798,6 +3798,7 @@ (define-public rapidcheck
|
|||
(sha256
|
||||
(base32 "1s2qva1amhs887jcdj12ppxk9kkfvy25xy7vzhkwb7rljr3gj713"))
|
||||
(modules '((guix build utils)))
|
||||
(patches (search-patches "rapidcheck-fix-libs.patch"))
|
||||
(snippet
|
||||
#~(begin
|
||||
(make-file-writable "ext/CMakeLists.txt")
|
||||
|
|
27
gnu/packages/patches/rapidcheck-fix-libs.patch
Normal file
27
gnu/packages/patches/rapidcheck-fix-libs.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From c4f558b0990571759fdaf976eb35ee1eb0d934a0 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Hensing <robert@roberthensing.nl>
|
||||
Date: Tue, 25 Jun 2024 20:57:41 +0200
|
||||
Subject: [PATCH] Add -lrapidcheck to pkg-config module
|
||||
|
||||
This adds the library to rapidcheck.pc, so that it doesn't have
|
||||
to be specified manually in projects that consume it.
|
||||
|
||||
The other modules don't need it because they have rapidcheck in
|
||||
their Requires field.
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index d55fdc51..046df2fd 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -128,7 +128,7 @@ set(PKG_CONFIG_DESCRIPTION_SUMMARY "C++ framework for property based testing ins
|
||||
set(PKG_CONFIG_VERSION)
|
||||
set(PKG_CONFIG_LIBDIR "\${prefix}/lib")
|
||||
set(PKG_CONFIG_INCLUDEDIR "\${prefix}/include")
|
||||
-set(PKG_CONFIG_LIBS)
|
||||
+set(PKG_CONFIG_LIBS "-L\${libdir} -lrapidcheck")
|
||||
set(PKG_CONFIG_CFLAGS "-I\${includedir}")
|
||||
|
||||
configure_file(
|
Loading…
Reference in a new issue