mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 06:06:53 -05:00
gnu: module-init-tools: Fix $LINUX_MODULE_DIRECTORY handling in 'depmod'.
* gnu/packages/patches/module-init-tools-moduledir.patch: Adjust the 'depmod' part to handle $LINUX_MODULE_DIRECTORY without a trailing slash.
This commit is contained in:
parent
4a8b4c25b0
commit
94b13427d7
1 changed files with 2 additions and 2 deletions
|
@ -6,7 +6,7 @@ Original patch by David Guibert, from Nixpkgs; adjusted to use
|
|||
'LINUX_MODULE_DIRECTORY' rather than 'MODULE_DIR' as the variable name.
|
||||
|
||||
diff --git a/depmod.c b/depmod.c
|
||||
index a1d2f8c..a8f92b2 100644
|
||||
index a1d2f8c..ff579c7 100644
|
||||
--- a/depmod.c
|
||||
+++ b/depmod.c
|
||||
@@ -48,9 +48,6 @@
|
||||
|
@ -77,7 +77,7 @@ index a1d2f8c..a8f92b2 100644
|
|||
+ module_dir = "/lib/modules";
|
||||
+ }
|
||||
+
|
||||
+ nofail_asprintf(&dirname, "%s%s%s", basedir, module_dir, version);
|
||||
+ nofail_asprintf(&dirname, "%s%s/%s", basedir, module_dir, version);
|
||||
|
||||
if (maybe_all) {
|
||||
if (!doing_stdout && !depfile_out_of_date(dirname))
|
||||
|
|
Loading…
Reference in a new issue