mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: boost: Patch transitive linking bug.
* gnu/packages/patches/boost-fix-transitive-linking.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
ced3d5cbf9
commit
94cf367634
3 changed files with 21 additions and 0 deletions
|
@ -40,6 +40,7 @@
|
||||||
# Copyright © 2020 Malte Frank Gerdes <mate.f.gerdes@gmail.com>
|
# Copyright © 2020 Malte Frank Gerdes <mate.f.gerdes@gmail.com>
|
||||||
# Copyright © 2020 Vinicius Monego <monego@posteo.net>
|
# Copyright © 2020 Vinicius Monego <monego@posteo.net>
|
||||||
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
|
# Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
|
||||||
|
# Copyright © 2021 Greg Hogan <code@greghogan.com>
|
||||||
#
|
#
|
||||||
# This file is part of GNU Guix.
|
# This file is part of GNU Guix.
|
||||||
#
|
#
|
||||||
|
@ -866,6 +867,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/blender-2.79-oiio2.patch \
|
%D%/packages/patches/blender-2.79-oiio2.patch \
|
||||||
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
|
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
|
||||||
%D%/packages/patches/blender-2.79-python-3.8-fix.patch \
|
%D%/packages/patches/blender-2.79-python-3.8-fix.patch \
|
||||||
|
%D%/packages/patches/boost-fix-transitive-linking.patch \
|
||||||
%D%/packages/patches/bpftrace-disable-bfd-disasm.patch \
|
%D%/packages/patches/bpftrace-disable-bfd-disasm.patch \
|
||||||
%D%/packages/patches/byobu-writable-status.patch \
|
%D%/packages/patches/byobu-writable-status.patch \
|
||||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||||
|
|
|
@ -15,6 +15,7 @@
|
||||||
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
|
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
|
||||||
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
|
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
|
||||||
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
|
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
|
||||||
|
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
|
@ -68,6 +69,8 @@ (define-public boost
|
||||||
(uri (string-append "https://dl.bintray.com/boostorg/release/"
|
(uri (string-append "https://dl.bintray.com/boostorg/release/"
|
||||||
version "/source/boost_"
|
version "/source/boost_"
|
||||||
(version-with-underscores version) ".tar.bz2"))
|
(version-with-underscores version) ".tar.bz2"))
|
||||||
|
; Should be included in next Boost update
|
||||||
|
(patches (search-patches "boost-fix-transitive-linking.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
|
"1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
|
||||||
|
|
16
gnu/packages/patches/boost-fix-transitive-linking.patch
Normal file
16
gnu/packages/patches/boost-fix-transitive-linking.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
Patch from https://github.com/boostorg/boost_install/issues/47
|
||||||
|
which should be included in the Boost 1.76 release.
|
||||||
|
|
||||||
|
This patch prevents CMake from explicitly linking against Boost dependencies
|
||||||
|
when building against the shared Boost libraries.
|
||||||
|
--- a/tools/boost_install/boost-install.jam
|
||||||
|
+++ b/tools/boost_install/boost-install.jam
|
||||||
|
@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
|
||||||
|
|
||||||
|
.info " deps3=" $(deps3) ;
|
||||||
|
|
||||||
|
- if $(deps3)
|
||||||
|
+ if $(deps3) && $(link) = static
|
||||||
|
{
|
||||||
|
print.text
|
||||||
|
|
Loading…
Reference in a new issue