mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: aws-c-event-stream: Replace patch.
* gnu/packages/c.scm (aws-c-event-stream): Replace patch. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patch. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: Delete file. * gnu/local.mk: Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
c769b8c2b5
commit
963ebbc62c
3 changed files with 5 additions and 17 deletions
|
@ -871,7 +871,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||
%D%/packages/patches/aws-c-auth-install-private-headers.patch \
|
||||
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
|
||||
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
||||
%D%/packages/patches/azr3.patch \
|
||||
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
|
||||
|
|
|
@ -605,6 +605,7 @@ (define-public aws-checksums
|
|||
(define-public aws-c-event-stream
|
||||
(package
|
||||
(name "aws-c-event-stream")
|
||||
; Update only when updating aws-crt-cpp.
|
||||
(version "0.2.7")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
|
@ -614,12 +615,13 @@ (define-public aws-c-event-stream
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))
|
||||
(patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
|
||||
"0xwwr7gdgfrphk6j7vk12rgimfim6m4qnj6hg8hgg16cplhvsfzh"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
'(#:configure-flags
|
||||
'("-DBUILD_SHARED_LIBS=ON")))
|
||||
(list "-DBUILD_SHARED_LIBS=ON"
|
||||
(string-append "-DCMAKE_PREFIX_PATH="
|
||||
(assoc-ref %build-inputs "aws-c-common")))))
|
||||
(propagated-inputs
|
||||
`(("aws-c-common" ,aws-c-common)
|
||||
("aws-c-io" ,aws-c-io)
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -3,6 +3,10 @@
|
||||
cmake_minimum_required (VERSION 3.1)
|
||||
project (aws-c-event-stream C)
|
||||
|
||||
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
||||
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
||||
+endif()
|
||||
+
|
||||
if (DEFINED CMAKE_PREFIX_PATH)
|
||||
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
||||
endif()
|
Loading…
Reference in a new issue