mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-26 20:49:29 -05:00
gnu: gnome-todo: Update to "Endeavour" 42.0.
* gnu/packages/gnome.scm (gnome-todo): Deprecate and rename to... (endeavour): ... this. [source]: Use git origin. * gnu/packages/patches/gnome-todo-libportal.patch: Deleted file. * gnu/local.mk (dist_patch_DATA): Update accordingly.
This commit is contained in:
parent
72fe3c0a35
commit
96c7887864
3 changed files with 11 additions and 64 deletions
|
@ -1219,7 +1219,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gnome-online-miners-tracker-3.patch \
|
||||
%D%/packages/patches/gnome-settings-daemon-gc.patch \
|
||||
%D%/packages/patches/gnome-session-support-elogind.patch \
|
||||
%D%/packages/patches/gnome-todo-libportal.patch \
|
||||
%D%/packages/patches/gnome-tweaks-search-paths.patch \
|
||||
%D%/packages/patches/gnupg-CVE-2022-34903.patch \
|
||||
%D%/packages/patches/gnupg-default-pinentry.patch \
|
||||
|
|
|
@ -10252,19 +10252,18 @@ (define-public gnome-calendar
|
|||
desktop. It supports multiple calendars, month, week and year view.")
|
||||
(license license:gpl3+)))
|
||||
|
||||
(define-public gnome-todo
|
||||
(define-public endeavour
|
||||
(package
|
||||
(name "gnome-todo")
|
||||
(version "41.0")
|
||||
(name "endeavour")
|
||||
(version "42.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||
(version-major version) "/"
|
||||
name "-" version ".tar.xz"))
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://gitlab.gnome.org/World/Endeavour")
|
||||
(commit (string-append "v" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"1r94880d4khbjhhfnhaba3y3d4hv2bri82rzfzxn27s5iybpqras"))
|
||||
(patches (search-patches "gnome-todo-libportal.patch"))))
|
||||
"0d6by7aq8db35zavzvckcxxxcdi6qnv0mkjndhb0syc8ih15dpak"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
@ -10309,6 +10308,9 @@ (define-public gnome-todo
|
|||
to perfectly fit the GNOME desktop.")
|
||||
(license license:gpl3+)))
|
||||
|
||||
(define-public gnome-todo
|
||||
(deprecated-package "gnome-todo" endeavour))
|
||||
|
||||
(define-public gnome-dictionary
|
||||
(package
|
||||
(name "gnome-dictionary")
|
||||
|
|
|
@ -1,54 +0,0 @@
|
|||
From 3e1f4da8c0e536c09ffaf3b43fe2eb5dc17cc23e Mon Sep 17 00:00:00 2001
|
||||
From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
|
||||
Date: Thu, 18 Nov 2021 19:46:13 -0300
|
||||
Subject: [PATCH] flatpak: Adjust to libportal changes
|
||||
|
||||
---
|
||||
build-aux/flatpak/org.gnome.Todo.json | 3 +++
|
||||
src/plugins/background/gtd-plugin-background.c | 2 +-
|
||||
src/plugins/background/meson.build | 2 +-
|
||||
3 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build-aux/flatpak/org.gnome.Todo.json b/build-aux/flatpak/org.gnome.Todo.json
|
||||
index 034e200c..44b83d66 100644
|
||||
--- a/build-aux/flatpak/org.gnome.Todo.json
|
||||
+++ b/build-aux/flatpak/org.gnome.Todo.json
|
||||
@@ -143,6 +143,9 @@
|
||||
{
|
||||
"name" : "libportal",
|
||||
"buildsystem" : "meson",
|
||||
+ "config-opts" : [
|
||||
+ "-Dbackends=gtk4"
|
||||
+ ],
|
||||
"sources" : [
|
||||
{
|
||||
"type" : "git",
|
||||
diff --git a/src/plugins/background/gtd-plugin-background.c b/src/plugins/background/gtd-plugin-background.c
|
||||
index cf48786c..f64d07aa 100644
|
||||
--- a/src/plugins/background/gtd-plugin-background.c
|
||||
+++ b/src/plugins/background/gtd-plugin-background.c
|
||||
@@ -28,7 +28,7 @@
|
||||
#include <gtk/gtk.h>
|
||||
|
||||
#include <libportal/portal.h>
|
||||
-#include <libportal/portal-gtk4.h>
|
||||
+#include <libportal-gtk4/portal-gtk4.h>
|
||||
|
||||
#define AUTOSTART_NOTIFICATION_ID "Gtd::BackgroundPlugin::autostart_notification"
|
||||
#define AUTOSTART_NOTIFICATION_TIMEOUT 3 /* seconds */
|
||||
diff --git a/src/plugins/background/meson.build b/src/plugins/background/meson.build
|
||||
index a671a4f3..59d3635f 100644
|
||||
--- a/src/plugins/background/meson.build
|
||||
+++ b/src/plugins/background/meson.build
|
||||
@@ -1,7 +1,7 @@
|
||||
plugins_ldflags += ['-Wl,--undefined=gtd_plugin_background_register_types']
|
||||
|
||||
plugins_deps += [
|
||||
- dependency('libportal'),
|
||||
+ dependency('libportal-gtk4'),
|
||||
]
|
||||
|
||||
plugins_sources += files(
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in a new issue