mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-18 04:37:36 -05:00
gnu: ganeti: Remove PYTHONPATH-altering patch.
* gnu/packages/patches/ganeti-preserve-PYTHONPATH.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Un-register it. * gnu/packages/virtualization.scm (ganeti): Remove patch.
This commit is contained in:
parent
a0658f1a33
commit
98f147dbda
3 changed files with 1 additions and 24 deletions
|
@ -1008,7 +1008,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ganeti-drbd-compat.patch \
|
||||
%D%/packages/patches/ganeti-haskell-pythondir.patch \
|
||||
%D%/packages/patches/ganeti-os-disk-size.patch \
|
||||
%D%/packages/patches/ganeti-preserve-PYTHONPATH.patch \
|
||||
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
|
||||
%D%/packages/patches/ganeti-shepherd-support.patch \
|
||||
%D%/packages/patches/gash-utils-ls-test.patch \
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
Do not override PYTHONPATH when calling Python code from the Haskell
|
||||
daemons. This is necessary because the Python library dependencies are
|
||||
only available through PYTHONPATH.
|
||||
|
||||
diff --git a/src/Ganeti/Query/Exec.hs b/src/Ganeti/Query/Exec.hs
|
||||
--- a/src/Ganeti/Query/Exec.hs
|
||||
+++ b/src/Ganeti/Query/Exec.hs
|
||||
@@ -99,12 +99,10 @@ spawnJobProcess jid = withErrorLogAt CRITICAL (show jid) $
|
||||
do
|
||||
use_debug <- isDebugMode
|
||||
env_ <- (M.toList . M.insert "GNT_DEBUG" (if use_debug then "1" else "0")
|
||||
- . M.insert "PYTHONPATH" AC.pythondir
|
||||
. M.fromList)
|
||||
`liftM` getEnvironment
|
||||
execPy <- P.jqueueExecutorPy
|
||||
logDebug $ "Executing " ++ AC.pythonPath ++ " " ++ execPy
|
||||
- ++ " with PYTHONPATH=" ++ AC.pythondir
|
||||
|
||||
(master, child) <- pipeClient connectConfig
|
||||
let (rh, wh) = clientToHandle child
|
||||
|
|
@ -404,8 +404,7 @@ (define-public ganeti
|
|||
"ganeti-drbd-compat.patch"
|
||||
"ganeti-os-disk-size.patch"
|
||||
"ganeti-haskell-pythondir.patch"
|
||||
"ganeti-disable-version-symlinks.patch"
|
||||
"ganeti-preserve-PYTHONPATH.patch"))))
|
||||
"ganeti-disable-version-symlinks.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:imported-modules (,@%gnu-build-system-modules
|
||||
|
|
Loading…
Reference in a new issue