mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-27 21:49:34 -05:00
gnu: orc: Update to 0.4.31.
* gnu/packages/patches/orc-typedef-enum.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gstreamer.scm (orc): Update to 0.4.31. [source](patches): Remove.
This commit is contained in:
parent
cb669c0951
commit
99732a8f22
3 changed files with 2 additions and 21 deletions
|
@ -1212,7 +1212,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||||
%D%/packages/patches/openssl-CVE-2019-1559.patch \
|
%D%/packages/patches/openssl-CVE-2019-1559.patch \
|
||||||
%D%/packages/patches/open-zwave-hidapi.patch \
|
%D%/packages/patches/open-zwave-hidapi.patch \
|
||||||
%D%/packages/patches/orc-typedef-enum.patch \
|
|
||||||
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
|
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||||
%D%/packages/patches/osip-CVE-2017-7853.patch \
|
%D%/packages/patches/osip-CVE-2017-7853.patch \
|
||||||
%D%/packages/patches/ots-no-include-missing-file.patch \
|
%D%/packages/patches/ots-no-include-missing-file.patch \
|
||||||
|
|
|
@ -69,15 +69,14 @@ (define-module (gnu packages gstreamer)
|
||||||
(define-public orc
|
(define-public orc
|
||||||
(package
|
(package
|
||||||
(name "orc")
|
(name "orc")
|
||||||
(version "0.4.30")
|
(version "0.4.31")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
|
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
|
||||||
"orc/orc-" version ".tar.xz"))
|
"orc/orc-" version ".tar.xz"))
|
||||||
(patches (search-patches "orc-typedef-enum.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
|
"0xb0c7q3xv1ldmz5ipybazb01gy3cijj8622dcx7rbm9lq85zax0"))))
|
||||||
(build-system meson-build-system)
|
(build-system meson-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
|
|
@ -1,17 +0,0 @@
|
||||||
Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
|
|
||||||
|
|
||||||
Taken from upstream:
|
|
||||||
https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
|
|
||||||
|
|
||||||
diff --git a/orc/orctarget.h b/orc/orctarget.h
|
|
||||||
--- a/orc/orctarget.h
|
|
||||||
+++ b/orc/orctarget.h
|
|
||||||
@@ -19,7 +19,7 @@ enum {
|
|
||||||
ORC_TARGET_FAST_DENORMAL = (1<<31)
|
|
||||||
};
|
|
||||||
|
|
||||||
-enum {
|
|
||||||
+typedef enum {
|
|
||||||
ORC_TARGET_POWERPC_64BIT = (1<<0),
|
|
||||||
ORC_TARGET_POWERPC_LE = (1<<1),
|
|
||||||
ORC_TARGET_POWERPC_ALTIVEC = (1<<2),
|
|
Loading…
Reference in a new issue