mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: qxlsx: Fix include directory.
* gnu/packages/qt.scm (qxlsx)[source]: Add patch. * gnu/packages/patches/qxlsx-fix-include-directory.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
800fef714c
commit
9bba3eb336
3 changed files with 27 additions and 1 deletions
|
@ -1721,6 +1721,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-wxwidgets-type-errors.patch \
|
||||
%D%/packages/patches/quodlibet-fix-invalid-glob.patch \
|
||||
%D%/packages/patches/quodlibet-fix-mtime-tests.patch \
|
||||
%D%/packages/patches/qxlsx-fix-include-directory.patch \
|
||||
%D%/packages/patches/scribus-1.5.8-poppler-22.03.0.patch \
|
||||
%D%/packages/patches/scribus-1.5.8-poppler-22.04.0.patch \
|
||||
%D%/packages/patches/scribus-1.5.8-poppler-22.09.0.patch \
|
||||
|
|
24
gnu/packages/patches/qxlsx-fix-include-directory.patch
Normal file
24
gnu/packages/patches/qxlsx-fix-include-directory.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 8c3e6633e3c901bc5a5cd477383421b0980dcd26 Mon Sep 17 00:00:00 2001
|
||||
From: Alexey Sokolov <sokolov@google.com>
|
||||
Date: Mon, 17 Apr 2023 23:43:59 +0100
|
||||
Subject: [PATCH] Fix #278
|
||||
|
||||
There's no real reason to install the same headers twice, but at least
|
||||
now clients of the library can build again
|
||||
---
|
||||
QXlsx/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/QXlsx/CMakeLists.txt b/QXlsx/CMakeLists.txt
|
||||
index 4fa7f7f1..074922a8 100644
|
||||
--- a/QXlsx/CMakeLists.txt
|
||||
+++ b/QXlsx/CMakeLists.txt
|
||||
@@ -179,7 +179,7 @@ PRIVATE
|
||||
${QXLSX_HEADERPATH}
|
||||
PUBLIC
|
||||
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/header>
|
||||
- $<INSTALL_INTERFACE:include/QXlsx>
|
||||
+ $<INSTALL_INTERFACE:include/QXlsxQt${QT_VERSION_MAJOR}>
|
||||
)
|
||||
|
||||
set_target_properties(QXlsx PROPERTIES
|
|
@ -1129,7 +1129,8 @@ (define-public qxlsx
|
|||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0xbpajvwkv09h2fang200nsanv5gl1alsdd725gh9cgq4szng6gj"))))
|
||||
(base32 "0xbpajvwkv09h2fang200nsanv5gl1alsdd725gh9cgq4szng6gj"))
|
||||
(patches (search-patches "qxlsx-fix-include-directory.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
(list
|
||||
|
|
Loading…
Reference in a new issue