gnu: krita: Fix build.

* gnu/packages/kde.scm (krita): Fix build.
[source]: Apply krita-bump-sip-abi-version-to-12.8 patch.
* gnu/packages/patches/krita-bump-sip-abi-version-to-12.8.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Change-Id: I322c32716a676af7c90e019b53a1fd5395701b49
Signed-off-by: Andreas Enge <andreas@enge.fr>
This commit is contained in:
Remco van 't Veer 2024-05-14 18:01:26 +02:00 committed by Andreas Enge
parent 8e5579f37c
commit 9d42741693
No known key found for this signature in database
GPG key ID: F7D5C9BF765C61E3
3 changed files with 31 additions and 3 deletions

View file

@ -48,7 +48,7 @@
# Copyright © 2021 Andrew Tropin <andrew@trop.in>
# Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
# Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
# Copyright © 2022 Remco van 't Veer <remco@remworks.net>
# Copyright © 2022, 2024 Remco van 't Veer <remco@remworks.net>
# Copyright © 2022, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
# Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
# Copyright © 2022 muradm <mail@muradm.net>
@ -1570,8 +1570,9 @@ dist_patch_DATA = \
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
%D%/packages/patches/kwin-unwrap-executable-name-for-dot-desktop-search.patch\
%D%/packages/patches/kodi-mesa-eglchromium.patch \
%D%/packages/patches/krita-bump-sip-abi-version-to-12.8.patch \
%D%/packages/patches/kwin-unwrap-executable-name-for-dot-desktop-search.patch\
%D%/packages/patches/laby-make-install.patch \
%D%/packages/patches/laby-use-tmpdir-from-runtime.patch \
%D%/packages/patches/ldns-drill-examples.patch \

View file

@ -18,6 +18,7 @@
;;; Copyright © 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Mehmet Tekman <mtekman89@gmail.com>
;;; Copyright © 2024 Remco van 't Veer <remco@remworks.net>
;;;
;;; This file is part of GNU Guix.
;;;
@ -726,7 +727,8 @@ (define-public krita
"mirror://kde/stable/krita/" version "/krita-" version
".tar.gz"))
(sha256
(base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))))
(base32 "1kzmn89b1vrasba7z8hp8izyrrskgc7ggnz82zqyyy1v5d8mnri7"))
(patches (search-patches "krita-bump-sip-abi-version-to-12.8.patch"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f

View file

@ -0,0 +1,25 @@
From 2d71c47661d43a4e3c1ab0c27803de980bdf2bb2 Mon Sep 17 00:00:00 2001
From: Antonio Rojas <arojas@archlinux.org>
Date: Mon, 11 Dec 2023 20:26:13 +0100
Subject: [PATCH] Bump SIP ABI version to 12.8
Fixes build with SIP 6.8
---
cmake/modules/pyproject.toml.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cmake/modules/pyproject.toml.in b/cmake/modules/pyproject.toml.in
index 090b2d4b0cb..085ddf41799 100644
--- a/cmake/modules/pyproject.toml.in
+++ b/cmake/modules/pyproject.toml.in
@@ -9,7 +9,7 @@ name = "@module_name_toml@"
sip-module = "@sip_name@"
sip-include-dirs = @sip_include_dirs@
sip-files-dir = "@module_srcs@"
-abi-version = "12"
+abi-version = "12.8"
[tool.sip.bindings.@module_name_toml@]
tags = @module_tags@
--
GitLab