gnu: Add gemrb-0.9.3.

* gnu/packages/games.scm (gemrb-0.9.3): New variable.
* gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Register patch.

Change-Id: Ic05eacf362f9a4ebfe88b1e0967e72e824c4f404
Signed-off-by: Andreas Enge <andreas@enge.fr>
This commit is contained in:
Ashvith Shetty 2024-09-15 13:23:44 +05:30 committed by Andreas Enge
parent 2fb4ce5110
commit 9d75215a59
No known key found for this signature in database
GPG key ID: F7D5C9BF765C61E3
3 changed files with 56 additions and 0 deletions

View file

@ -1367,6 +1367,7 @@ dist_patch_DATA = \
%D%/packages/patches/gdm-pass-gdk-pixbuf-loader-env.patch \
%D%/packages/patches/gemmi-fix-pegtl-usage.patch \
%D%/packages/patches/gemmi-fix-sajson-types.patch \
%D%/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch \
%D%/packages/patches/genimage-mke2fs-test.patch \
%D%/packages/patches/geoclue-config.patch \
%D%/packages/patches/gettext-libunicode-update.patch \

View file

@ -84,6 +84,7 @@
;;; Copyright © 2024 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@ -11805,6 +11806,45 @@ (define-public steam-devices-udev-rules
virtual reality devices.")
(license license:expat))))
(define-public gemrb
(package
(name "gemrb")
(version "0.9.3")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/gemrb/gemrb")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1wfmq4z2in18k4znshd7h1i496zlskbci49yp5d54mfxvyp534m5"))
;; Remove the patch in the next version, as commit d339c0d fixes this
(patches (search-patches
"gemrb-add-path-suffixes-for-vlc-headers.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags `("-DUSE_TESTS=ON" "-DOPENGL_BACKEND=OpenGL")))
(native-inputs (list python-3.10 glibc-locales googletest))
(inputs (list freetype
libiconv
libpng
libvorbis
openal
sdl2
sdl2-mixer
vlc
zlib))
(home-page "https://gemrb.org/")
(synopsis
"Portable open-source implementation of Bioware's Infinity Engine")
(description
"GemRB (Game Engine Made with preRendered Background) is a portable
open-source reimplementation of the Infinity Engine that underpinned
Baldur's Gate, Icewind Dale and Planescape: Torment. It sports a
cleaner design, greater extensibility and several innovations.")
(license (list license:gpl2))))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar

View file

@ -0,0 +1,15 @@
Add PATH_SUFFIXES to look inside the sub-directory `vlc` - the original statement
only check for `vlc.h` inside the directory `include`, `bin`, etc.
In Guix, however, `vlc.h` lies inside `/gnu/store/<hash>-vlc-x.y.z/include/vlc/vlc.h`
--- a/cmake/modules/FindLIBVLC.cmake
+++ b/cmake/modules/FindLIBVLC.cmake
@@ -29,7 +29,7 @@ FIND_PATH(LIBVLC_INCLUDE_DIR vlc/vlc.h
c:/msys/local/include
NO_DEFAULT_PATH
)
-FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h)
+FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h PATH_SUFFIXES vlc)
#Put here path to custom location
#example: /home/user/vlc/lib etc..