mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
gnu: coreutils: Update to 8.28.
* gnu/packages/base.scm (coreutils): Update to 8.28. [source]: Remove 'patches'. * gnu/packages/patches/coreutils-cut-huge-range-test.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
6dff905e51
commit
9f993702a6
3 changed files with 2 additions and 37 deletions
|
@ -559,7 +559,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/cool-retro-term-fix-array-size.patch \
|
||||
%D%/packages/patches/cool-retro-term-memory-leak-1.patch \
|
||||
%D%/packages/patches/cool-retro-term-remove-non-free-fonts.patch \
|
||||
%D%/packages/patches/coreutils-cut-huge-range-test.patch \
|
||||
%D%/packages/patches/cpio-CVE-2016-2037.patch \
|
||||
%D%/packages/patches/cpufrequtils-fix-aclocal.patch \
|
||||
%D%/packages/patches/cracklib-CVE-2016-6318.patch \
|
||||
|
|
|
@ -292,15 +292,14 @@ (define-public findutils
|
|||
(define-public coreutils
|
||||
(package
|
||||
(name "coreutils")
|
||||
(version "8.27")
|
||||
(version "8.28")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/coreutils/coreutils-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0sv547572iq8ayy8klir4hnngnx92a9nsazmf1wgzfc7xr4x74c8"))
|
||||
(patches (search-patches "coreutils-cut-huge-range-test.patch"))))
|
||||
"0r8c1bgm68kl70j1lgd0rv12iykw6143k4m9a56xip9rc2hv25qi"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
||||
("gmp" ,gmp) ;bignums in 'expr', yay!
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
This patch fixes 100% reproducible test failures on arm-linux-gnueabihf in our
|
||||
the build environment chroot, as reported at <https://bugs.gnu.org/26253>,
|
||||
and now on x86_64-linux-gnu as well. It is a variant of this upstream patch:
|
||||
|
||||
commit f5422009389678680dba9ff4ecb7d33632ee3383
|
||||
Author: Ludovic Courtès <ludo@gnu.org>
|
||||
Date: Mon Mar 27 20:34:39 2017 -0700
|
||||
|
||||
tests: avoid false ulimit failure on some systems
|
||||
|
||||
* tests/misc/cut-huge-range.sh: On some systems returns_ may
|
||||
use more memory, so incorporate that in the determination
|
||||
of the ulimit value to use. Noticed on ARMv7 with bash-4.4.12,
|
||||
and x86_64 with bash-4.2.37.
|
||||
Fixes http://bugs.gnu.org/26253
|
||||
|
||||
... which appeared to be insufficient.
|
||||
|
||||
diff --git a/tests/misc/cut-huge-range.sh b/tests/misc/cut-huge-range.sh
|
||||
index 6b3c5b6ed..55b7b640e 100755
|
||||
--- a/tests/misc/cut-huge-range.sh
|
||||
+++ b/tests/misc/cut-huge-range.sh
|
||||
@@ -20,9 +20,9 @@
|
||||
print_ver_ cut
|
||||
getlimits_
|
||||
|
||||
-vm=$(get_min_ulimit_v_ cut -b1 /dev/null) \
|
||||
+vm=$(get_min_ulimit_v_ sh -c 'cut -b1 /dev/null') \
|
||||
|| skip_ "this shell lacks ulimit support"
|
||||
vm=$(($vm + 1000)) # avoid spurious failures
|
||||
|
||||
# sed script to subtract one from the input.
|
||||
# Each input line should consist of a positive decimal number.
|
Loading…
Reference in a new issue