mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: coreutils: Update to 8.23.
* gnu/packages/patches/coreutils-skip-nohup.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove coreutils-skip-nohup.patch. * gnu/packages/patches/coreutils-dummy-man.patch: Adapt for 8.23. * gnu/packages/base.scm (coreutils): Update to 8.23.
This commit is contained in:
parent
8ceaf72c6d
commit
a092cd820b
4 changed files with 8 additions and 39 deletions
|
@ -288,7 +288,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/clucene-pkgconfig.patch \
|
gnu/packages/patches/clucene-pkgconfig.patch \
|
||||||
gnu/packages/patches/cmake-fix-tests.patch \
|
gnu/packages/patches/cmake-fix-tests.patch \
|
||||||
gnu/packages/patches/coreutils-dummy-man.patch \
|
gnu/packages/patches/coreutils-dummy-man.patch \
|
||||||
gnu/packages/patches/coreutils-skip-nohup.patch \
|
|
||||||
gnu/packages/patches/cpio-gets-undeclared.patch \
|
gnu/packages/patches/cpio-gets-undeclared.patch \
|
||||||
gnu/packages/patches/cssc-gets-undeclared.patch \
|
gnu/packages/patches/cssc-gets-undeclared.patch \
|
||||||
gnu/packages/patches/cssc-missing-include.patch \
|
gnu/packages/patches/cssc-missing-include.patch \
|
||||||
|
|
|
@ -233,17 +233,15 @@ (define-public findutils
|
||||||
(define-public coreutils
|
(define-public coreutils
|
||||||
(package
|
(package
|
||||||
(name "coreutils")
|
(name "coreutils")
|
||||||
(version "8.22")
|
(version "8.23")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/coreutils/coreutils-"
|
(uri (string-append "mirror://gnu/coreutils/coreutils-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"04hjzzv434fb8ak3hh3dyhdvg3hqjjwvjmjxqzk1gh2jh6cr8gjv"))
|
"0bdq6yggyl7nkc2pbl6pxhhyx15nyqhz3ds6rfn448n6rxdwlhzc"))
|
||||||
(patches (list (search-patch "coreutils-dummy-man.patch")
|
(patches (list (search-patch "coreutils-dummy-man.patch")))))
|
||||||
;; TODO: remove this patch for >= 8.23
|
|
||||||
(search-patch "coreutils-skip-nohup.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
(inputs `(("acl" ,acl) ; TODO: add SELinux
|
||||||
("gmp" ,gmp)))
|
("gmp" ,gmp)))
|
||||||
|
|
|
@ -7,15 +7,15 @@ would appear when compiling:
|
||||||
|
|
||||||
dummy-man: too many non-option arguments
|
dummy-man: too many non-option arguments
|
||||||
|
|
||||||
--- coreutils-8.22/Makefile.in 2013-12-13 16:20:00.000000000 +0100
|
--- coreutils-8.23/Makefile.in 2014-07-18 18:22:24.000000000 -0400
|
||||||
+++ coreutils-8.22/Makefile.in 2014-02-28 10:53:27.000000000 +0100
|
+++ coreutils-8.23/Makefile.in 2014-08-03 20:21:10.849158313 -0400
|
||||||
@@ -9977,8 +9977,8 @@ man/yes.1: src/yes
|
@@ -14076,8 +14076,8 @@
|
||||||
&& $(run_help2man) \
|
&& $(run_help2man) \
|
||||||
--source='$(PACKAGE_STRING)' \
|
--source='$(PACKAGE_STRING)' \
|
||||||
--include=$(srcdir)/man/$$name.x \
|
--include=$(srcdir)/man/$$name.x \
|
||||||
- --output=$$t/$$name.1 $$t/$$name \
|
- --output=$$t/$$name.1 $$t/$$argv \
|
||||||
--info-page='coreutils \(aq'$$name' invocation\(aq' \
|
--info-page='coreutils \(aq'$$name' invocation\(aq' \
|
||||||
+ --output=$$t/$$name.1 $$t/$$name \
|
+ --output=$$t/$$name.1 $$t/$$argv \
|
||||||
&& sed \
|
&& sed \
|
||||||
-e 's|$*\.td/||g' \
|
-e 's|$*\.td/||g' \
|
||||||
-e '/For complete documentation/d' \
|
-e '/For complete documentation/d' \
|
||||||
|
|
|
@ -1,28 +0,0 @@
|
||||||
commit 5dce6bdfafc930dfd17d5d16aea7d1add3472066
|
|
||||||
Author: Pádraig Brady <P@draigBrady.com>
|
|
||||||
Date: Wed Mar 5 15:14:07 2014 +0000
|
|
||||||
|
|
||||||
tests: fix false failure in nohup.sh in non tty builds
|
|
||||||
|
|
||||||
* tests/misc/nohup.sh: When running tests without a controlling tty,
|
|
||||||
an exec failure is triggered in a subshell, which causes POSIX
|
|
||||||
shells to immediately exit the subshell. This was brought
|
|
||||||
to notice by the newly conforming bash 4.3.
|
|
||||||
Fixes http:/bugs.gnu.org/16940
|
|
||||||
|
|
||||||
diff --git a/tests/misc/nohup.sh b/tests/misc/nohup.sh
|
|
||||||
index 6d2b515..2328b43 100755
|
|
||||||
--- a/tests/misc/nohup.sh
|
|
||||||
+++ b/tests/misc/nohup.sh
|
|
||||||
@@ -63,6 +63,11 @@ rm -f nohup.out err
|
|
||||||
# to stderr must be fatal. Requires stdout to be terminal.
|
|
||||||
if test -w /dev/full && test -c /dev/full; then
|
|
||||||
(
|
|
||||||
+ # POSIX shells immediately exit the subshell on exec error.
|
|
||||||
+ # So check we can write to /dev/tty before the exec, which
|
|
||||||
+ # isn't possible if we've no controlling tty for example.
|
|
||||||
+ test -c /dev/tty && >/dev/tty || exit 0
|
|
||||||
+
|
|
||||||
exec >/dev/tty
|
|
||||||
test -t 1 || exit 0
|
|
||||||
nohup echo hi 2> /dev/full
|
|
Loading…
Reference in a new issue