mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: netsurf: Update to 3.11.
* gnu/packages/web.scm (netsurf): Update to 3.11. [arguments]: Adjust to new source. Netsurf's JS engine cannot handle DuckDuckGo's redirect urls, so replace websearch form with post to DuckDuckGo Lite. (netsurf-buildsystem): Update to 1.10 (libparserutils): Update to 0.2.5. (hubbub): Update to 0.3.8. [source]: Remove hubbub-maybe-uninitialized.patch. (libcss): Update to 0.9.2. [source]: Remove snippet. Add patch for tests. (libdom): Update to 0.4.2. (libsvgtiny): Update to 0.1.8. (libnsbmp): Update to 0.1.7. (libnsgif): Update to 1.0.0. (libnsutils): Update to 0.1.1. (libnspsl): Update to 0.1.7. (nsgenbind): Update to 0.9. * gnu/packages/patches/netsurf-message-timestamp.patch: Adjust to latest source. * gnu/packages/patches/hubbub-maybe-uninitialized.patch: Delete patch. * gnu/packages/patches/libcss-check-format.patch: New patch. * gnu/local.mk (dist_patch_DATA): Adjust. Change-Id: I5834b0418270309aa30b6cd0a5a307e20c00fd4a
This commit is contained in:
parent
e51c26ef2d
commit
a10cce5246
5 changed files with 62 additions and 85 deletions
|
@ -1442,7 +1442,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/http-parser-CVE-2020-8287.patch \
|
%D%/packages/patches/http-parser-CVE-2020-8287.patch \
|
||||||
%D%/packages/patches/htslib-for-stringtie.patch \
|
%D%/packages/patches/htslib-for-stringtie.patch \
|
||||||
%D%/packages/patches/hubbub-sort-entities.patch \
|
%D%/packages/patches/hubbub-sort-entities.patch \
|
||||||
%D%/packages/patches/hubbub-maybe-uninitialized.patch \
|
|
||||||
%D%/packages/patches/hueplusplus-mbedtls.patch \
|
%D%/packages/patches/hueplusplus-mbedtls.patch \
|
||||||
%D%/packages/patches/hurd-add-without-rump-configure-option.patch \
|
%D%/packages/patches/hurd-add-without-rump-configure-option.patch \
|
||||||
%D%/packages/patches/hurd-fix-rumpdisk-build.patch \
|
%D%/packages/patches/hurd-fix-rumpdisk-build.patch \
|
||||||
|
@ -1512,6 +1511,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
||||||
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
|
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
|
||||||
%D%/packages/patches/julia-Use-MPFR-4.2.patch \
|
%D%/packages/patches/julia-Use-MPFR-4.2.patch \
|
||||||
|
%D%/packages/patches/libcss-check-format.patch \
|
||||||
%D%/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch \
|
%D%/packages/patches/libftdi-fix-paths-when-FTDIPP-set.patch \
|
||||||
%D%/packages/patches/libgeotiff-fix-tests-with-proj-9.1.1.patch \
|
%D%/packages/patches/libgeotiff-fix-tests-with-proj-9.1.1.patch \
|
||||||
%D%/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch \
|
%D%/packages/patches/libgeotiff-fix-tests-with-proj-9.3.0.patch \
|
||||||
|
|
|
@ -1,40 +0,0 @@
|
||||||
From 69d81a8a4d4c223aad67cde0fdf64d64351b9802 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Andy Tai <atai@atai.org>
|
|
||||||
Date: Sat, 27 May 2023 00:01:34 -0700
|
|
||||||
Subject: [PATCH] prevent -Werror=maybe-uninitialized build failure with gcc 11
|
|
||||||
when building tests tokeniser2 and tokeniser3
|
|
||||||
|
|
||||||
---
|
|
||||||
test/tokeniser2.c | 2 +-
|
|
||||||
test/tokeniser3.c | 2 +-
|
|
||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/test/tokeniser2.c b/test/tokeniser2.c
|
|
||||||
index c8ab9c0..4caae38 100644
|
|
||||||
--- a/test/tokeniser2.c
|
|
||||||
+++ b/test/tokeniser2.c
|
|
||||||
@@ -438,7 +438,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
|
|
||||||
/* Expected token only contained part of the data
|
|
||||||
* Calculate how much is left, then try again with
|
|
||||||
* the next expected token */
|
|
||||||
- hubbub_token t;
|
|
||||||
+ hubbub_token t = { 0 };
|
|
||||||
|
|
||||||
t.type = HUBBUB_TOKEN_CHARACTER;
|
|
||||||
t.data.character.ptr += len;
|
|
||||||
diff --git a/test/tokeniser3.c b/test/tokeniser3.c
|
|
||||||
index e33d018..b3be901 100644
|
|
||||||
--- a/test/tokeniser3.c
|
|
||||||
+++ b/test/tokeniser3.c
|
|
||||||
@@ -447,7 +447,7 @@ hubbub_error token_handler(const hubbub_token *token, void *pw)
|
|
||||||
/* Expected token only contained part of the data
|
|
||||||
* Calculate how much is left, then try again with
|
|
||||||
* the next expected token */
|
|
||||||
- hubbub_token t;
|
|
||||||
+ hubbub_token t = { 0 };
|
|
||||||
|
|
||||||
t.type = HUBBUB_TOKEN_CHARACTER;
|
|
||||||
t.data.character.ptr += len;
|
|
||||||
--
|
|
||||||
2.40.1
|
|
||||||
|
|
13
gnu/packages/patches/libcss-check-format.patch
Normal file
13
gnu/packages/patches/libcss-check-format.patch
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
Submitted upstream at https://bugs.netsurf-browser.org/mantis/view.php?id=2870
|
||||||
|
|
||||||
|
--- libcss-0.9.2/test/dump.h.orig
|
||||||
|
+++ libcss-0.9.2/test/dump.h
|
||||||
|
@@ -131,7 +131,7 @@ void dump_rule_media(css_rule_media *s, char **buf, size_t *buflen)
|
||||||
|
char *ptr = *buf;
|
||||||
|
css_rule *rule;
|
||||||
|
|
||||||
|
- ptr += sprintf(ptr, "| @media %s%03lx",
|
||||||
|
+ ptr += sprintf(ptr, "| @media %s%03" PRIx64,
|
||||||
|
s->media->negate_type ? "not " : "",
|
||||||
|
s->media->type);
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
--- netsurf-3.8/utils/split-messages.pl.orig 1969-12-31 18:00:00.000000000 -0600
|
--- netsurf-3.11/tools/split-messages.pl.orig
|
||||||
+++ netsurf-3.8/utils/split-messages.pl 2018-08-30 00:18:58.158367530 -0500
|
+++ netsurf-3.11/tools/split-messages.pl
|
||||||
@@ -238,7 +238,7 @@
|
@@ -238,7 +238,7 @@
|
||||||
|
|
||||||
if( $opt{gzip} )
|
if( $opt{gzip} )
|
||||||
|
|
|
@ -6,7 +6,7 @@
|
||||||
;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
|
||||||
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
|
;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
|
||||||
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
|
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
|
||||||
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
|
;;; Copyright © 2015-2020, 2024 Eric Bavier <bavier@posteo.net>
|
||||||
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
|
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
|
||||||
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
|
;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
|
||||||
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
|
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
|
||||||
|
@ -5459,7 +5459,7 @@ (define-public woof
|
||||||
(define netsurf-buildsystem
|
(define netsurf-buildsystem
|
||||||
(package
|
(package
|
||||||
(name "netsurf-buildsystem")
|
(name "netsurf-buildsystem")
|
||||||
(version "1.9")
|
(version "1.10")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5467,7 +5467,7 @@ (define netsurf-buildsystem
|
||||||
"buildsystem-" version ".tar.gz"))
|
"buildsystem-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0alsmaig9ln8dgllb3z63gq90fiz75jz0ic71fi0k0k898qix14k"))))
|
"0yadmrpgvl9r08b56qiy5f77jracc7g9n4krn727fip4d7akjgix"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("perl" ,perl)))
|
(inputs `(("perl" ,perl)))
|
||||||
(arguments
|
(arguments
|
||||||
|
@ -5498,7 +5498,7 @@ (define netsurf-buildsystem-arguments
|
||||||
(define-public libparserutils
|
(define-public libparserutils
|
||||||
(package
|
(package
|
||||||
(name "libparserutils")
|
(name "libparserutils")
|
||||||
(version "0.2.4")
|
(version "0.2.5")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5506,7 +5506,7 @@ (define-public libparserutils
|
||||||
name "-" version "-src.tar.gz"))
|
name "-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1n2794y2l0c8nv8z2pxwfnbn882987ifmxjv60zdxkhcndhswarj"))))
|
"0ffi5q1jlcdl66nk3cax0mnzvhrjvvjvlx0rfasjfygi333xazii"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem pkg-config perl)) ;for test harness
|
(list netsurf-buildsystem pkg-config perl)) ;for test harness
|
||||||
|
@ -5521,7 +5521,7 @@ (define-public libparserutils
|
||||||
(define-public hubbub
|
(define-public hubbub
|
||||||
(package
|
(package
|
||||||
(name "hubbub")
|
(name "hubbub")
|
||||||
(version "0.3.7")
|
(version "0.3.8")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5529,15 +5529,14 @@ (define-public hubbub
|
||||||
"libhubbub-" version "-src.tar.gz"))
|
"libhubbub-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1dimfyblmym98qa1b80c5jslv2zk8r44xbdrgrsrw1n9wr9y4yly"))
|
"19fm5h8arnsgxd4w5vr9s2fcb422acciffar3la0b36lygsydhca"))
|
||||||
(patches (search-patches
|
(patches (search-patches "hubbub-sort-entities.patch"))))
|
||||||
"hubbub-sort-entities.patch"
|
|
||||||
"hubbub-maybe-uninitialized.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem
|
(list netsurf-buildsystem
|
||||||
pkg-config
|
pkg-config
|
||||||
doxygen
|
doxygen
|
||||||
|
gperf
|
||||||
json-c-0.12 ; check whether json-c-0.12 can be removed
|
json-c-0.12 ; check whether json-c-0.12 can be removed
|
||||||
perl))
|
perl))
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
|
@ -5705,7 +5704,7 @@ (define-public libwapcaplet
|
||||||
(define-public libcss
|
(define-public libcss
|
||||||
(package
|
(package
|
||||||
(name "libcss")
|
(name "libcss")
|
||||||
(version "0.9.1")
|
(version "0.9.2")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5713,13 +5712,8 @@ (define-public libcss
|
||||||
"libcss-" version "-src.tar.gz"))
|
"libcss-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))
|
"0khmf5bdpkc09fpsgwzi23sihpadvyr02jx0q5h1vm9lxjxibwid"))
|
||||||
(modules '((guix build utils)))
|
(patches (search-patches "libcss-check-format.patch"))))
|
||||||
(snippet
|
|
||||||
'(begin
|
|
||||||
;; This can be removed with the next release.
|
|
||||||
(substitute* "src/select/computed.c"
|
|
||||||
(("css_unit unit;") "css_unit unit = CSS_UNIT_PX;"))))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem pkg-config perl))
|
(list netsurf-buildsystem pkg-config perl))
|
||||||
|
@ -5736,7 +5730,7 @@ (define-public libcss
|
||||||
(define-public libdom
|
(define-public libdom
|
||||||
(package
|
(package
|
||||||
(name "libdom")
|
(name "libdom")
|
||||||
(version "0.4.1")
|
(version "0.4.2") ;TODO include patch for additional tags?
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5744,7 +5738,7 @@ (define-public libdom
|
||||||
"libdom-" version "-src.tar.gz"))
|
"libdom-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0jpg5hx3y0mdxk5szd47dyijqimd2321brbqk2620pp5f4j0gvlq"))))
|
"0g0gqcglk8f8gbygbcq5ylcx84zsf0vczbm3n3118w2l2splapnh"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem
|
(list netsurf-buildsystem
|
||||||
|
@ -5771,7 +5765,7 @@ (define-public libdom
|
||||||
(define-public libsvgtiny
|
(define-public libsvgtiny
|
||||||
(package
|
(package
|
||||||
(name "libsvgtiny")
|
(name "libsvgtiny")
|
||||||
(version "0.1.7")
|
(version "0.1.8")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5779,7 +5773,7 @@ (define-public libsvgtiny
|
||||||
name "-" version "-src.tar.gz"))
|
name "-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"10bpkmvfpydj74im3r6kqm9vnvgib6afy0alx71q5n0w5yawy39c"))))
|
"0750q884ax8wygl64wq03zdjj8h838ch3f8jdfkv4gz809zj4my3"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem pkg-config gperf-3.0))
|
(list netsurf-buildsystem pkg-config gperf-3.0))
|
||||||
|
@ -5800,7 +5794,7 @@ (define-public libsvgtiny
|
||||||
(define-public libnsbmp
|
(define-public libnsbmp
|
||||||
(package
|
(package
|
||||||
(name "libnsbmp")
|
(name "libnsbmp")
|
||||||
(version "0.1.6")
|
(version "0.1.7")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5808,7 +5802,7 @@ (define-public libnsbmp
|
||||||
name "-" version "-src.tar.gz"))
|
name "-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0krjg69a2amxjsahdgm3wmy9ngnyr3gfs2a1zhdlbvb0z1jr7i3r"))))
|
"14r2v1ich4lxn3sdwpiwq5adydrd1qlhbd8mbamalaqj59laf1sl"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem))
|
(list netsurf-buildsystem))
|
||||||
|
@ -5856,7 +5850,7 @@ (define-public libnsfb
|
||||||
(define-public libnsgif
|
(define-public libnsgif
|
||||||
(package
|
(package
|
||||||
(name "libnsgif")
|
(name "libnsgif")
|
||||||
(version "0.2.1")
|
(version "1.0.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5864,7 +5858,7 @@ (define-public libnsgif
|
||||||
name "-" version "-src.tar.gz"))
|
name "-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0jwshypgmx16xlsbx3d8njk8a5khazlplca5mxd3rdbhrlsabbly"))))
|
"06q69hn0nz3c6hnwmzfcldyrppkvimx3s97ql3sx4m0lyr1ch530"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem))
|
(list netsurf-buildsystem))
|
||||||
|
@ -5907,7 +5901,7 @@ (define-public libnslog
|
||||||
(define-public libnsutils
|
(define-public libnsutils
|
||||||
(package
|
(package
|
||||||
(name "libnsutils")
|
(name "libnsutils")
|
||||||
(version "0.1.0")
|
(version "0.1.1")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5915,7 +5909,7 @@ (define-public libnsutils
|
||||||
name "-" version "-src.tar.gz"))
|
name "-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1w5fyy2i60a3v3if3iqcn9sy9sycx6966rcx53v85gja6hb6a33r"))))
|
"14pakllwf7a205d0dkvyg8jhmqfbi5sh5riw840d13j5dr9b952n"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem))
|
(list netsurf-buildsystem))
|
||||||
|
@ -5930,7 +5924,7 @@ (define-public libnsutils
|
||||||
(define-public libnspsl
|
(define-public libnspsl
|
||||||
(package
|
(package
|
||||||
(name "libnspsl")
|
(name "libnspsl")
|
||||||
(version "0.1.6")
|
(version "0.1.7")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5938,7 +5932,7 @@ (define-public libnspsl
|
||||||
"libnspsl-" version "-src.tar.gz"))
|
"libnspsl-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"02q28n5i6fwqcz1nn167rb71k1q95mx38mfah6zi1lvqrc2q5ifk"))))
|
"105cjkb622wz11z26il4j1n4ydyrrgv0nglr67aawpam5z1wx11n"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem))
|
(list netsurf-buildsystem))
|
||||||
|
@ -5953,7 +5947,7 @@ (define-public libnspsl
|
||||||
(define-public nsgenbind
|
(define-public nsgenbind
|
||||||
(package
|
(package
|
||||||
(name "nsgenbind")
|
(name "nsgenbind")
|
||||||
(version "0.8")
|
(version "0.9")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5961,7 +5955,7 @@ (define-public nsgenbind
|
||||||
"nsgenbind-" version "-src.tar.gz"))
|
"nsgenbind-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1cqwgwca49jvmijwiyaab2bwxicgxdrnlpinf8kp3nha02nm73ad"))))
|
"0p9q9ffn9hf1qrphz2qxq2xvyysn5kg2dbl8cbnkwb5wdkvf0b13"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
(list netsurf-buildsystem bison flex))
|
(list netsurf-buildsystem bison flex))
|
||||||
|
@ -5979,7 +5973,7 @@ (define-public nsgenbind
|
||||||
(define-public netsurf
|
(define-public netsurf
|
||||||
(package
|
(package
|
||||||
(name "netsurf")
|
(name "netsurf")
|
||||||
(version "3.10")
|
(version "3.11")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -5987,7 +5981,7 @@ (define-public netsurf
|
||||||
"releases/source/netsurf-" version "-src.tar.gz"))
|
"releases/source/netsurf-" version "-src.tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0plra64c5xyiw12yx2q13brxsv8apmany97zqa2lcqckw4ll8j1n"))
|
"1chw40nx7krpy7m14bajfrcj88h98if8py0k7c2qshpfxxm652n2"))
|
||||||
(patches (search-patches "netsurf-system-utf8proc.patch"
|
(patches (search-patches "netsurf-system-utf8proc.patch"
|
||||||
"netsurf-y2038-tests.patch"
|
"netsurf-y2038-tests.patch"
|
||||||
"netsurf-longer-test-timeout.patch"
|
"netsurf-longer-test-timeout.patch"
|
||||||
|
@ -6038,22 +6032,17 @@ (define-public netsurf
|
||||||
(add-after 'unpack 'remove-timestamps
|
(add-after 'unpack 'remove-timestamps
|
||||||
;; Avoid embedding timestamp for reproducible builds
|
;; Avoid embedding timestamp for reproducible builds
|
||||||
(lambda _
|
(lambda _
|
||||||
(substitute* "utils/git-testament.pl"
|
(substitute* "tools/git-testament.pl"
|
||||||
(("WT_COMPILEDATE ..$compiledate")
|
(("WT_COMPILEDATE ..$compiledate")
|
||||||
"WT_COMPILEDATE \\\""))))
|
"WT_COMPILEDATE \\\""))))
|
||||||
(add-after 'build 'adjust-welcome
|
(add-after 'build 'adjust-welcome
|
||||||
(lambda _
|
(lambda _
|
||||||
(substitute* "frontends/gtk/res/welcome.html"
|
(substitute* "frontends/gtk/res/welcome.html"
|
||||||
;; Close some XHTML tags.
|
;; Close some XHTML tags.
|
||||||
(("<(img|input)([^>]*)>" _ tag contents)
|
(("<(img|input)([^>]*)>" _ tag contents)
|
||||||
(string-append "<" tag contents " />"))
|
(string-append "<" tag contents " />"))
|
||||||
;; Increase freedom.
|
;; Increase freedom.
|
||||||
((" open source") ", free software")
|
((" open source") ", free software"))
|
||||||
;; Prefer a more privacy-respecting default search engine.
|
|
||||||
(("www.google.co.uk") "www.duckduckgo.com/html")
|
|
||||||
(("Google Search") "DuckDuckGo Search")
|
|
||||||
(("name=\"btnG\"") ""))
|
|
||||||
;; Remove default links so it doesn't seem we're endorsing them.
|
|
||||||
(with-atomic-file-replacement "frontends/gtk/res/welcome.html"
|
(with-atomic-file-replacement "frontends/gtk/res/welcome.html"
|
||||||
(lambda (in out)
|
(lambda (in out)
|
||||||
;; Leave the DOCTYPE header as is.
|
;; Leave the DOCTYPE header as is.
|
||||||
|
@ -6068,8 +6057,23 @@ (define-public netsurf
|
||||||
;; We'd like to use sxml-match here, but it can't
|
;; We'd like to use sxml-match here, but it can't
|
||||||
;; match against generic tag symbols...
|
;; match against generic tag symbols...
|
||||||
(match sxml
|
(match sxml
|
||||||
|
;; Remove default links so it doesn't seem we're
|
||||||
|
;; endorsing them.
|
||||||
(`(div (@ (class "links")) . ,rest)
|
(`(div (@ (class "links")) . ,rest)
|
||||||
'())
|
'())
|
||||||
|
;; Prefer a more privacy-respecting default search
|
||||||
|
;; engine.
|
||||||
|
(`(form . ,rest)
|
||||||
|
`(form (@ (action "https://lite.duckduckgo.com/lite/")
|
||||||
|
(method "post"))
|
||||||
|
(div (@ (class "websearch"))
|
||||||
|
(input (@ (type "text")
|
||||||
|
(size "42")
|
||||||
|
(name "q")
|
||||||
|
(autocomplete "off")
|
||||||
|
(value "")))
|
||||||
|
(input (@ (type "submit")
|
||||||
|
(value "DuckDuckGo Search"))))))
|
||||||
(`(ENTITY ,ent)
|
(`(ENTITY ,ent)
|
||||||
`(*ENTITY* ,ent))
|
`(*ENTITY* ,ent))
|
||||||
((x ...)
|
((x ...)
|
||||||
|
|
Loading…
Reference in a new issue