gnu: orc: Fix broken header file.

* gnu/packages/patches/orc-typedef-enum.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/gstreamer.scm (orc)[source](patches): New field.
This commit is contained in:
Marius Bakke 2019-10-15 18:18:38 +02:00
parent c436261312
commit a1d1703a1d
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 19 additions and 0 deletions

View file

@ -1181,6 +1181,7 @@ dist_patch_DATA = \
%D%/packages/patches/openssl-c-rehash-in.patch \
%D%/packages/patches/openssl-CVE-2019-1559.patch \
%D%/packages/patches/open-zwave-hidapi.patch \
%D%/packages/patches/orc-typedef-enum.patch \
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
%D%/packages/patches/osip-CVE-2017-7853.patch \
%D%/packages/patches/ots-no-include-missing-file.patch \

View file

@ -74,6 +74,7 @@ (define-public orc
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
"orc/orc-" version ".tar.xz"))
(patches (search-patches "orc-typedef-enum.patch"))
(sha256
(base32
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))

View file

@ -0,0 +1,17 @@
Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
Taken from upstream:
https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
diff --git a/orc/orctarget.h b/orc/orctarget.h
--- a/orc/orctarget.h
+++ b/orc/orctarget.h
@@ -19,7 +19,7 @@ enum {
ORC_TARGET_FAST_DENORMAL = (1<<31)
};
-enum {
+typedef enum {
ORC_TARGET_POWERPC_64BIT = (1<<0),
ORC_TARGET_POWERPC_LE = (1<<1),
ORC_TARGET_POWERPC_ALTIVEC = (1<<2),