mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: orc: Fix broken header file.
* gnu/packages/patches/orc-typedef-enum.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gstreamer.scm (orc)[source](patches): New field.
This commit is contained in:
parent
c436261312
commit
a1d1703a1d
3 changed files with 19 additions and 0 deletions
|
@ -1181,6 +1181,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||||
%D%/packages/patches/openssl-CVE-2019-1559.patch \
|
%D%/packages/patches/openssl-CVE-2019-1559.patch \
|
||||||
%D%/packages/patches/open-zwave-hidapi.patch \
|
%D%/packages/patches/open-zwave-hidapi.patch \
|
||||||
|
%D%/packages/patches/orc-typedef-enum.patch \
|
||||||
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
|
%D%/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||||
%D%/packages/patches/osip-CVE-2017-7853.patch \
|
%D%/packages/patches/osip-CVE-2017-7853.patch \
|
||||||
%D%/packages/patches/ots-no-include-missing-file.patch \
|
%D%/packages/patches/ots-no-include-missing-file.patch \
|
||||||
|
|
|
@ -74,6 +74,7 @@ (define-public orc
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
|
(uri (string-append "https://gstreamer.freedesktop.org/data/src/"
|
||||||
"orc/orc-" version ".tar.xz"))
|
"orc/orc-" version ".tar.xz"))
|
||||||
|
(patches (search-patches "orc-typedef-enum.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
|
"0wj93im7i8a6546q2r8sp39yjfbxflkc0ygb0b8iqsd58qhvjhds"))))
|
||||||
|
|
17
gnu/packages/patches/orc-typedef-enum.patch
Normal file
17
gnu/packages/patches/orc-typedef-enum.patch
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
Orc 0.4.30 has a bug that causes duplicate symbols due to a missing typedef.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://gitlab.freedesktop.org/gstreamer/orc/merge_requests/32
|
||||||
|
|
||||||
|
diff --git a/orc/orctarget.h b/orc/orctarget.h
|
||||||
|
--- a/orc/orctarget.h
|
||||||
|
+++ b/orc/orctarget.h
|
||||||
|
@@ -19,7 +19,7 @@ enum {
|
||||||
|
ORC_TARGET_FAST_DENORMAL = (1<<31)
|
||||||
|
};
|
||||||
|
|
||||||
|
-enum {
|
||||||
|
+typedef enum {
|
||||||
|
ORC_TARGET_POWERPC_64BIT = (1<<0),
|
||||||
|
ORC_TARGET_POWERPC_LE = (1<<1),
|
||||||
|
ORC_TARGET_POWERPC_ALTIVEC = (1<<2),
|
Loading…
Reference in a new issue