mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: python2-cython: Fix build on 32-bit platforms.
* gnu/packages/python.scm (python-cython, python2-cython)[source]: Add patch. * gnu/packages/patches/python-cython-fix-tests-32bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
6beaa5a02a
commit
a3dea99107
3 changed files with 29 additions and 0 deletions
|
@ -878,6 +878,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||
%D%/packages/patches/python-statsmodels-fix-tests.patch \
|
||||
%D%/packages/patches/python-configobj-setuptools.patch \
|
||||
%D%/packages/patches/python-cython-fix-tests-32bit.patch \
|
||||
%D%/packages/patches/python-fake-factory-fix-build-32bit.patch \
|
||||
%D%/packages/patches/python-faker-fix-build-32bit.patch \
|
||||
%D%/packages/patches/python-pandas-skip-failing-tests.patch \
|
||||
|
|
27
gnu/packages/patches/python-cython-fix-tests-32bit.patch
Normal file
27
gnu/packages/patches/python-cython-fix-tests-32bit.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
This fixes a test failure on 32-bit platforms.
|
||||
|
||||
Upstream bug URL: https://github.com/cython/cython/issues/1548
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
https://github.com/cython/cython/commit/d92a718a26c9354fbf35f31a17de5c069865a447
|
||||
|
||||
From d92a718a26c9354fbf35f31a17de5c069865a447 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Bradshaw <robertwb@gmail.com>
|
||||
Date: Tue, 24 Jan 2017 16:57:00 -0800
|
||||
Subject: [PATCH] Normalize possible L suffix.
|
||||
|
||||
---
|
||||
tests/run/cpdef_enums.pyx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/run/cpdef_enums.pyx b/tests/run/cpdef_enums.pyx
|
||||
index 167c762..c264ec5 100644
|
||||
--- a/tests/run/cpdef_enums.pyx
|
||||
+++ b/tests/run/cpdef_enums.pyx
|
||||
@@ -93,4 +93,4 @@ def verify_resolution_GH1533():
|
||||
3
|
||||
"""
|
||||
THREE = 100
|
||||
- return PyxEnum.THREE
|
||||
+ return int(PyxEnum.THREE)
|
|
@ -3406,6 +3406,7 @@ (define-public python-cython
|
|||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "Cython" version))
|
||||
(patches (search-patches "python-cython-fix-tests-32bit.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"01h3lrf6d98j07iakifi81qjszh6faa37ibx7ylva1vsqbwx2hgi"))))
|
||||
|
|
Loading…
Reference in a new issue