mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
gnu: mesa: Fix sporadic test failures.
* gnu/packages/patches/mesa-fix-sporadic-test-failures.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gl.scm (mesa)[source]: Apply it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
be41d82d19
commit
a56eafd28b
3 changed files with 31 additions and 1 deletions
|
@ -1526,6 +1526,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mercurial-hg-extension-path.patch \
|
||||
%D%/packages/patches/mercurial-openssl-compat.patch \
|
||||
%D%/packages/patches/mesa-opencl-all-targets.patch \
|
||||
%D%/packages/patches/mesa-fix-sporadic-test-failures.patch \
|
||||
%D%/packages/patches/meson-allow-dirs-outside-of-prefix.patch \
|
||||
%D%/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
%D%/packages/patches/mia-fix-boost-headers.patch \
|
||||
|
|
|
@ -278,7 +278,9 @@ (define-public mesa
|
|||
version "/mesa-" version ".tar.xz")))
|
||||
(sha256
|
||||
(base32
|
||||
"1azpr68pdg63yq3igmzwsgn2ypg49m0mp3hfkq0lcyswr99npmv5"))))
|
||||
"1azpr68pdg63yq3igmzwsgn2ypg49m0mp3hfkq0lcyswr99npmv5"))
|
||||
(patches
|
||||
(list (search-patch "mesa-fix-sporadic-test-failures.patch")))))
|
||||
(build-system meson-build-system)
|
||||
(propagated-inputs
|
||||
;; The following are in the Requires.private field of gl.pc.
|
||||
|
|
27
gnu/packages/patches/mesa-fix-sporadic-test-failures.patch
Normal file
27
gnu/packages/patches/mesa-fix-sporadic-test-failures.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
commit 7749599d737d205a88bbb6fa755ba095d9b581fa
|
||||
Author: Gert Wollny <gert.wollny@collabora.com>
|
||||
Date: Mon Aug 15 17:15:43 2022 +0200
|
||||
|
||||
r600/sfn: Initialize out buffer when printing op
|
||||
|
||||
79ca456b4837b3bc21cf9ef3c03c505c4b4909f6
|
||||
r600/sfn: rewrite NIR backend
|
||||
|
||||
Closes: #7021
|
||||
|
||||
Signed-off-by: Gert Wollny <gert.wollny@collabora.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/18130>
|
||||
|
||||
diff --git a/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp b/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
|
||||
index 3d40ea1796a..00826ed6457 100644
|
||||
--- a/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
|
||||
+++ b/src/gallium/drivers/r600/sfn/sfn_instr_export.cpp
|
||||
@@ -206,7 +206,7 @@ bool WriteScratchInstr::do_ready() const
|
||||
|
||||
void WriteScratchInstr::do_print(std::ostream& os) const
|
||||
{
|
||||
- char buf[6];
|
||||
+ char buf[6] = {0};
|
||||
|
||||
os << "WRITE_SCRATCH ";
|
||||
if (m_address)
|
Loading…
Reference in a new issue