mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 13:28:12 -05:00
gnu: kio: Search 'smbd' on $PATH.
Transfer the remaining NixOS patch for kio as of 2018-02-17. * gnu/packages/patches/kio-search-smbd-on-PATH.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm(kio)<source>: Use it.
This commit is contained in:
parent
8791aa98a7
commit
a6e532815d
3 changed files with 34 additions and 3 deletions
|
@ -855,6 +855,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/kiki-makefile.patch \
|
||||
%D%/packages/patches/kiki-missing-includes.patch \
|
||||
%D%/packages/patches/kiki-portability-64bit.patch \
|
||||
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
|
||||
%D%/packages/patches/kmod-module-directory.patch \
|
||||
%D%/packages/patches/kobodeluxe-paths.patch \
|
||||
%D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch \
|
||||
|
|
|
@ -2573,7 +2573,8 @@ (define-public kio
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0rrsg3g1b204cdp58vxd5dig1ggwyvk1382p1c86vn6w8qbrq27k"))))
|
||||
"0rrsg3g1b204cdp58vxd5dig1ggwyvk1382p1c86vn6w8qbrq27k"))
|
||||
(patches (search-patches "kio-search-smbd-on-PATH.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(propagated-inputs
|
||||
`(("kbookmarks" ,kbookmarks)
|
||||
|
@ -2616,11 +2617,10 @@ (define-public kio
|
|||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'patch
|
||||
(lambda _
|
||||
;; Better error message (taken from nix)
|
||||
;; Better error message (taken from NixOS)
|
||||
(substitute* "src/kiod/kiod_main.cpp"
|
||||
(("(^\\s*qCWarning(KIOD_CATEGORY) << \"Error loading plugin:\")( << loader.errorString();)" _ a b)
|
||||
(string-append a "<< name" b)))
|
||||
;; TODO: samba-search-path.patch from nix: search smbd on $PATH
|
||||
#t))
|
||||
(add-before 'check 'check-setup
|
||||
(lambda _
|
||||
|
|
30
gnu/packages/patches/kio-search-smbd-on-PATH.patch
Normal file
30
gnu/packages/patches/kio-search-smbd-on-PATH.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
Adopted from NixOS
|
||||
pkgs/development/libraries/kde-frameworks/kio/samba-search-path.patch
|
||||
|
||||
===================================================================
|
||||
--- kio-5.17.0.orig/src/core/ksambashare.cpp
|
||||
+++ kio-5.17.0/src/core/ksambashare.cpp
|
||||
@@ -67,13 +67,18 @@ KSambaSharePrivate::~KSambaSharePrivate(
|
||||
|
||||
bool KSambaSharePrivate::isSambaInstalled()
|
||||
{
|
||||
- if (QFile::exists(QStringLiteral("/usr/sbin/smbd"))
|
||||
- || QFile::exists(QStringLiteral("/usr/local/sbin/smbd"))) {
|
||||
- return true;
|
||||
+ const QByteArray pathEnv = qgetenv("PATH");
|
||||
+ if (!pathEnv.isEmpty()) {
|
||||
+ QLatin1Char pathSep(':');
|
||||
+ QStringList paths = QFile::decodeName(pathEnv).split(pathSep, QString::SkipEmptyParts);
|
||||
+ for (QStringList::iterator it = paths.begin(); it != paths.end(); ++it) {
|
||||
+ it->append("/smbd");
|
||||
+ if (QFile::exists(*it)) {
|
||||
+ return true;
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
|
||||
- //qDebug() << "Samba is not installed!";
|
||||
-
|
||||
return false;
|
||||
}
|
||||
|
Loading…
Reference in a new issue