mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: guile: Fix tests on emulated architectures.
The stack overflow test limits the virtual memory size using setrlimit with RLIMIT_AS argument. This is ignored when using QEMU transparent emulation, causing the test to crash. * gnu/packages/patches/guile-2.2-skip-so-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/guile.scm (guile-2.2): Add it.
This commit is contained in:
parent
31ebecf73d
commit
a8650a70ab
3 changed files with 26 additions and 1 deletions
|
@ -1123,6 +1123,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-so-test.patch \
|
||||
%D%/packages/patches/guile-default-utf8.patch \
|
||||
%D%/packages/patches/guile-2.2-default-utf8.patch \
|
||||
%D%/packages/patches/guile-relocatable.patch \
|
||||
|
|
|
@ -245,7 +245,8 @@ (define-public guile-2.2
|
|||
"013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))
|
||||
(modules '((guix build utils)))
|
||||
(patches (search-patches
|
||||
"guile-2.2-skip-oom-test.patch"))
|
||||
"guile-2.2-skip-oom-test.patch"
|
||||
"guile-2.2-skip-so-test.patch"))
|
||||
|
||||
;; Remove the pre-built object files. Instead, build everything
|
||||
;; from source, at the expense of significantly longer build
|
||||
|
|
23
gnu/packages/patches/guile-2.2-skip-so-test.patch
Normal file
23
gnu/packages/patches/guile-2.2-skip-so-test.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
Skip 'test-stack-overflow' that crashes when using QEMU transparent emulation.
|
||||
|
||||
--- a/test-suite/standalone/Makefile.in 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ b/test-suite/standalone/Makefile.in 2021-01-11 10:59:31.606269449 +0100
|
||||
@@ -102,8 +102,7 @@
|
||||
test-scm-to-latin1-string$(EXEEXT) test-scm-values$(EXEEXT) \
|
||||
test-scm-c-bind-keyword-arguments$(EXEEXT) \
|
||||
test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
|
||||
- test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
|
||||
- test-stack-overflow
|
||||
+ test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT)
|
||||
check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
|
||||
test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
|
||||
test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
|
||||
@@ -1938,7 +1937,7 @@
|
||||
test-command-line-encoding test-command-line-encoding2 \
|
||||
test-language test-guild-compile $(am__append_3) \
|
||||
test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
|
||||
- test-use-srfi $(am__append_5) test-stack-overflow
|
||||
+ test-use-srfi $(am__append_5)
|
||||
BUILT_SOURCES = $(am__append_2)
|
||||
EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
|
||||
test-import-order-c.scm test-import-order-d.scm \
|
Loading…
Reference in a new issue