mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
gnu: superlu-dist: Update to 6.2.0.
* gnu/packages/maths.scm (superlu-dist): Update to 6.2.0. [source]: Update upstream url. Remove mpi deprecations patch. * gnu/packages/patches/superlu-dist-fix-mpi-deprecations.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
48fe5c36a2
commit
aa2e83cce2
3 changed files with 5 additions and 64 deletions
|
@ -1394,7 +1394,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/spice-fix-test-armhf.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/superlu-dist-awpm-grid.patch \
|
||||
%D%/packages/patches/superlu-dist-fix-mpi-deprecations.patch \
|
||||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
%D%/packages/patches/supertux-unbundle-squirrel.patch \
|
||||
%D%/packages/patches/swig-guile-gc.patch \
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
|
||||
;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
|
||||
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
|
||||
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
|
||||
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
|
||||
|
@ -2473,14 +2473,14 @@ (define-public superlu
|
|||
(define-public superlu-dist
|
||||
(package
|
||||
(name "superlu-dist")
|
||||
(version "6.1.0")
|
||||
(version "6.2.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://crd-legacy.lbl.gov/~xiaoye/SuperLU/"
|
||||
(uri (string-append "https://portal.nersc.gov/project/sparse/superlu/"
|
||||
"superlu_dist_" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0pqgcgh1yxhfzs99fas3mggajzd5wca3nbyp878rziy74gfk03dl"))
|
||||
(base32 "1ynmwqajc9sc3my2hssa5k9s58ggvizqv9rdss0j7w99pbh5mnvw"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
;; Replace the non-free implementation of MC64 with a stub
|
||||
|
@ -2506,8 +2506,7 @@ (define-public superlu-dist
|
|||
"RowPerm = NOROWPERM;"))
|
||||
#t))
|
||||
(patches (search-patches "superlu-dist-scotchmetis.patch"
|
||||
"superlu-dist-awpm-grid.patch"
|
||||
"superlu-dist-fix-mpi-deprecations.patch"))))
|
||||
"superlu-dist-awpm-grid.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("tcsh" ,tcsh)))
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
From c9cbcf8730221e366c7495073f8f8d819ee8ce89 Mon Sep 17 00:00:00 2001
|
||||
From: Eric Bavier <bavier@member.fsf.org>
|
||||
Date: Wed, 6 Feb 2019 10:06:59 -0600
|
||||
Subject: [PATCH] Replace deprecated MPI_Attr_get.
|
||||
|
||||
Fixes build with OpenMPI version 4.0.
|
||||
|
||||
* SRC/pdgstrf.c, SRC/pdgstrf.c, SRC/superlu_grid.c: 'MPI_Attr_get' ->
|
||||
'MPI_Comm_get_attr'.
|
||||
---
|
||||
SRC/pdgstrf.c | 2 +-
|
||||
SRC/pzgstrf.c | 2 +-
|
||||
SRC/superlu_grid.c | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/SRC/pdgstrf.c b/SRC/pdgstrf.c
|
||||
index 736ffa2..f92a1ba 100644
|
||||
--- a/SRC/pdgstrf.c
|
||||
+++ b/SRC/pdgstrf.c
|
||||
@@ -426,7 +426,7 @@ pdgstrf(superlu_dist_options_t * options, int m, int n, double anorm,
|
||||
s_eps = smach_dist("Epsilon");
|
||||
thresh = s_eps * anorm;
|
||||
|
||||
- MPI_Attr_get (MPI_COMM_WORLD, MPI_TAG_UB, &attr_val, &flag);
|
||||
+ MPI_Comm_get_attr (MPI_COMM_WORLD, MPI_TAG_UB, &attr_val, &flag);
|
||||
if (!flag) {
|
||||
fprintf (stderr, "Could not get TAG_UB\n");
|
||||
return (-1);
|
||||
diff --git a/SRC/pzgstrf.c b/SRC/pzgstrf.c
|
||||
index 8896548..8800057 100644
|
||||
--- a/SRC/pzgstrf.c
|
||||
+++ b/SRC/pzgstrf.c
|
||||
@@ -426,7 +426,7 @@ pzgstrf(superlu_dist_options_t * options, int m, int n, double anorm,
|
||||
s_eps = smach_dist("Epsilon");
|
||||
thresh = s_eps * anorm;
|
||||
|
||||
- MPI_Attr_get (MPI_COMM_WORLD, MPI_TAG_UB, &attr_val, &flag);
|
||||
+ MPI_Comm_get_attr (MPI_COMM_WORLD, MPI_TAG_UB, &attr_val, &flag);
|
||||
if (!flag) {
|
||||
fprintf (stderr, "Could not get TAG_UB\n");
|
||||
return (-1);
|
||||
diff --git a/SRC/superlu_grid.c b/SRC/superlu_grid.c
|
||||
index 1213d27..0c0fb90 100644
|
||||
--- a/SRC/superlu_grid.c
|
||||
+++ b/SRC/superlu_grid.c
|
||||
@@ -150,7 +150,7 @@ void superlu_gridmap(
|
||||
{
|
||||
int tag_ub;
|
||||
if ( !grid->iam ) {
|
||||
- MPI_Attr_get(Bcomm, MPI_TAG_UB, &tag_ub, &info);
|
||||
+ MPI_Comm_get_attr(Bcomm, MPI_TAG_UB, &tag_ub, &info);
|
||||
printf("MPI_TAG_UB %d\n", tag_ub);
|
||||
/* returns 4295677672
|
||||
In reality it is restricted to no greater than 16384. */
|
||||
--
|
||||
2.20.1
|
||||
|
Loading…
Reference in a new issue