gnu: python-mediafile: Update to 0.7.0.

Remove patch. It is now included in upstream release.

* gnu/packages/music.scm (python-mediafile): Update to 0.7.0.
* gnu/packages/patches/python-mediafile-wavpack.patch: Delete patch.
* gnu/local.mk: Deregister it.
This commit is contained in:
Simon Streit 2021-09-02 13:50:53 +02:00 committed by Lars-Dominik Braun
parent 9f543674ff
commit ab12354c0a
No known key found for this signature in database
GPG key ID: F663943E08D8092A
3 changed files with 4 additions and 63 deletions

View file

@ -1646,7 +1646,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-flint-includes.patch \ %D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-libxml2-utf8.patch \ %D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch \ %D%/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch \
%D%/packages/patches/python-mediafile-wavpack.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \ %D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \ %D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \ %D%/packages/patches/python-testtools.patch \

View file

@ -41,6 +41,7 @@
;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com> ;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li> ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -3604,20 +3605,18 @@ (define-public python-mutagen
(define-public python-mediafile (define-public python-mediafile
(package (package
(name "python-mediafile") (name "python-mediafile")
(version "0.6.0") (version "0.8.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (pypi-uri "mediafile" version)) (uri (pypi-uri "mediafile" version))
(patches (search-patches "python-mediafile-wavpack.patch"))
(sha256 (sha256
(base32 (base32
"0jmsp3f57xj35ayp8b6didk85nxgl3viw34s5px3l5dwgc055yx3")))) "0ipb001j19s9wvssmrj8wz0nrkbl0k3zr3dgzyp1bd9cjc6vklnp"))))
(build-system python-build-system) (build-system python-build-system)
(propagated-inputs (propagated-inputs
`(("python-mutagen" ,python-mutagen) `(("python-mutagen" ,python-mutagen)
("python-six" ,python-six) ("python-six" ,python-six)))
("python-tox" ,python-tox)))
(home-page "https://github.com/beetbox/mediafile") (home-page "https://github.com/beetbox/mediafile")
(synopsis "Read and write audio file tags") (synopsis "Read and write audio file tags")
(description (description

View file

@ -1,57 +0,0 @@
This patch has already been applied upstream, but is not included in the
current release 0.6.0.
From d2fc3b59f77c515b02dfe7ad936f89264375d2b4 Mon Sep 17 00:00:00 2001
From: Adrian Sampson <adrian@radbox.org>
Date: Wed, 29 Jul 2020 19:42:57 -0400
Subject: [PATCH] Fix test for WavPack bitrate
Fixes #34.
---
docs/index.rst | 5 +++++
mediafile.py | 2 +-
test/test_mediafile.py | 2 +-
3 files changed, 7 insertions(+), 2 deletions(-)
diff --git a/docs/index.rst b/docs/index.rst
index 7b622df..1465405 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -100,6 +100,11 @@ Internals
Changelog
---------
+v0.7.0
+''''''
+
+- Mutagen 1.45.0 or later is now required.
+
v0.6.0
''''''
diff --git a/mediafile.py b/mediafile.py
index 23fadaf..9e9d063 100644
--- a/mediafile.py
+++ b/mediafile.py
@@ -56,7 +56,7 @@
import six
-__version__ = '0.6.0'
+__version__ = '0.7.0'
__all__ = ['UnreadableFileError', 'FileTypeError', 'MediaFile']
log = logging.getLogger(__name__)
diff --git a/test/test_mediafile.py b/test/test_mediafile.py
index e9e1850..7f17f44 100644
--- a/test/test_mediafile.py
+++ b/test/test_mediafile.py
@@ -907,7 +907,7 @@ class WavpackTest(ReadWriteTestBase, unittest.TestCase):
'bitrate': 109312,
'format': u'WavPack',
'samplerate': 44100,
- 'bitdepth': 0,
+ 'bitdepth': 16,
'channels': 1,
}