mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add fcgi.
* gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch: New file. * gnu/packages/patches/fcgi-2.4.0-poll.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patches. * gnu/packages/web.scm (fcgi): New variable.
This commit is contained in:
parent
e9913f8271
commit
ab519cfa3d
4 changed files with 130 additions and 0 deletions
|
@ -540,6 +540,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fasthenry-spUtils.patch \
|
||||
%D%/packages/patches/fasthenry-spSolve.patch \
|
||||
%D%/packages/patches/fasthenry-spFactor.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-gcc44-fixes.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
||||
%D%/packages/patches/findutils-localstatedir.patch \
|
||||
%D%/packages/patches/findutils-test-xargs.patch \
|
||||
%D%/packages/patches/flex-CVE-2016-6354.patch \
|
||||
|
|
14
gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch
Normal file
14
gnu/packages/patches/fcgi-2.4.0-gcc44-fixes.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-gcc44_fixes.patch.
|
||||
Fixes compilation with GCC 4.4 and later.
|
||||
|
||||
diff -up fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes fcgi-2.4.0/libfcgi/fcgio.cpp
|
||||
--- fcgi-2.4.0/libfcgi/fcgio.cpp.gcc44_fixes 2002-02-24 21:12:22.000000000 +0100
|
||||
+++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-02-15 11:35:18.000000000 +0100
|
||||
@@ -23,6 +23,7 @@
|
||||
#endif
|
||||
|
||||
#include <limits.h>
|
||||
+#include <cstdio>
|
||||
#include "fcgio.h"
|
||||
|
||||
using std::streambuf;
|
89
gnu/packages/patches/fcgi-2.4.0-poll.patch
Normal file
89
gnu/packages/patches/fcgi-2.4.0-poll.patch
Normal file
|
@ -0,0 +1,89 @@
|
|||
Taken from http://pkgs.fedoraproject.org/cgit/rpms/fcgi.git/plain/fcgi-2.4.0-poll.patch
|
||||
Fixes CVE-2012-6687.
|
||||
|
||||
Author: Anton Kortunov <toshic.toshic@gmail.com>
|
||||
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libfcgi/+bug/933417
|
||||
Description: use poll in os_unix.c instead of select to avoid problem with > 1024 connections
|
||||
Forwarded: yes, fastcgi-developers@mailman.fastcgi.com
|
||||
|
||||
diff --git a/libfcgi/os_unix.c b/libfcgi/os_unix.c
|
||||
index 73e6a7f..af35aee 100755
|
||||
--- a/libfcgi/os_unix.c
|
||||
+++ b/libfcgi/os_unix.c
|
||||
@@ -42,6 +42,7 @@ static const char rcsid[] = "$Id: os_unix.c,v 1.37 2002/03/05 19:14:49 robs Exp
|
||||
#include <sys/time.h>
|
||||
#include <sys/un.h>
|
||||
#include <signal.h>
|
||||
+#include <poll.h>
|
||||
|
||||
#ifdef HAVE_NETDB_H
|
||||
#include <netdb.h>
|
||||
@@ -103,6 +104,9 @@ static int volatile maxFd = -1;
|
||||
static int shutdownPending = FALSE;
|
||||
static int shutdownNow = FALSE;
|
||||
|
||||
+static int libfcgiOsClosePollTimeout = 2000;
|
||||
+static int libfcgiIsAfUnixKeeperPollTimeout = 2000;
|
||||
+
|
||||
void OS_ShutdownPending()
|
||||
{
|
||||
shutdownPending = TRUE;
|
||||
@@ -168,6 +172,16 @@ int OS_LibInit(int stdioFds[3])
|
||||
if(libInitialized)
|
||||
return 0;
|
||||
|
||||
+ char *libfcgiOsClosePollTimeoutStr = getenv( "LIBFCGI_OS_CLOSE_POLL_TIMEOUT" );
|
||||
+ if(libfcgiOsClosePollTimeoutStr) {
|
||||
+ libfcgiOsClosePollTimeout = atoi(libfcgiOsClosePollTimeoutStr);
|
||||
+ }
|
||||
+
|
||||
+ char *libfcgiIsAfUnixKeeperPollTimeoutStr = getenv( "LIBFCGI_IS_AF_UNIX_KEEPER_POLL_TIMEOUT" );
|
||||
+ if(libfcgiIsAfUnixKeeperPollTimeoutStr) {
|
||||
+ libfcgiIsAfUnixKeeperPollTimeout = atoi(libfcgiIsAfUnixKeeperPollTimeoutStr);
|
||||
+ }
|
||||
+
|
||||
asyncIoTable = (AioInfo *)malloc(asyncIoTableSize * sizeof(AioInfo));
|
||||
if(asyncIoTable == NULL) {
|
||||
errno = ENOMEM;
|
||||
@@ -755,19 +769,16 @@ int OS_Close(int fd)
|
||||
|
||||
if (shutdown(fd, 1) == 0)
|
||||
{
|
||||
- struct timeval tv;
|
||||
- fd_set rfds;
|
||||
+ struct pollfd pfd;
|
||||
int rv;
|
||||
char trash[1024];
|
||||
|
||||
- FD_ZERO(&rfds);
|
||||
+ pfd.fd = fd;
|
||||
+ pfd.events = POLLIN;
|
||||
|
||||
do
|
||||
{
|
||||
- FD_SET(fd, &rfds);
|
||||
- tv.tv_sec = 2;
|
||||
- tv.tv_usec = 0;
|
||||
- rv = select(fd + 1, &rfds, NULL, NULL, &tv);
|
||||
+ rv = poll(&pfd, 1, libfcgiOsClosePollTimeout);
|
||||
}
|
||||
while (rv > 0 && read(fd, trash, sizeof(trash)) > 0);
|
||||
}
|
||||
@@ -1116,13 +1127,11 @@ static int is_reasonable_accept_errno (const int error)
|
||||
*/
|
||||
static int is_af_unix_keeper(const int fd)
|
||||
{
|
||||
- struct timeval tval = { READABLE_UNIX_FD_DROP_DEAD_TIMEVAL };
|
||||
- fd_set read_fds;
|
||||
-
|
||||
- FD_ZERO(&read_fds);
|
||||
- FD_SET(fd, &read_fds);
|
||||
+ struct pollfd pfd;
|
||||
+ pfd.fd = fd;
|
||||
+ pfd.events = POLLIN;
|
||||
|
||||
- return select(fd + 1, &read_fds, NULL, NULL, &tval) >= 0 && FD_ISSET(fd, &read_fds);
|
||||
+ return poll(&pfd, 1, libfcgiIsAfUnixKeeperPollTimeout) >= 0 && (pfd.revents & POLLIN);
|
||||
}
|
||||
|
||||
/*
|
|
@ -201,6 +201,31 @@ (define-public nginx
|
|||
;; except for two source files which are bsd-4 licensed.
|
||||
(license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
|
||||
|
||||
(define-public fcgi
|
||||
(package
|
||||
(name "fcgi")
|
||||
(version "2.4.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
;; Upstream has disappeared
|
||||
(uri (string-append "https://sources.archlinux.org/other/packages/fcgi/"
|
||||
"fcgi-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1f857wnl1d6jfrgfgfpz3zdaj8fch3vr13mnpcpvy8bang34bz36"))
|
||||
(patches (search-patches "fcgi-2.4.0-poll.patch"
|
||||
"fcgi-2.4.0-gcc44-fixes.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(home-page "http://www.fastcgi.com")
|
||||
(synopsis "Language-independent, high-performant extension to CGI")
|
||||
(description "FastCGI is a language independent, scalable extension to CGI
|
||||
that provides high performance without the limitations of server specific
|
||||
APIs.")
|
||||
;; This package is released under the Open Market License, a variant of
|
||||
;; the Expat license, incompatible with the GPL.
|
||||
(license (l:non-copyleft "file://LICENSE.TERMS"))))
|
||||
|
||||
(define-public starman
|
||||
(package
|
||||
(name "starman")
|
||||
|
|
Loading…
Reference in a new issue