mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: ghostscript: Make "/CreationDate", "/ModDate" optional, depending on environment variable.
* gnu/packages/patches/ghostscript-no-header-creationdate.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ghostscript.scm (ghostscript): Use it.
This commit is contained in:
parent
63eb4a2a91
commit
ad22c71853
3 changed files with 25 additions and 8 deletions
|
@ -621,6 +621,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ghostscript-CVE-2017-8291.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-id.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
||||
%D%/packages/patches/ghostscript-runpath.patch \
|
||||
%D%/packages/patches/glib-networking-ssl-cert-file.patch \
|
||||
%D%/packages/patches/glib-tests-timer.patch \
|
||||
|
|
|
@ -144,6 +144,7 @@ (define-public ghostscript
|
|||
"0lyhjcrkmd5fcmh8h56bs4xr9k4jasmikv5vsix1hd4ai0ad1q9b"))
|
||||
(patches (search-patches "ghostscript-runpath.patch"
|
||||
"ghostscript-CVE-2017-8291.patch"
|
||||
"ghostscript-no-header-creationdate.patch"
|
||||
"ghostscript-no-header-id.patch"
|
||||
"ghostscript-no-header-uuid.patch"))
|
||||
(modules '((guix build utils)))
|
||||
|
@ -154,14 +155,7 @@ (define-public ghostscript
|
|||
'(begin
|
||||
(for-each delete-file-recursively '("freetype" "jbig2dec" "jpeg"
|
||||
"lcms2" "libpng"
|
||||
"tiff" "zlib"))
|
||||
;; Get rid of timestamps (remove /CreationDate and /ModDate).
|
||||
(substitute* "devices/vector/gdevpdf.c"
|
||||
((", but we do the same")
|
||||
(string-append "*/ "
|
||||
"if (!getenv(\"GS_GENERATE_UUIDS\") || "
|
||||
"(strcmp(getenv(\"GS_GENERATE_UUIDS\"), \"0\") != 0 && "
|
||||
"strcmp(getenv(\"GS_GENERATE_UUIDS\"), \"no\") != 0)) /*")))))))
|
||||
"tiff" "zlib"))))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out" "doc")) ;19 MiB of HTML/PS doc + examples
|
||||
(arguments
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
This patch makes emission of /CreationDate and /ModDate headers optional.
|
||||
|
||||
If the environment variable GS_GENERATE_UUIDS is set to "0" or "no", it will
|
||||
not write out the "/ID" field (if that's permissible).
|
||||
|
||||
Upstream does not want to do this.
|
||||
|
||||
See: https://bugs.ghostscript.com/show_bug.cgi?id=698208
|
||||
diff --git a/orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c b/bb/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
|
||||
index 0fb067e..b342e2c 100644
|
||||
--- orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
|
||||
+++ gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
|
||||
@@ -305,6 +305,9 @@ pdf_initialize_ids(gx_device_pdf * pdev)
|
||||
* date and time, rather than (for example) %%CreationDate from the
|
||||
* PostScript file. We think this is wrong, but we do the same.
|
||||
*/
|
||||
+ if (!getenv("GS_GENERATE_UUIDS") ||
|
||||
+ (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 &&
|
||||
+ strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))
|
||||
{
|
||||
struct tm tms;
|
||||
time_t t;
|
Loading…
Reference in a new issue