mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: tar: Update to 1.30.
* gnu/packages/base.scm (tar): Update to 1.30. [source]: Remove 'tar-CVE-2016-6321.patch'. * gnu/packages/patches/tar-CVE-2016-6321.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
36d37ca9c5
commit
ad3c9f18da
3 changed files with 4 additions and 57 deletions
|
@ -1092,7 +1092,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
||||
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
||||
%D%/packages/patches/t1lib-CVE-2011-1552+.patch \
|
||||
%D%/packages/patches/tar-CVE-2016-6321.patch \
|
||||
%D%/packages/patches/tar-skip-unreliable-tests.patch \
|
||||
%D%/packages/patches/tclxml-3.2-install.patch \
|
||||
%D%/packages/patches/tcsh-fix-autotest.patch \
|
||||
|
|
|
@ -7,7 +7,7 @@
|
|||
;;; Copyright © 2014, 2015 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
||||
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
|
||||
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
|
||||
;;; Copyright © 2016, 2018 Alex Vong <alexvong1995@gmail.com>
|
||||
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
|
||||
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
|
||||
|
@ -167,16 +167,15 @@ (define-public sed
|
|||
(define-public tar
|
||||
(package
|
||||
(name "tar")
|
||||
(version "1.29")
|
||||
(version "1.30")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/tar/tar-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"097hx7sbzp8qirl4m930lw84kn0wmxhmq7v1qpra3mrg0b8cyba0"))
|
||||
(patches (search-patches "tar-CVE-2016-6321.patch"
|
||||
"tar-skip-unreliable-tests.patch"))))
|
||||
"1lyjyk8z8hdddsxw0ikchrsfg3i0x3fsh7l63a8jgaz1n7dr5gzi"))
|
||||
(patches (search-patches "tar-skip-unreliable-tests.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
;; Note: test suite requires ~1GiB of disk space.
|
||||
(arguments
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
Fix CVE-2016-6321:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-6321
|
||||
https://security-tracker.debian.org/tracker/CVE-2016-6321
|
||||
|
||||
Patch adapted from upstream source repository (the changes to 'NEWS'
|
||||
don't apply to the Tar 1.29 release tarball).
|
||||
|
||||
http://git.savannah.gnu.org/cgit/tar.git/commit/?id=7340f67b9860ea0531c1450e5aa261c50f67165d
|
||||
|
||||
From 7340f67b9860ea0531c1450e5aa261c50f67165d Mon Sep 17 00:00:00 2001
|
||||
From: Paul Eggert <eggert@Penguin.CS.UCLA.EDU>
|
||||
Date: Sat, 29 Oct 2016 21:04:40 -0700
|
||||
Subject: [PATCH] When extracting, skip ".." members
|
||||
|
||||
* NEWS: Document this.
|
||||
* src/extract.c (extract_archive): Skip members whose names
|
||||
contain "..".
|
||||
---
|
||||
NEWS | 8 +++++++-
|
||||
src/extract.c | 8 ++++++++
|
||||
2 files changed, 15 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/extract.c b/src/extract.c
|
||||
index f982433..7904148 100644
|
||||
--- a/src/extract.c
|
||||
+++ b/src/extract.c
|
||||
@@ -1629,12 +1629,20 @@ extract_archive (void)
|
||||
{
|
||||
char typeflag;
|
||||
tar_extractor_t fun;
|
||||
+ bool skip_dotdot_name;
|
||||
|
||||
fatal_exit_hook = extract_finish;
|
||||
|
||||
set_next_block_after (current_header);
|
||||
|
||||
+ skip_dotdot_name = (!absolute_names_option
|
||||
+ && contains_dot_dot (current_stat_info.orig_file_name));
|
||||
+ if (skip_dotdot_name)
|
||||
+ ERROR ((0, 0, _("%s: Member name contains '..'"),
|
||||
+ quotearg_colon (current_stat_info.orig_file_name)));
|
||||
+
|
||||
if (!current_stat_info.file_name[0]
|
||||
+ || skip_dotdot_name
|
||||
|| (interactive_option
|
||||
&& !confirm ("extract", current_stat_info.file_name)))
|
||||
{
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
Reference in a new issue