mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
gnu: seahorse: Update to 3.30.1.1.
* gnu/packages/gnome.scm (seahorse)[version]: Update version number. [origin]: Update hash. Add patch needed for compilation with our version of libsecret (0.19.1). [inputs]: Add avahi dependency. [native-inputs]: Add vala dependency. Use gettext-minimal instead of intltool, as only xgettext is used. * gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
84af1e7402
commit
af561664b8
3 changed files with 50 additions and 4 deletions
|
@ -1325,6 +1325,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-integer-declarations.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
%D%/packages/patches/shishi-fix-libgcrypt-detection.patch \
|
||||
|
|
|
@ -2223,7 +2223,7 @@ (define-public gnome-themes-standard
|
|||
(define-public seahorse
|
||||
(package
|
||||
(name "seahorse")
|
||||
(version "3.30")
|
||||
(version "3.30.1.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -2232,8 +2232,19 @@ (define-public seahorse
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1sbj1czlx1fakm72dwgbn0bwm12j838yaky4mkf6hf8j8afnxmzp"))))
|
||||
(build-system glib-or-gtk-build-system)
|
||||
"12x7xmwh62yl0ax90v8nkx3jqzviaz9hz2g56yml78wzww20gawy"))
|
||||
(patches (search-patches
|
||||
"seahorse-gkr-use-0-on-empty-flags.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
'(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'skip-gtk-update-icon-cache
|
||||
;; Don't create 'icon-theme.cache'.
|
||||
(lambda _
|
||||
(substitute* "build-aux/meson_post_install.py"
|
||||
(("gtk-update-icon-cache") "true"))
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("gtk+" ,gtk+)
|
||||
("gcr" ,gcr)
|
||||
|
@ -2241,13 +2252,15 @@ (define-public seahorse
|
|||
("gpgme" ,gpgme)
|
||||
("openldap" ,openldap)
|
||||
("openssh" ,openssh)
|
||||
("avahi" ,avahi)
|
||||
("libsecret" ,libsecret)
|
||||
("libsoup" ,libsoup)))
|
||||
(native-inputs
|
||||
`(("intltool" ,intltool)
|
||||
`(("gettext" ,gettext-minimal)
|
||||
("glib:bin" ,glib "bin")
|
||||
("itstool" ,itstool)
|
||||
("pkg-config" ,pkg-config)
|
||||
("vala" ,vala)
|
||||
("xmllint" ,libxml2)))
|
||||
(home-page "https://launchpad.net/gnome-themes-standard")
|
||||
(synopsis "Manage encryption keys and passwords in the GNOME keyring")
|
||||
|
|
32
gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch
Normal file
32
gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
Patch from <https://gitlab.gnome.org/GNOME/seahorse/commit/d9db29db567012b7c72e85e1be1fbf55fcc9b667>.
|
||||
|
||||
From d9db29db567012b7c72e85e1be1fbf55fcc9b667 Mon Sep 17 00:00:00 2001
|
||||
From: Niels De Graef <nielsdegraef@gmail.com>
|
||||
Date: Sat, 11 May 2019 09:02:34 +0200
|
||||
Subject: [PATCH] gkr: Use 0 on empty flags
|
||||
|
||||
A Flags-type variable without any flag set can be replaced with 0, so
|
||||
this is a safe thing to do. It also prevents us from having to deal with
|
||||
the accidental API break in libsecret (see
|
||||
https://gitlab.gnome.org/GNOME/libsecret/merge_requests/19)
|
||||
---
|
||||
gkr/gkr-keyring-add.vala | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gkr/gkr-keyring-add.vala b/gkr/gkr-keyring-add.vala
|
||||
index 4e92a520..f60c9a22 100644
|
||||
--- a/gkr/gkr-keyring-add.vala
|
||||
+++ b/gkr/gkr-keyring-add.vala
|
||||
@@ -41,8 +41,7 @@ public class Seahorse.Gkr.KeyringAdd : Gtk.Dialog {
|
||||
|
||||
var cancellable = Dialog.begin_request(this);
|
||||
var service = Backend.instance().service;
|
||||
- Secret.Collection.create.begin(service, this.name_entry.text, null,
|
||||
- Secret.CollectionCreateFlags.COLLECTION_CREATE_NONE,
|
||||
+ Secret.Collection.create.begin(service, this.name_entry.text, null, 0,
|
||||
cancellable, (obj, res) => {
|
||||
/* Clear the operation without cancelling it since it is complete */
|
||||
Dialog.complete_request(this, false);
|
||||
--
|
||||
2.23.0
|
||||
|
Loading…
Reference in a new issue