mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-23 19:19:20 -05:00
gnu: openldap: Fix CVE-2017-9287.
* gnu/packages/patches/openldap-CVE-2017-9287.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/openldap.scm (openldap)[replacement]: New field. (openldap/fixed): New variable.
This commit is contained in:
parent
8e33bc1816
commit
b0415c0361
3 changed files with 48 additions and 0 deletions
|
@ -863,6 +863,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openexr-missing-samples.patch \
|
%D%/packages/patches/openexr-missing-samples.patch \
|
||||||
%D%/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch \
|
%D%/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch \
|
||||||
%D%/packages/patches/openjpeg-CVE-2016-9572-CVE-2016-9573.patch \
|
%D%/packages/patches/openjpeg-CVE-2016-9572-CVE-2016-9573.patch \
|
||||||
|
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
||||||
%D%/packages/patches/openocd-nrf52.patch \
|
%D%/packages/patches/openocd-nrf52.patch \
|
||||||
%D%/packages/patches/openssl-runpath.patch \
|
%D%/packages/patches/openssl-runpath.patch \
|
||||||
%D%/packages/patches/openssl-1.1.0-c-rehash-in.patch \
|
%D%/packages/patches/openssl-1.1.0-c-rehash-in.patch \
|
||||||
|
|
|
@ -31,6 +31,7 @@ (define-module (gnu packages openldap)
|
||||||
#:use-module (gnu packages linux)
|
#:use-module (gnu packages linux)
|
||||||
#:use-module (gnu packages python)
|
#:use-module (gnu packages python)
|
||||||
#:use-module (gnu packages tls)
|
#:use-module (gnu packages tls)
|
||||||
|
#:use-module (gnu packages)
|
||||||
#:use-module ((guix licenses) #:select (openldap2.8 lgpl2.1+))
|
#:use-module ((guix licenses) #:select (openldap2.8 lgpl2.1+))
|
||||||
#:use-module (guix packages)
|
#:use-module (guix packages)
|
||||||
#:use-module (guix download)
|
#:use-module (guix download)
|
||||||
|
@ -39,6 +40,7 @@ (define-module (gnu packages openldap)
|
||||||
(define-public openldap
|
(define-public openldap
|
||||||
(package
|
(package
|
||||||
(name "openldap")
|
(name "openldap")
|
||||||
|
(replacement openldap/fixed)
|
||||||
(version "2.4.44")
|
(version "2.4.44")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -79,6 +81,14 @@ (define-public openldap
|
||||||
(license openldap2.8)
|
(license openldap2.8)
|
||||||
(home-page "http://www.openldap.org/")))
|
(home-page "http://www.openldap.org/")))
|
||||||
|
|
||||||
|
(define openldap/fixed
|
||||||
|
(package
|
||||||
|
(inherit openldap)
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(inherit (package-source openldap))
|
||||||
|
(patches (search-patches "openldap-CVE-2017-9287.patch"))))))
|
||||||
|
|
||||||
(define-public nss-pam-ldapd
|
(define-public nss-pam-ldapd
|
||||||
(package
|
(package
|
||||||
(name "nss-pam-ldapd")
|
(name "nss-pam-ldapd")
|
||||||
|
|
37
gnu/packages/patches/openldap-CVE-2017-9287.patch
Normal file
37
gnu/packages/patches/openldap-CVE-2017-9287.patch
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
Fix CVE-2017-9287:
|
||||||
|
|
||||||
|
https://www.openldap.org/its/?findid=8655
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9287
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=0cee1ffb6021b1aae3fcc9581699da1c85a6dd6e
|
||||||
|
|
||||||
|
From 0cee1ffb6021b1aae3fcc9581699da1c85a6dd6e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ryan Tandy <ryan@nardis.ca>
|
||||||
|
Date: Wed, 17 May 2017 20:07:39 -0700
|
||||||
|
Subject: [PATCH] ITS#8655 fix double free on paged search with pagesize 0
|
||||||
|
|
||||||
|
Fixes a double free when a search includes the Paged Results control
|
||||||
|
with a page size of 0 and the search base matches the filter.
|
||||||
|
---
|
||||||
|
servers/slapd/back-mdb/search.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/servers/slapd/back-mdb/search.c b/servers/slapd/back-mdb/search.c
|
||||||
|
index 301d1a498c..43442aa242 100644
|
||||||
|
--- a/servers/slapd/back-mdb/search.c
|
||||||
|
+++ b/servers/slapd/back-mdb/search.c
|
||||||
|
@@ -1066,7 +1066,8 @@ notfound:
|
||||||
|
/* check size limit */
|
||||||
|
if ( get_pagedresults(op) > SLAP_CONTROL_IGNORED ) {
|
||||||
|
if ( rs->sr_nentries >= ((PagedResultsState *)op->o_pagedresults_state)->ps_size ) {
|
||||||
|
- mdb_entry_return( op, e );
|
||||||
|
+ if (e != base)
|
||||||
|
+ mdb_entry_return( op, e );
|
||||||
|
e = NULL;
|
||||||
|
send_paged_response( op, rs, &lastid, tentries );
|
||||||
|
goto done;
|
||||||
|
--
|
||||||
|
2.13.0
|
||||||
|
|
Loading…
Reference in a new issue