mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: libdrm: Fix symbol check tests on mips64el and armhf.
* gnu/packages/patches/libdrm-symbol-check.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xdisorg.scm (libdrm)[source]: Add patch.
This commit is contained in:
parent
a572dca848
commit
b2aab72c14
3 changed files with 198 additions and 1 deletions
|
@ -519,6 +519,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/libarchive-mtree-filename-length-fix.patch \
|
||||
gnu/packages/patches/libbonobo-activation-test-race.patch \
|
||||
gnu/packages/patches/libcanberra-sound-theme-freedesktop.patch \
|
||||
gnu/packages/patches/libdrm-symbol-check.patch \
|
||||
gnu/packages/patches/libevent-dns-tests.patch \
|
||||
gnu/packages/patches/libmtp-devices.patch \
|
||||
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
|
||||
|
|
195
gnu/packages/patches/libdrm-symbol-check.patch
Normal file
195
gnu/packages/patches/libdrm-symbol-check.patch
Normal file
|
@ -0,0 +1,195 @@
|
|||
Augment the list of expected symbols to fix the symbol-check tests on
|
||||
mips64el-linux and armhf-linux.
|
||||
|
||||
--- libdrm-2.4.65/freedreno/freedreno-symbol-check.orig 2015-09-04 11:07:40.000000000 -0400
|
||||
+++ libdrm-2.4.65/freedreno/freedreno-symbol-check 2015-10-18 23:57:15.288416229 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_freedreno.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
fd_bo_cpu_fini
|
||||
fd_bo_cpu_prep
|
||||
fd_bo_del
|
||||
--- libdrm-2.4.65/nouveau/nouveau-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/nouveau/nouveau-symbol-check 2015-10-18 23:55:26.078327118 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBDRM_NOUVEAU_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_nouveau.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
nouveau_bo_map
|
||||
nouveau_bo_name_get
|
||||
nouveau_bo_name_ref
|
||||
--- libdrm-2.4.65/libkms/kms-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/libkms/kms-symbol-check 2015-10-18 23:46:10.683869471 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBKMS_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libkms.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
kms_bo_create
|
||||
kms_bo_destroy
|
||||
kms_bo_get_prop
|
||||
--- libdrm-2.4.65/intel/intel-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/intel/intel-symbol-check 2015-10-18 23:55:53.309558508 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBDRM_INTEL_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_intel.so} | awk '{print $3}' | while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
drm_intel_bo_alloc
|
||||
drm_intel_bo_alloc_for_render
|
||||
drm_intel_bo_alloc_tiled
|
||||
--- libdrm-2.4.65/amdgpu/amdgpu-symbol-check.orig 2015-08-17 10:08:11.000000000 -0400
|
||||
+++ libdrm-2.4.65/amdgpu/amdgpu-symbol-check 2015-10-18 23:56:10.606917723 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.am/libdrm_amdgpuinclude_HEADERS
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_amdgpu.so} | awk '{print $3}' | while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
amdgpu_bo_alloc
|
||||
amdgpu_bo_cpu_map
|
||||
amdgpu_bo_cpu_unmap
|
||||
--- libdrm-2.4.65/exynos/exynos-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/exynos/exynos-symbol-check 2015-10-18 23:56:32.025486153 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.am/libdrm_exynos*_HEADERS
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_exynos.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
exynos_bo_create
|
||||
exynos_bo_destroy
|
||||
exynos_bo_from_name
|
||||
--- libdrm-2.4.65/omap/omap-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/omap/omap-symbol-check 2015-10-18 23:56:44.834438626 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.am/libdrm_omap*HEADERS
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_omap.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
omap_bo_cpu_fini
|
||||
omap_bo_cpu_prep
|
||||
omap_bo_del
|
||||
--- libdrm-2.4.65/tegra/tegra-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
|
||||
+++ libdrm-2.4.65/tegra/tegra-symbol-check 2015-10-18 23:57:00.756759698 -0400
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/bash
|
||||
|
||||
-# The following symbols (past the first five) are taken from the public headers.
|
||||
+# The following symbols (past the first 12) are taken from the public headers.
|
||||
# A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
|
||||
|
||||
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
|
||||
@@ -10,6 +10,13 @@
|
||||
_end
|
||||
_fini
|
||||
_init
|
||||
+_fbss
|
||||
+_fdata
|
||||
+_ftext
|
||||
+__bss_start__
|
||||
+__bss_end__
|
||||
+_bss_end__
|
||||
+__end__
|
||||
drm_tegra_bo_get_flags
|
||||
drm_tegra_bo_get_handle
|
||||
drm_tegra_bo_get_tiling
|
|
@ -209,7 +209,8 @@ (define-public libdrm
|
|||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1i4n7mz49l0j4kr0dg9n1j3hlc786ncqgj0v5fci1mz7pp40m5ki"))))
|
||||
"1i4n7mz49l0j4kr0dg9n1j3hlc786ncqgj0v5fci1mz7pp40m5ki"))
|
||||
(patches (list (search-patch "libdrm-symbol-check.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("libpciaccess" ,libpciaccess)
|
||||
|
|
Loading…
Reference in a new issue