mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: libvpx: Graft to fix CVE-2023-5217.
* gnu/packages/video.scm (libvpx)[replacement]: New field, set to… (libvpx/fixed): …this new variable. * gnu/packages/patches/libvpx-CVE-2023-5217.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
79abbaf4e4
commit
b2ab38cd82
3 changed files with 110 additions and 0 deletions
|
@ -1562,6 +1562,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libutils-remove-damaging-includes.patch \
|
||||
%D%/packages/patches/libvdpau-va-gl-unbundle.patch \
|
||||
%D%/packages/patches/libvpx-CVE-2016-2818.patch \
|
||||
%D%/packages/patches/libvpx-CVE-2023-5217.patch \
|
||||
%D%/packages/patches/libxml2-xpath0-Add-option-xpath0.patch \
|
||||
%D%/packages/patches/libwpd-gcc-compat.patch \
|
||||
%D%/packages/patches/libxslt-generated-ids.patch \
|
||||
|
|
99
gnu/packages/patches/libvpx-CVE-2023-5217.patch
Normal file
99
gnu/packages/patches/libvpx-CVE-2023-5217.patch
Normal file
|
@ -0,0 +1,99 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Sun Sep 24 02:00:00 2023 +0200
|
||||
Subject: libvpx: Fix CVE-2023-5217.
|
||||
|
||||
These are the changes made to libvpx between Firefox ESR 115.3.0 and
|
||||
115.3.1, which claims to fix CVE-2023-5217 and so do we. The report
|
||||
itself is not public.
|
||||
|
||||
It consists of the following 2 upstream libvpx commits:
|
||||
af6dedd715f4307669366944cca6e0417b290282
|
||||
3fbd1dca6a4d2dad332a2110d646e4ffef36d590
|
||||
which are not yet part of an upstream commit.
|
||||
|
||||
---
|
||||
diff -Naur libvpx.orig/test/encode_api_test.cc libvpx/test/encode_api_test.cc
|
||||
--- libvpx.orig/test/encode_api_test.cc 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ libvpx/test/encode_api_test.cc 2023-09-29 21:00:03.189620452 +0200
|
||||
@@ -304,7 +304,6 @@
|
||||
|
||||
void InitCodec(const vpx_codec_iface_t &iface, int width, int height,
|
||||
vpx_codec_ctx_t *enc, vpx_codec_enc_cfg_t *cfg) {
|
||||
- ASSERT_EQ(vpx_codec_enc_config_default(&iface, cfg, 0), VPX_CODEC_OK);
|
||||
cfg->g_w = width;
|
||||
cfg->g_h = height;
|
||||
cfg->g_lag_in_frames = 0;
|
||||
@@ -342,6 +341,7 @@
|
||||
vpx_codec_ctx_t ctx = {};
|
||||
} enc;
|
||||
|
||||
+ ASSERT_EQ(vpx_codec_enc_config_default(iface, &cfg, 0), VPX_CODEC_OK);
|
||||
EXPECT_NO_FATAL_FAILURE(
|
||||
InitCodec(*iface, kWidth, kHeight, &enc.ctx, &cfg));
|
||||
if (IsVP9(iface)) {
|
||||
@@ -353,6 +353,50 @@
|
||||
|
||||
for (const auto threads : { 1, 4, 8, 6, 2, 1 }) {
|
||||
cfg.g_threads = threads;
|
||||
+ EXPECT_NO_FATAL_FAILURE(EncodeWithConfig(cfg, &enc.ctx))
|
||||
+ << "iteration: " << i << " threads: " << threads;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+TEST(EncodeAPI, ConfigResizeChangeThreadCount) {
|
||||
+ constexpr int kInitWidth = 1024;
|
||||
+ constexpr int kInitHeight = 1024;
|
||||
+
|
||||
+ for (const auto *iface : kCodecIfaces) {
|
||||
+ SCOPED_TRACE(vpx_codec_iface_name(iface));
|
||||
+ for (int i = 0; i < (IsVP9(iface) ? 2 : 1); ++i) {
|
||||
+ vpx_codec_enc_cfg_t cfg = {};
|
||||
+ struct Encoder {
|
||||
+ ~Encoder() { EXPECT_EQ(vpx_codec_destroy(&ctx), VPX_CODEC_OK); }
|
||||
+ vpx_codec_ctx_t ctx = {};
|
||||
+ } enc;
|
||||
+
|
||||
+ ASSERT_EQ(vpx_codec_enc_config_default(iface, &cfg, 0), VPX_CODEC_OK);
|
||||
+ // Start in threaded mode to ensure resolution and thread related
|
||||
+ // allocations are updated correctly across changes in resolution and
|
||||
+ // thread counts. See https://crbug.com/1486441.
|
||||
+ cfg.g_threads = 4;
|
||||
+ EXPECT_NO_FATAL_FAILURE(
|
||||
+ InitCodec(*iface, kInitWidth, kInitHeight, &enc.ctx, &cfg));
|
||||
+ if (IsVP9(iface)) {
|
||||
+ EXPECT_EQ(vpx_codec_control_(&enc.ctx, VP9E_SET_TILE_COLUMNS, 6),
|
||||
+ VPX_CODEC_OK);
|
||||
+ EXPECT_EQ(vpx_codec_control_(&enc.ctx, VP9E_SET_ROW_MT, i),
|
||||
+ VPX_CODEC_OK);
|
||||
+ }
|
||||
+
|
||||
+ cfg.g_w = 1000;
|
||||
+ cfg.g_h = 608;
|
||||
+ EXPECT_EQ(vpx_codec_enc_config_set(&enc.ctx, &cfg), VPX_CODEC_OK)
|
||||
+ << vpx_codec_error_detail(&enc.ctx);
|
||||
+
|
||||
+ cfg.g_w = 16;
|
||||
+ cfg.g_h = 720;
|
||||
+
|
||||
+ for (const auto threads : { 1, 4, 8, 6, 2, 1 }) {
|
||||
+ cfg.g_threads = threads;
|
||||
EXPECT_NO_FATAL_FAILURE(EncodeWithConfig(cfg, &enc.ctx))
|
||||
<< "iteration: " << i << " threads: " << threads;
|
||||
}
|
||||
diff -Naur libvpx.orig/vp8/encoder/onyx_if.c libvpx/vp8/encoder/onyx_if.c
|
||||
--- libvpx.orig/vp8/encoder/onyx_if.c 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ libvpx/vp8/encoder/onyx_if.c 2023-09-29 21:01:44.155476128 +0200
|
||||
@@ -1443,6 +1443,11 @@
|
||||
last_h = cpi->oxcf.Height;
|
||||
prev_number_of_layers = cpi->oxcf.number_of_layers;
|
||||
|
||||
+ if (cpi->initial_width) {
|
||||
+ // TODO(https://crbug.com/1486441): Allow changing thread counts; the
|
||||
+ // allocation is done once in vp8_create_compressor().
|
||||
+ oxcf->multi_threaded = cpi->oxcf.multi_threaded;
|
||||
+ }
|
||||
cpi->oxcf = *oxcf;
|
||||
|
||||
switch (cpi->oxcf.Mode) {
|
|
@ -2395,6 +2395,7 @@ (define-public libvpx
|
|||
(package
|
||||
(name "libvpx")
|
||||
(version "1.12.0")
|
||||
(replacement libvpx/fixed)
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
|
@ -2433,6 +2434,15 @@ (define-public libvpx
|
|||
(license license:bsd-3)
|
||||
(home-page "https://www.webmproject.org/")))
|
||||
|
||||
(define libvpx/fixed
|
||||
(package
|
||||
(inherit libvpx)
|
||||
(source
|
||||
(origin
|
||||
(inherit (package-source libvpx))
|
||||
(patches (search-patches "libvpx-CVE-2016-2818.patch"
|
||||
"libvpx-CVE-2023-5217.patch"))))))
|
||||
|
||||
(define-public orf-dl
|
||||
(let ((commit "2dbbe7ef4e0efe0f3c1d59c503108e22d9065999")
|
||||
(revision "1"))
|
||||
|
|
Loading…
Reference in a new issue