mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: doxygen: Update to 1.8.17.
* gnu/packages/documentation.scm (doxygen): Update to 1.8.17. [source](patches): Add doxygen-1.8.17-runtests.patch. [arguments]: Remove obsolete phase. * gnu/packages/patches/doxygen-test.patch: Adjust for upstream changes. * gnu/packages/patches/doxygen-1.8.17-runtests.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
23c883ef83
commit
b34c125851
4 changed files with 80 additions and 12 deletions
|
@ -814,6 +814,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/docker-use-fewer-modprobes.patch \
|
||||
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
%D%/packages/patches/doxygen-1.8.17-runtests.patch \
|
||||
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
|
||||
%D%/packages/patches/dstat-skip-devices-without-io.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
|
|
|
@ -125,7 +125,7 @@ (define-public asciidoc
|
|||
(define-public doxygen
|
||||
(package
|
||||
(name "doxygen")
|
||||
(version "1.8.16")
|
||||
(version "1.8.17")
|
||||
(home-page "http://www.doxygen.nl/")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
|
@ -136,8 +136,9 @@ (define-public doxygen
|
|||
".src.tar.gz")))
|
||||
(sha256
|
||||
(base32
|
||||
"10iwv8bcz5b5cd85gg8pgn0bmyg04n9hs36xn7ggjjnvynv1z67z"))
|
||||
(patches (search-patches "doxygen-test.patch"))))
|
||||
"16dmv0gm1x8rvbm82fmjvi213q8fxqxinm75pcf595flya59ific"))
|
||||
(patches (search-patches "doxygen-test.patch"
|
||||
"doxygen-1.8.17-runtests.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(native-inputs
|
||||
`(("bison" ,bison)
|
||||
|
@ -157,13 +158,6 @@ (define-public doxygen
|
|||
'())
|
||||
#:test-target "tests"
|
||||
#:phases (modify-phases %standard-phases
|
||||
(add-after 'unpack 'remove-git-requirement
|
||||
(lambda _
|
||||
;; TODO: Remove this for > 1.8.16.
|
||||
(substitute* "cmake/git_watcher.cmake"
|
||||
(("Git QUIET REQUIRED")
|
||||
"Git QUIET"))
|
||||
#t))
|
||||
(add-before 'configure 'patch-sh
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(substitute* "src/portable.cpp"
|
||||
|
|
73
gnu/packages/patches/doxygen-1.8.17-runtests.patch
Normal file
73
gnu/packages/patches/doxygen-1.8.17-runtests.patch
Normal file
|
@ -0,0 +1,73 @@
|
|||
1.8.17 was released with a broken test runner.
|
||||
|
||||
https://github.com/doxygen/doxygen/issues/7464
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/doxygen/doxygen/commit/cd9dee013dc749a10bbe019c350e0e62b6635795
|
||||
|
||||
diff --git a/testing/runtests.py b/testing/runtests.py
|
||||
index a4118b865..10fe50214 100755
|
||||
--- a/testing/runtests.py
|
||||
+++ b/testing/runtests.py
|
||||
@@ -3,6 +3,7 @@
|
||||
from __future__ import print_function
|
||||
import argparse, glob, itertools, re, shutil, os, sys
|
||||
import subprocess
|
||||
+import shlex
|
||||
|
||||
config_reg = re.compile('.*\/\/\s*(?P<name>\S+):\s*(?P<value>.*)$')
|
||||
|
||||
@@ -28,10 +29,10 @@ def xpopen(cmd, cmd1="",encoding='utf-8-sig', getStderr=False):
|
||||
return os.popen(cmd).read() # Python 2 without encoding
|
||||
else:
|
||||
if (getStderr):
|
||||
- proc = subprocess.run(cmd1,encoding=encoding,capture_output=True) # Python 3 with encoding
|
||||
- return proc.stderr
|
||||
+ proc = subprocess.Popen(shlex.split(cmd1),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
|
||||
+ return proc.stderr.read()
|
||||
else:
|
||||
- proc = subprocess.Popen(cmd,stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
|
||||
+ proc = subprocess.Popen(shlex.split(cmd),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
|
||||
return proc.stdout.read()
|
||||
|
||||
class Tester:
|
||||
@@ -137,7 +138,7 @@ def prepare_test(self):
|
||||
print('GENERATE_DOCBOOK=NO', file=f)
|
||||
if (self.args.xhtml):
|
||||
print('GENERATE_HTML=YES', file=f)
|
||||
- # HTML_OUTPUT can also be set locally
|
||||
+ # HTML_OUTPUT can also have been set locally
|
||||
print('HTML_OUTPUT=%s/html' % self.test_out, file=f)
|
||||
print('HTML_FILE_EXTENSION=.xhtml', file=f)
|
||||
if (self.args.pdf):
|
||||
@@ -184,7 +185,7 @@ def update_test(self,testmgr):
|
||||
print('Non-existing file %s after \'check:\' statement' % check_file)
|
||||
return
|
||||
# convert output to canonical form
|
||||
- data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file)).read()
|
||||
+ data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file))
|
||||
if data:
|
||||
# strip version
|
||||
data = re.sub(r'xsd" version="[0-9.-]+"','xsd" version=""',data).rstrip('\n')
|
||||
@@ -326,7 +327,7 @@ def perform_test(self,testmgr):
|
||||
tests.append(glob.glob('%s/*.xml' % (docbook_output)))
|
||||
tests.append(glob.glob('%s/*/*/*.xml' % (docbook_output)))
|
||||
tests = ' '.join(list(itertools.chain.from_iterable(tests))).replace(self.args.outputdir +'/','').replace('\\','/')
|
||||
- exe_string = '%s --nonet --postvalid %s' % (self.args.xmllint,tests)
|
||||
+ exe_string = '%s --noout --nonet --postvalid %s' % (self.args.xmllint,tests)
|
||||
exe_string1 = exe_string
|
||||
exe_string += ' %s' % (redirx)
|
||||
exe_string += ' %s more "%s/temp"' % (separ,docbook_output)
|
||||
@@ -346,7 +347,11 @@ def perform_test(self,testmgr):
|
||||
redirx=' 2> %s/temp >nul:'%html_output
|
||||
else:
|
||||
redirx='2>%s/temp >/dev/null'%html_output
|
||||
- exe_string = '%s --path dtd --nonet --postvalid %s/*xhtml' % (self.args.xmllint,html_output)
|
||||
+ check_file = []
|
||||
+ check_file.append(glob.glob('%s/*.xhtml' % (html_output)))
|
||||
+ check_file.append(glob.glob('%s/*/*/*.xhtml' % (html_output)))
|
||||
+ check_file = ' '.join(list(itertools.chain.from_iterable(check_file))).replace(self.args.outputdir +'/','').replace('\\','/')
|
||||
+ exe_string = '%s --noout --path dtd --nonet --postvalid %s' % (self.args.xmllint,check_file)
|
||||
exe_string1 = exe_string
|
||||
exe_string += ' %s' % (redirx)
|
||||
exe_string += ' %s more "%s/temp"' % (separ,html_output)
|
|
@ -52,9 +52,9 @@ diff -u -r doxygen-1.8.7.orig/testing/012/indexpage.xml doxygen-1.8.7/testing/01
|
|||
</briefdescription>
|
||||
<detaileddescription>
|
||||
- <para>See <ref refid="citelist_1CITEREF_knuth79" kindref="member">[3]</ref> for more info.</para>
|
||||
- <para>Oter references with crosreference see <ref refid="citelist_1CITEREF_Be09" kindref="member">[1]</ref> and <ref refid="citelist_1CITEREF_BertholdHeinzVigerske2009" kindref="member">[2]</ref> for more info. </para>
|
||||
- <para>Other references with cross references see <ref refid="citelist_1CITEREF_Be09" kindref="member">[1]</ref> and <ref refid="citelist_1CITEREF_BertholdHeinzVigerske2009" kindref="member">[2]</ref> for more info. </para>
|
||||
+ <para>See knuth79 for more info.</para>
|
||||
+ <para>Oter references with crosreference see Be09 and BertholdHeinzVigerske2009 for more info. </para>
|
||||
+ <para>Other references with cross references see Be09 and BertholdHeinzVigerske2009 for more info. </para>
|
||||
</detaileddescription>
|
||||
</compounddef>
|
||||
</doxygen>
|
||||
|
|
Loading…
Reference in a new issue