mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: clang@11, clang@12: Do not refer to /lib on foreign distros.
Partly fixes <https://issues.guix.gnu.org/51088>. * gnu/packages/patches/clang-11.0-libc-search-path.patch: Update. * gnu/packages/patches/clang-12.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/llvm.scm (clang-12): Use it.
This commit is contained in:
parent
f1b4f46f0a
commit
b37fe44b7d
4 changed files with 134 additions and 54 deletions
|
@ -936,6 +936,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/clang-9.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-10.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-11.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-12.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
|
||||
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
|
||||
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
|
||||
|
|
|
@ -547,7 +547,7 @@ (define-public clang-runtime-12
|
|||
(define-public clang-12
|
||||
(clang-from-llvm llvm-12 clang-runtime-12
|
||||
"0px4gl27az6cdz6adds89qzdwb1cqpjsfvrldbz9qvpmphrj34bf"
|
||||
#:patches '("clang-11.0-libc-search-path.patch")
|
||||
#:patches '("clang-12.0-libc-search-path.patch")
|
||||
#:tools-extra
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
|
|
@ -4,48 +4,47 @@ but unfortunately, that doesn't work for us.
|
|||
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
||||
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
||||
the distro-specific stuff and removes the hard-coded FHS directory names
|
||||
to make sure Clang also works on non-Guix systems.
|
||||
to make sure Clang also works on foreign distros.
|
||||
|
||||
diff --git a/lib/Driver/ToolChains/Gnu.cpp b/lib/Driver/ToolChains/Gnu.cpp
|
||||
--- a/lib/Driver/ToolChains/Gnu.cpp
|
||||
+++ b/lib/Driver/ToolChains/Gnu.cpp
|
||||
@@ -2797,7 +2797,7 @@ void Generic_GCC::AddMultilibPaths(const Driver &D,
|
||||
// the cross. Note that GCC does include some of these directories in some
|
||||
// configurations but this seems somewhere between questionable and simply
|
||||
// a bug.
|
||||
- if (StringRef(LibPath).startswith(SysRoot)) {
|
||||
+ if (0) {
|
||||
addPathIfExists(D, LibPath + "/" + MultiarchTriple, Paths);
|
||||
addPathIfExists(D, LibPath + "/../" + OSLibDir, Paths);
|
||||
}
|
||||
@@ -2811,6 +2811,10 @@ void Generic_GCC::AddMultiarchPaths(const Driver &D,
|
||||
// Try walking via the GCC triple path in case of biarch or multiarch GCC
|
||||
// installations with strange symlinks.
|
||||
if (GCCInstallation.isValid()) {
|
||||
+
|
||||
+// The following code would end up adding things like
|
||||
+// "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
||||
+#if 0
|
||||
addPathIfExists(D,
|
||||
SysRoot + "/usr/lib/" + GCCInstallation.getTriple().str() +
|
||||
"/../../" + OSLibDir,
|
||||
@@ -2823,6 +2827,7 @@ void Generic_GCC::AddMultiarchPaths(const Driver &D,
|
||||
D, GCCInstallation.getInstallPath() + BiarchSibling.gccSuffix(),
|
||||
Paths);
|
||||
}
|
||||
+#endif // Guix
|
||||
diff --git a/lib/Driver/Distro.cpp b/lib/Driver/Distro.cpp
|
||||
index 4d58ad1a..6f638eca 100644
|
||||
--- a/lib/Driver/Distro.cpp
|
||||
+++ b/lib/Driver/Distro.cpp
|
||||
@@ -21,6 +21,10 @@ using namespace clang;
|
||||
|
||||
// See comments above on the multilib variant for details of why this is
|
||||
// included even from outside the sysroot.
|
||||
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS,
|
||||
const llvm::Triple &TargetOrHost) {
|
||||
+ // The compiler should always behave the same, even when used via Guix on a
|
||||
+ // foreign distro.
|
||||
+ return Distro::UnknownDistro;
|
||||
+
|
||||
// If we don't target Linux, no need to check the distro. This saves a few
|
||||
// OS calls.
|
||||
if (!TargetOrHost.isOSLinux())
|
||||
diff --git a/lib/Driver/ToolChains/Cuda.cpp b/lib/Driver/ToolChains/Cuda.cpp
|
||||
index 110a0bca..42b9f7b7 100644
|
||||
--- a/lib/Driver/ToolChains/Cuda.cpp
|
||||
+++ b/lib/Driver/ToolChains/Cuda.cpp
|
||||
@@ -67,6 +67,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
||||
const Driver &D, const llvm::Triple &HostTriple,
|
||||
const llvm::opt::ArgList &Args)
|
||||
: D(D) {
|
||||
+ // Don't look for CUDA in /usr.
|
||||
+ return;
|
||||
+
|
||||
struct Candidate {
|
||||
std::string Path;
|
||||
bool StrictChecking;
|
||||
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
||||
index 18035047..ace8f443 100644
|
||||
--- a/lib/Driver/ToolChains/Linux.cpp
|
||||
+++ b/lib/Driver/ToolChains/Linux.cpp
|
||||
@@ -219,6 +219,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
|
||||
Generic_GCC::PushPPaths(PPaths);
|
||||
|
||||
+// Comment out the distro-specific tweaks so that they don't bite when
|
||||
+// using Guix on a foreign distro.
|
||||
+ // Comment out the distro-specific tweaks so that they don't bite when
|
||||
+ // using Guix on a foreign distro.
|
||||
+#if 0
|
||||
Distro Distro(D.getVFS(), Triple);
|
||||
|
||||
|
@ -54,36 +53,32 @@ diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
|||
|
||||
if (IsAndroid || Distro.IsOpenSUSE())
|
||||
ExtraOpts.push_back("--enable-new-dtags");
|
||||
+#endif // Guix
|
||||
+#endif
|
||||
|
||||
// The selection of paths to try here is designed to match the patterns which
|
||||
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
||||
@@ -310,6 +314,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
||||
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
||||
@@ -297,6 +301,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
|
||||
Generic_GCC::AddMultilibPaths(D, SysRoot, OSLibDir, MultiarchTriple, Paths);
|
||||
|
||||
+// This requires the commented distro tweaks above.
|
||||
+#if 0
|
||||
if (IsAndroid) {
|
||||
// Android sysroots contain a library directory for each supported OS
|
||||
// version as well as some unversioned libraries in the usual multiarch
|
||||
@@ -338,6 +344,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
||||
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
||||
}
|
||||
+#endif // Guix
|
||||
|
||||
Generic_GCC::AddMultiarchPaths(D, SysRoot, OSLibDir, Paths);
|
||||
|
||||
@@ -349,8 +356,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// Similar to the logic for GCC above, if we currently running Clang inside
|
||||
// of the requested system root, add its parent library paths to
|
||||
// those searched.
|
||||
@@ -348,9 +353,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// directory ('Dir' below) or the ResourceDir.
|
||||
if (StringRef(D.Dir).startswith(SysRoot))
|
||||
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+#endif
|
||||
+
|
||||
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
||||
+ // and friends can be found.
|
||||
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
||||
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
||||
}
|
||||
|
||||
ToolChain::CXXStdlibType Linux::GetDefaultCXXStdlibType() const {
|
||||
|
|
84
gnu/packages/patches/clang-12.0-libc-search-path.patch
Normal file
84
gnu/packages/patches/clang-12.0-libc-search-path.patch
Normal file
|
@ -0,0 +1,84 @@
|
|||
Clang attempts to guess file names based on the OS and distro (yes!),
|
||||
but unfortunately, that doesn't work for us.
|
||||
|
||||
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
||||
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
||||
the distro-specific stuff and removes the hard-coded FHS directory names
|
||||
to make sure Clang also works on foreign distros.
|
||||
|
||||
diff --git a/lib/Driver/Distro.cpp b/lib/Driver/Distro.cpp
|
||||
index ee4fe841..f0313bbe 100644
|
||||
--- a/lib/Driver/Distro.cpp
|
||||
+++ b/lib/Driver/Distro.cpp
|
||||
@@ -93,6 +93,10 @@ static Distro::DistroType DetectLsbRelease(llvm::vfs::FileSystem &VFS) {
|
||||
}
|
||||
|
||||
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS) {
|
||||
+ // The compiler should always behave the same, even when used via Guix on a
|
||||
+ // foreign distro.
|
||||
+ return Distro::UnknownDistro;
|
||||
+
|
||||
Distro::DistroType Version = Distro::UnknownDistro;
|
||||
|
||||
// Newer freedesktop.org's compilant systemd-based systems
|
||||
diff --git a/lib/Driver/ToolChains/Cuda.cpp b/lib/Driver/ToolChains/Cuda.cpp
|
||||
index d14776c5..88bc3ccd 100644
|
||||
--- a/lib/Driver/ToolChains/Cuda.cpp
|
||||
+++ b/lib/Driver/ToolChains/Cuda.cpp
|
||||
@@ -119,6 +119,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
||||
const Driver &D, const llvm::Triple &HostTriple,
|
||||
const llvm::opt::ArgList &Args)
|
||||
: D(D) {
|
||||
+ // Don't look for CUDA in /usr.
|
||||
+ return;
|
||||
+
|
||||
struct Candidate {
|
||||
std::string Path;
|
||||
bool StrictChecking;
|
||||
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
||||
index 9663a739..107f96d6 100644
|
||||
--- a/lib/Driver/ToolChains/Linux.cpp
|
||||
+++ b/lib/Driver/ToolChains/Linux.cpp
|
||||
@@ -223,6 +223,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
|
||||
Generic_GCC::PushPPaths(PPaths);
|
||||
|
||||
+ // Comment out the distro-specific tweaks so that they don't bite when
|
||||
+ // using Guix on a foreign distro.
|
||||
+#if 0
|
||||
Distro Distro(D.getVFS(), Triple);
|
||||
|
||||
if (Distro.IsAlpineLinux() || Triple.isAndroid()) {
|
||||
@@ -288,6 +291,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
|
||||
if (IsAndroid || Distro.IsOpenSUSE())
|
||||
ExtraOpts.push_back("--enable-new-dtags");
|
||||
+#endif
|
||||
|
||||
// The selection of paths to try here is designed to match the patterns which
|
||||
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
||||
@@ -301,6 +305,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
|
||||
Generic_GCC::AddMultilibPaths(D, SysRoot, OSLibDir, MultiarchTriple, Paths);
|
||||
|
||||
+#if 0
|
||||
// Similar to the logic for GCC above, if we currently running Clang inside
|
||||
// of the requested system root, add its parent library paths to
|
||||
// those searched.
|
||||
@@ -352,9 +357,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
||||
// directory ('Dir' below) or the ResourceDir.
|
||||
if (StringRef(D.Dir).startswith(SysRoot))
|
||||
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
||||
+#endif
|
||||
+
|
||||
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
||||
+ // and friends can be found.
|
||||
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
||||
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
||||
}
|
||||
|
||||
ToolChain::CXXStdlibType Linux::GetDefaultCXXStdlibType() const {
|
Loading…
Reference in a new issue