mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add laby.
* gnu/packages/patches/laby-make-install.patch: New file. * gnu/local.mk (dist_patch_DATA): gnu-system.am: Add it. * gnu/packages/games.scm (laby): New variable. Signed-off-by: 宋文武 <iyzsong@gmail.com>
This commit is contained in:
parent
7024aeaaaa
commit
b3de5ff221
3 changed files with 67 additions and 0 deletions
|
@ -597,6 +597,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||
%D%/packages/patches/khmer-use-libraries.patch \
|
||||
%D%/packages/patches/kmod-module-directory.patch \
|
||||
%D%/packages/patches/laby-make-install.patch \
|
||||
%D%/packages/patches/ldc-disable-tests.patch \
|
||||
%D%/packages/patches/lftp-dont-save-unknown-host-fingerprint.patch \
|
||||
%D%/packages/patches/liba52-enable-pic.patch \
|
||||
|
|
|
@ -22,6 +22,7 @@
|
|||
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
|
||||
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il"
|
||||
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -74,6 +75,7 @@ (define-module (gnu packages games)
|
|||
#:use-module (gnu packages image)
|
||||
#:use-module (gnu packages ncurses)
|
||||
#:use-module (gnu packages netpbm)
|
||||
#:use-module (gnu packages ocaml)
|
||||
#:use-module (gnu packages python)
|
||||
#:use-module (gnu packages readline)
|
||||
#:use-module (gnu packages xorg)
|
||||
|
@ -2731,3 +2733,42 @@ (define-public supertux
|
|||
the GNU GPL.")
|
||||
(home-page "https://supertuxproject.org/")
|
||||
(license license:gpl3+)))
|
||||
|
||||
(define-public laby
|
||||
(package
|
||||
(name "laby")
|
||||
(version "0.6.4")
|
||||
(source
|
||||
(origin (method url-fetch)
|
||||
(uri (string-append
|
||||
"https://github.com/sgimenez/laby/tarball/"
|
||||
name "-" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"113ip48308ps3lsw427xswgx3wdanils43nyal9n4jr6bcx1bj2j"))
|
||||
(patches (search-patches "laby-make-install.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("lablgtk" ,lablgtk)
|
||||
("ocaml" ,ocaml)
|
||||
("ocaml-findlib" ,ocaml-findlib)))
|
||||
(arguments
|
||||
'(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(delete 'configure)
|
||||
(add-before 'build 'setenv
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
(let ((lablgtk (assoc-ref inputs "lablgtk")))
|
||||
(setenv "LD_LIBRARY_PATH"
|
||||
(string-append lablgtk "/lib/ocaml/stublibs"))))))
|
||||
#:tests? #f ; no 'check' target
|
||||
#:make-flags
|
||||
(list (string-append "PREFIX=" (assoc-ref %outputs "out")) "all")))
|
||||
(home-page "https://sgimenez.github.io/laby/")
|
||||
(synopsis "Programming game")
|
||||
(description "Learn programming, playing with ants and spider webs ;-)
|
||||
Your robot ant can be programmed in many languages: OCaml, Python, C, C++,
|
||||
Java, Ruby, Lua, JavaScript, Pascal, Perl, Scheme, Vala, Prolog. Experienced
|
||||
programmers may also add their own favorite language.")
|
||||
(license license:gpl3+)))
|
||||
|
|
25
gnu/packages/patches/laby-make-install.patch
Normal file
25
gnu/packages/patches/laby-make-install.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From e9896b8951f9faf1f76a3b45be6e70d0aeb30a73 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Nieuwenhuizen <janneke@gnu.org>
|
||||
Date: Sat, 15 Nov 2014 17:48:18 +0100
|
||||
Subject: [PATCH] Add make install.
|
||||
|
||||
---
|
||||
Makefile | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ca18c1e..65af31b 100644
|
||||
--- a/Makefile 2016-02-09 21:34:01.883660009 +0100
|
||||
+++ b/Makefile 2016-02-09 21:34:30.672150679 +0100
|
||||
@@ -19,3 +19,11 @@
|
||||
@git archive --prefix="$(PROJECT_ARCHIVE)/" HEAD \
|
||||
| gzip >_dist/"$(PROJECT_ARCHIVE)".tar.gz
|
||||
@echo archive stored in "_dist/$(PROJECT_ARCHIVE).tar.gz"
|
||||
+
|
||||
+PREFIX=/usr/local
|
||||
+install:
|
||||
+ strip laby
|
||||
+ mkdir -p $(PREFIX)/bin
|
||||
+ cp laby $(PREFIX)/bin/laby
|
||||
+ mkdir -p $(PREFIX)/share/laby
|
||||
+ tar -C data -cf - . | tar -C $(PREFIX)/share/laby -xf-
|
Loading…
Reference in a new issue