mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: texinfo: Update to 6.6.
* gnu/packages/patches/texinfo-perl-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/texinfo.scm (texinfo): Update to 6.6. [source](patches): Remove.
This commit is contained in:
parent
47f66348f7
commit
b3e508dadb
3 changed files with 2 additions and 55 deletions
|
@ -1270,7 +1270,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tcsh-fix-out-of-bounds-read.patch \
|
||||
%D%/packages/patches/teensy-loader-cli-help.patch \
|
||||
%D%/packages/patches/teeworlds-use-latest-wavpack.patch \
|
||||
%D%/packages/patches/texinfo-perl-compat.patch \
|
||||
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||
%D%/packages/patches/texlive-bin-luatex-poppler-compat.patch \
|
||||
%D%/packages/patches/texlive-bin-pdftex-poppler-compat.patch \
|
||||
|
|
|
@ -1,51 +0,0 @@
|
|||
Fix compatibility with newer Perls.
|
||||
|
||||
The first patch is taken from upstream:
|
||||
https://svn.savannah.gnu.org/viewvc/texinfo?view=revision&revision=8008
|
||||
|
||||
The second gets rid of a deprecation warning that breaks some tests.
|
||||
Taken from Fedora: <https://bugzilla.redhat.com/show_bug.cgi?id=1590308>.
|
||||
|
||||
--- trunk/tp/Texinfo/Convert/XSParagraph/xspara.c 2017/04/30 14:57:26 7765
|
||||
+++ trunk/tp/Texinfo/Convert/XSParagraph/xspara.c 2018/07/13 15:39:29 8008
|
||||
@@ -248,6 +248,11 @@
|
||||
|
||||
dTHX;
|
||||
|
||||
+#if PERL_VERSION > 27 || (PERL_VERSION == 27 && PERL_SUBVERSION > 8)
|
||||
+ /* needed due to thread-safe locale handling in newer perls */
|
||||
+ switch_to_global_locale();
|
||||
+#endif
|
||||
+
|
||||
if (setlocale (LC_CTYPE, "en_US.UTF-8")
|
||||
|| setlocale (LC_CTYPE, "en_US.utf8"))
|
||||
goto success;
|
||||
@@ -320,6 +325,10 @@
|
||||
{
|
||||
success: ;
|
||||
free (utf8_locale);
|
||||
+#if PERL_VERSION > 27 || (PERL_VERSION == 27 && PERL_SUBVERSION > 8)
|
||||
+ /* needed due to thread-safe locale handling in newer perls */
|
||||
+ sync_locale();
|
||||
+#endif
|
||||
/*
|
||||
fprintf (stderr, "tried to set LC_CTYPE to UTF-8.\n");
|
||||
fprintf (stderr, "character encoding is: %s\n",
|
||||
|
||||
diff -up texinfo-6.5/tp/Texinfo/Parser.pm.orig texinfo-6.5/tp/Texinfo/Parser.pm
|
||||
--- texinfo-6.5/tp/Texinfo/Parser.pm.orig 2018-06-12 13:40:29.356030136 +0200
|
||||
+++ texinfo-6.5/tp/Texinfo/Parser.pm 2018-06-12 13:41:28.357725639 +0200
|
||||
@@ -5478,11 +5478,11 @@ sub _parse_special_misc_command($$$$)
|
||||
}
|
||||
} elsif ($command eq 'clickstyle') {
|
||||
# REMACRO
|
||||
- if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) {
|
||||
+ if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) {
|
||||
$args = ['@'.$1];
|
||||
$self->{'clickstyle'} = $1;
|
||||
$remaining = $line;
|
||||
- $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
||||
+ $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//;
|
||||
$has_comment = 1 if (defined($4));
|
||||
} else {
|
||||
$self->line_error (sprintf($self->__(
|
|
@ -32,15 +32,14 @@ (define-module (gnu packages texinfo)
|
|||
(define-public texinfo
|
||||
(package
|
||||
(name "texinfo")
|
||||
(version "6.5")
|
||||
(version "6.6")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/texinfo/texinfo-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "texinfo-perl-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0qjzvbvnv9003xdrcpi3jp7y68j4hq2ciw9frh2hghh698zlnxvp"))))
|
||||
"0rixv4c301djr0d0cnsxs8c1wjndi6bf9vi5axz6mwjkv80cmfcv"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("ncurses" ,ncurses)
|
||||
("perl" ,perl)))
|
||||
|
|
Loading…
Reference in a new issue