mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: GHC: Adjust tests for grep 3.8.
This fixes a test failure introduced in commit
c527b0ce23
.
* gnu/packages/patches/ghc-testsuite-grep-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch
the 'ghc-testsuite' input.
This commit is contained in:
parent
77bd6accab
commit
b4693f4a58
3 changed files with 46 additions and 3 deletions
|
@ -1160,6 +1160,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ghc-4.patch \
|
||||
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
|
||||
%D%/packages/patches/ghc-testsuite-dlopen-pie.patch \
|
||||
%D%/packages/patches/ghc-testsuite-grep-compat.patch \
|
||||
%D%/packages/patches/ghc-language-haskell-extract-ghc-8.10.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-id.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||
|
|
|
@ -763,7 +763,8 @@ (define-public ghc-8.6
|
|||
(uri (string-append
|
||||
"https://www.haskell.org/ghc/dist/"
|
||||
version "/" name "-" version "-testsuite.tar.xz"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"
|
||||
"ghc-testsuite-grep-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0pw9r91g2np3i806g2f4f8z4jfdd7mx226cmdizk4swa7av1qf91"))
|
||||
|
@ -844,7 +845,8 @@ (define-public ghc-8.8
|
|||
(uri (string-append
|
||||
"https://www.haskell.org/ghc/dist/"
|
||||
version "/ghc-" version "-testsuite.tar.xz"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"
|
||||
"ghc-testsuite-grep-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))
|
||||
|
@ -902,7 +904,8 @@ (define-public ghc-8.10
|
|||
(uri (string-append
|
||||
"https://www.haskell.org/ghc/dist/"
|
||||
version "/ghc-" version "-testsuite.tar.xz"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
|
||||
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"
|
||||
"ghc-testsuite-grep-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))
|
||||
|
|
39
gnu/packages/patches/ghc-testsuite-grep-compat.patch
Normal file
39
gnu/packages/patches/ghc-testsuite-grep-compat.patch
Normal file
|
@ -0,0 +1,39 @@
|
|||
Remove stray escapes to avoid warnings from grep 3.8 which breaks
|
||||
expected test output.
|
||||
|
||||
diff --git a/testsuite/tests/hsc2hs/Makefile b/testsuite/tests/hsc2hs/Makefile
|
||||
--- a/testsuite/tests/hsc2hs/Makefile
|
||||
+++ b/testsuite/tests/hsc2hs/Makefile
|
||||
@@ -47,5 +47,5 @@ T12504:
|
||||
ifeq "$(WINDOWS)" "YES"
|
||||
grep '{-# LINE 1 \"T12504\\\\path\\\\to\\\\$@\.hsc\" #-}' T12504/path/to/$@.hs
|
||||
else
|
||||
- grep '{-# LINE 1 \"T12504/path/to/$@\.hsc\" #-}' T12504/path/to/$@.hs
|
||||
+ grep '{-# LINE 1 "T12504/path/to/$@\.hsc" #-}' T12504/path/to/$@.hs
|
||||
endif
|
||||
diff --git a/testsuite/tests/numeric/should_run/T7014.primops b/testsuite/tests/numeric/should_run/T7014.primops
|
||||
--- a/testsuite/tests/numeric/should_run/T7014.primops
|
||||
+++ b/testsuite/tests/numeric/should_run/T7014.primops
|
||||
@@ -1,8 +1,8 @@
|
||||
and#
|
||||
or#
|
||||
uncheckedShift.*#
|
||||
-\+#
|
||||
-\-#
|
||||
++#
|
||||
+-#
|
||||
\*#
|
||||
quotInt#
|
||||
remInt#
|
||||
diff --git a/testsuite/tests/simplCore/should_compile/Makefile b/testsuite/tests/simplCore/should_compile/Makefile
|
||||
--- a/testsuite/tests/simplCore/should_compile/Makefile
|
||||
+++ b/testsuite/tests/simplCore/should_compile/Makefile
|
||||
@@ -226,7 +226,7 @@ str-rules:
|
||||
# g should have been collapsed into one defininition by CSE.
|
||||
.PHONY: T13340
|
||||
T13340:
|
||||
- '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '\+#'
|
||||
+ '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '+#'
|
||||
|
||||
|
||||
# We expect to see all dictionaries specialized away.
|
Loading…
Reference in a new issue