mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: xf86-input-synaptics: Allow building with libc 2.20.
* gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-input-synaptics): Use it. Improve synopsis and description.
This commit is contained in:
parent
c9d39df937
commit
b5d9beaa1a
3 changed files with 70 additions and 3 deletions
|
@ -409,6 +409,7 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/util-linux-perl.patch \
|
gnu/packages/patches/util-linux-perl.patch \
|
||||||
gnu/packages/patches/vpnc-script.patch \
|
gnu/packages/patches/vpnc-script.patch \
|
||||||
gnu/packages/patches/w3m-fix-compile.patch \
|
gnu/packages/patches/w3m-fix-compile.patch \
|
||||||
|
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch \
|
||||||
gnu/packages/patches/xmodmap-asprintf.patch \
|
gnu/packages/patches/xmodmap-asprintf.patch \
|
||||||
gnu/packages/patches/xpdf-constchar.patch
|
gnu/packages/patches/xpdf-constchar.patch
|
||||||
|
|
||||||
|
|
63
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch
Normal file
63
gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch
Normal file
|
@ -0,0 +1,63 @@
|
||||||
|
Allow builds with libc 2.20.
|
||||||
|
Patch from <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
|
||||||
|
|
||||||
|
From 96e60a4ea242d2decf109835981ae186cc36f642 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||||
|
Date: Fri, 29 Aug 2014 07:57:41 +1000
|
||||||
|
Subject: Include xorg-server.h to fix build errors on newest glibc
|
||||||
|
|
||||||
|
In file included from /usr/include/string.h:634:0,
|
||||||
|
from /usr/include/xorg/os.h:53,
|
||||||
|
from /usr/include/xorg/misc.h:115,
|
||||||
|
from /usr/include/xorg/xf86str.h:37,
|
||||||
|
from /usr/include/xorg/xf86Xinput.h:54,
|
||||||
|
from synproto.h:36,
|
||||||
|
from synproto.c:24:
|
||||||
|
/usr/include/xorg/os.h:579:1: error: expected identifier or '(' before '__extension__'
|
||||||
|
strndup(const char *str, size_t n);
|
||||||
|
|
||||||
|
See http://lists.freedesktop.org/archives/xorg-devel/2014-July/043070.html
|
||||||
|
|
||||||
|
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||||
|
|
||||||
|
Status: Backport
|
||||||
|
|
||||||
|
Index: xf86-input-synaptics-1.8.0/src/eventcomm.h
|
||||||
|
===================================================================
|
||||||
|
--- xf86-input-synaptics-1.8.0.orig/src/eventcomm.h 2014-08-28 18:40:28.628070587 -0700
|
||||||
|
+++ xf86-input-synaptics-1.8.0/src/eventcomm.h 2014-08-28 18:40:28.620070587 -0700
|
||||||
|
@@ -27,6 +27,8 @@
|
||||||
|
#ifndef _EVENTCOMM_H_
|
||||||
|
#define _EVENTCOMM_H_
|
||||||
|
|
||||||
|
+#include <xorg-server.h>
|
||||||
|
+
|
||||||
|
#include <linux/input.h>
|
||||||
|
#include <linux/version.h>
|
||||||
|
#include <xf86Xinput.h>
|
||||||
|
Index: xf86-input-synaptics-1.8.0/src/ps2comm.h
|
||||||
|
===================================================================
|
||||||
|
--- xf86-input-synaptics-1.8.0.orig/src/ps2comm.h 2014-08-28 18:40:28.628070587 -0700
|
||||||
|
+++ xf86-input-synaptics-1.8.0/src/ps2comm.h 2014-08-28 18:40:28.620070587 -0700
|
||||||
|
@@ -22,6 +22,8 @@
|
||||||
|
#ifndef _PS2COMM_H_
|
||||||
|
#define _PS2COMM_H_
|
||||||
|
|
||||||
|
+#include <xorg-server.h>
|
||||||
|
+
|
||||||
|
#include <unistd.h>
|
||||||
|
#include <sys/ioctl.h>
|
||||||
|
#include "xf86_OSproc.h"
|
||||||
|
Index: xf86-input-synaptics-1.8.0/src/synproto.h
|
||||||
|
===================================================================
|
||||||
|
--- xf86-input-synaptics-1.8.0.orig/src/synproto.h 2014-08-28 18:40:28.628070587 -0700
|
||||||
|
+++ xf86-input-synaptics-1.8.0/src/synproto.h 2014-08-28 18:40:28.624070587 -0700
|
||||||
|
@@ -31,6 +31,8 @@
|
||||||
|
#include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <xorg-server.h>
|
||||||
|
+
|
||||||
|
#include <unistd.h>
|
||||||
|
#include <sys/ioctl.h>
|
||||||
|
#include <xf86Xinput.h>
|
|
@ -2323,7 +2323,9 @@ (define-public xf86-input-synaptics
|
||||||
".tar.bz2"))
|
".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0g5b1s6q1dg38l8y47cwg7cs5nivwj0agmp71g273ws0lfg4bc8s"))))
|
"0g5b1s6q1dg38l8y47cwg7cs5nivwj0agmp71g273ws0lfg4bc8s"))
|
||||||
|
(patches
|
||||||
|
(list (search-patch "xf86-input-synaptics-glibc-2.20.patch")))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(inputs `(("libx11" ,libx11)
|
(inputs `(("libx11" ,libx11)
|
||||||
("libxi" ,libxi)
|
("libxi" ,libxi)
|
||||||
|
@ -2339,8 +2341,9 @@ (define-public xf86-input-synaptics
|
||||||
(assoc-ref %outputs "out")
|
(assoc-ref %outputs "out")
|
||||||
"/share/X11/xorg.conf.d"))))
|
"/share/X11/xorg.conf.d"))))
|
||||||
(home-page "http://www.x.org/wiki/")
|
(home-page "http://www.x.org/wiki/")
|
||||||
(synopsis "xorg implementation of the X Window System")
|
(synopsis "Synaptics touchpad driver for X.Org")
|
||||||
(description "X.org provides an implementation of the X Window System")
|
(description
|
||||||
|
"This package provides a touchpad driver for the X.Org window system.")
|
||||||
(license license:x11)))
|
(license license:x11)))
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue