gnu: teeworlds: Update to 0.7.4 [security fixes]

This fixes CVE-2019-10877, CVE-2019-10878, and CVE-2019-10879.

* gnu/packages/games.scm (teeworlds): Update to 0.7.4.
[source]: Remove patch.
[arguments]: Remove use-latest-json-parser substitution.
* gnu/packages/patches/teeworlds-use-latest-wavpack.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Tobias Geerinckx-Rice 2020-01-19 15:41:32 +01:00
parent 5448b16e81
commit b74f7f06ac
No known key found for this signature in database
GPG key ID: 0DB0FF884F556D79
3 changed files with 3 additions and 152 deletions

View file

@ -1408,7 +1408,6 @@ dist_patch_DATA = \
%D%/packages/patches/tcsh-fix-autotest.patch \
%D%/packages/patches/tcsh-fix-out-of-bounds-read.patch \
%D%/packages/patches/teensy-loader-cli-help.patch \
%D%/packages/patches/teeworlds-use-latest-wavpack.patch \
%D%/packages/patches/texinfo-5-perl-compat.patch \
%D%/packages/patches/texlive-bin-CVE-2018-17407.patch \
%D%/packages/patches/texlive-bin-luatex-poppler-compat.patch \

View file

@ -4530,7 +4530,7 @@ (define-public kiki-the-nano-bot
(define-public teeworlds
(package
(name "teeworlds")
(version "0.7.2")
(version "0.7.4")
(source (origin
(method git-fetch)
(uri (git-reference
@ -4539,7 +4539,7 @@ (define-public teeworlds
(file-name (git-file-name name version))
(sha256
(base32
"15l988qcsqgb6rjais0qd5sd2rjanm2708jmzvkariqzz0d6pb93"))
"1lxdb1k2cdj2421vyz1z0ximzfnpkh2y4y84zpn2gqsa1nzwbryb"))
(modules '((guix build utils)
(ice-9 ftw)
(ice-9 regex)
@ -4551,9 +4551,7 @@ (define-public teeworlds
(cut string-append base-dir <>))
(remove (cut string-match "(^.)|(^md5$)" <>)
(scandir base-dir)))
#t))
(patches
(search-patches "teeworlds-use-latest-wavpack.patch"))))
#t))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests included
@ -4564,19 +4562,6 @@ (define-public teeworlds
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
;; The bundled json-parser uses an old API.
;; To use the latest non-bundled version, we need to pass the
;; length of the data in all 'json_parse_ex' calls.
(define (use-latest-json-parser file)
(substitute* file
(("engine/external/json-parser/json\\.h")
"json-parser/json.h")
(("json_parse_ex\\(&JsonSettings, pFileData, aError\\);")
"json_parse_ex(&JsonSettings,
pFileData,
strlen(pFileData),
aError);")))
;; Embed path to assets.
(substitute* "src/engine/shared/storage.cpp"
(("#define DATA_DIR.*")
@ -4608,13 +4593,6 @@ (define (use-latest-json-parser file)
(substitute* "src/engine/client/sound.cpp"
(("engine/external/wavpack/wavpack\\.h")
"wavpack/wavpack.h"))
(for-each use-latest-json-parser
'("src/game/client/components/countryflags.cpp"
"src/game/client/components/menus_settings.cpp"
"src/game/client/components/skins.cpp"
"src/game/client/localization.cpp"
"src/game/editor/auto_map.h"
"src/game/editor/editor.cpp"))
#t))
(replace 'build
(lambda _

View file

@ -1,126 +0,0 @@
Downloaded from https://salsa.debian.org/games-team/teeworlds/raw/master/debian/patches/new-wavpack.patch.
From: Markus Koschany <apo@debian.org>
Date: Thu, 25 Oct 2018 20:52:27 +0200
Subject: new-wavpack
Make wavpack compatible with Debian's version.
---
src/engine/client/sound.cpp | 33 +++++++++++++++------------------
src/engine/client/sound.h | 4 ----
2 files changed, 15 insertions(+), 22 deletions(-)
diff --git a/src/engine/client/sound.cpp b/src/engine/client/sound.cpp
index 048ec24..80de3c5 100644
--- a/src/engine/client/sound.cpp
+++ b/src/engine/client/sound.cpp
@@ -325,10 +325,6 @@ void CSound::RateConvert(int SampleID)
pSample->m_NumFrames = NumFrames;
}
-int CSound::ReadData(void *pBuffer, int Size)
-{
- return io_read(ms_File, pBuffer, Size);
-}
ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
{
@@ -336,6 +332,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
int SampleID = -1;
char aError[100];
WavpackContext *pContext;
+ char aWholePath[1024];
+ IOHANDLE File;
// don't waste memory on sound when we are stress testing
if(g_Config.m_DbgStress)
@@ -349,25 +347,29 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
return CSampleHandle();
lock_wait(m_SoundLock);
- ms_File = m_pStorage->OpenFile(pFilename, IOFLAG_READ, IStorage::TYPE_ALL);
- if(!ms_File)
+ File = m_pStorage->OpenFile(pFilename, IOFLAG_READ, IStorage::TYPE_ALL, aWholePath, sizeof(aWholePath));
+ if(!File)
{
dbg_msg("sound/wv", "failed to open file. filename='%s'", pFilename);
lock_unlock(m_SoundLock);
return CSampleHandle();
}
+ else
+ {
+ io_close(File);
+ }
SampleID = AllocID();
if(SampleID < 0)
{
- io_close(ms_File);
- ms_File = 0;
+ io_close(File);
+ File = 0;
lock_unlock(m_SoundLock);
return CSampleHandle();
}
pSample = &m_aSamples[SampleID];
- pContext = WavpackOpenFileInput(ReadData, aError);
+ pContext = WavpackOpenFileInput(aWholePath, aError, OPEN_2CH_MAX, 0);
if (pContext)
{
int m_aSamples = WavpackGetNumSamples(pContext);
@@ -385,8 +387,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
if(pSample->m_Channels > 2)
{
dbg_msg("sound/wv", "file is not mono or stereo. filename='%s'", pFilename);
- io_close(ms_File);
- ms_File = 0;
+ io_close(File);
+ File = 0;
lock_unlock(m_SoundLock);
return CSampleHandle();
}
@@ -401,8 +403,8 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
if(BitsPerSample != 16)
{
dbg_msg("sound/wv", "bps is %d, not 16, filname='%s'", BitsPerSample, pFilename);
- io_close(ms_File);
- ms_File = 0;
+ io_close(File);
+ File = 0;
lock_unlock(m_SoundLock);
return CSampleHandle();
}
@@ -429,9 +431,6 @@ ISound::CSampleHandle CSound::LoadWV(const char *pFilename)
dbg_msg("sound/wv", "failed to open %s: %s", pFilename, aError);
}
- io_close(ms_File);
- ms_File = NULL;
-
if(g_Config.m_Debug)
dbg_msg("sound/wv", "loaded %s", pFilename);
@@ -560,7 +559,5 @@ bool CSound::IsPlaying(CSampleHandle SampleID)
return Ret;
}
-IOHANDLE CSound::ms_File = 0;
-
IEngineSound *CreateEngineSound() { return new CSound; }
diff --git a/src/engine/client/sound.h b/src/engine/client/sound.h
index ff357c0..cec2cde 100644
--- a/src/engine/client/sound.h
+++ b/src/engine/client/sound.h
@@ -21,10 +21,6 @@ public:
static void RateConvert(int SampleID);
- // TODO: Refactor: clean this mess up
- static IOHANDLE ms_File;
- static int ReadData(void *pBuffer, int Size);
-
virtual bool IsSoundEnabled() { return m_SoundEnabled != 0; }
virtual CSampleHandle LoadWV(const char *pFilename);