mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-13 14:40:21 -05:00
gnu: fribidi: Update to 1.0.8.
* gnu/packages/patches/fribidi-CVE-2019-18397.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/fribidi.scm (fribidi): Update to 1.0.8.
This commit is contained in:
parent
343139dabb
commit
b9f71df377
3 changed files with 2 additions and 30 deletions
|
@ -859,7 +859,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/flint-ldconfig.patch \
|
||||
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
|
||||
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
|
||||
%D%/packages/patches/fribidi-CVE-2019-18397.patch \
|
||||
%D%/packages/patches/freeimage-unbundle.patch \
|
||||
%D%/packages/patches/fuse-overlapping-headers.patch \
|
||||
%D%/packages/patches/gawk-shell.patch \
|
||||
|
|
|
@ -28,7 +28,7 @@ (define-module (gnu packages fribidi)
|
|||
(define-public fribidi
|
||||
(package
|
||||
(name "fribidi")
|
||||
(version "1.0.7")
|
||||
(version "1.0.8")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -37,8 +37,7 @@ (define-public fribidi
|
|||
"/download/v" version "/fribidi-" version
|
||||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32 "0pckda4fcn0aw32lpycwdp25r2m7vca8zspq815ppi9gkwgg5das"))
|
||||
(patches (search-patches "fribidi-CVE-2019-18397.patch"))))
|
||||
(base32 "0v0ybhck9vz4yayihydknmikslh3xfxygzywnh9rcamdhs6vdiwl"))))
|
||||
(build-system gnu-build-system)
|
||||
(synopsis "Implementation of the Unicode bidirectional algorithm")
|
||||
(description
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
https://github.com/fribidi/fribidi/commit/034c6e9a1d296286305f4cfd1e0072b879f52568.patch
|
||||
|
||||
From 034c6e9a1d296286305f4cfd1e0072b879f52568 Mon Sep 17 00:00:00 2001
|
||||
From: Dov Grobgeld <dov.grobgeld@gmail.com>
|
||||
Date: Thu, 24 Oct 2019 09:37:29 +0300
|
||||
Subject: [PATCH] Truncate isolate_level to FRIBIDI_BIDI_MAX_EXPLICIT_LEVEL
|
||||
|
||||
---
|
||||
lib/fribidi-bidi.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/fribidi-bidi.c b/lib/fribidi-bidi.c
|
||||
index 6c84392..d384878 100644
|
||||
--- a/lib/fribidi-bidi.c
|
||||
+++ b/lib/fribidi-bidi.c
|
||||
@@ -747,7 +747,9 @@ fribidi_get_par_embedding_levels_ex (
|
||||
}
|
||||
|
||||
RL_LEVEL (pp) = level;
|
||||
- RL_ISOLATE_LEVEL (pp) = isolate_level++;
|
||||
+ RL_ISOLATE_LEVEL (pp) = isolate_level;
|
||||
+ if (isolate_level < FRIBIDI_BIDI_MAX_EXPLICIT_LEVEL-1)
|
||||
+ isolate_level++;
|
||||
base_level_per_iso_level[isolate_level] = new_level;
|
||||
|
||||
if (!FRIBIDI_IS_NEUTRAL (override))
|
Loading…
Reference in a new issue