mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: soprano: Add input clucene.
* gnu/packages/rdf.scm (soprano): Add input clucene and patch the cmake file looking for it. * gnu/packages/patches/soprano-find-clucene.patch: New file. * gnu-system.am (dist_patch_DATA): Register the patch.
This commit is contained in:
parent
c69fe8306d
commit
ba948b4fa0
3 changed files with 19 additions and 3 deletions
|
@ -335,6 +335,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/slim-session.patch \
|
||||
gnu/packages/patches/slim-config.patch \
|
||||
gnu/packages/patches/slim-sigusr1.patch \
|
||||
gnu/packages/patches/soprano-find-clucene.patch \
|
||||
gnu/packages/patches/source-highlight-regexrange-test.patch \
|
||||
gnu/packages/patches/sqlite-large-page-size-fix.patch \
|
||||
gnu/packages/patches/tcsh-fix-autotest.patch \
|
||||
|
|
15
gnu/packages/patches/soprano-find-clucene.patch
Normal file
15
gnu/packages/patches/soprano-find-clucene.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
Search for clucene include file in the clucene include directory.
|
||||
|
||||
diff -u -r soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake soprano-2.9.4/cmake/modules/FindCLucene.cmake
|
||||
--- soprano-2.9.4.orig/cmake/modules/FindCLucene.cmake 2013-10-09 19:22:28.000000000 +0200
|
||||
+++ soprano-2.9.4/cmake/modules/FindCLucene.cmake 2014-04-28 20:08:11.000000000 +0200
|
||||
@@ -77,7 +77,8 @@
|
||||
|
||||
get_filename_component(TRIAL_LIBRARY_DIR ${CLUCENE_LIBRARY} PATH)
|
||||
find_path(CLUCENE_LIBRARY_DIR
|
||||
- NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} NO_DEFAULT_PATH)
|
||||
+ NAMES CLucene/clucene-config.h PATHS ${TRIAL_LIBRARY_DIR} ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} ${CLUCENE_INCLUDE_DIR} NO_DEFAULT_PATH)
|
||||
+message (STATUS "XXX ${CLUCENE_LIBRARY_DIR}")
|
||||
if(CLUCENE_LIBRARY_DIR)
|
||||
message(STATUS "Found CLucene library dir: ${CLUCENE_LIBRARY_DIR}")
|
||||
file(READ ${CLUCENE_LIBRARY_DIR}/CLucene/clucene-config.h CLCONTENT)
|
|
@ -106,15 +106,15 @@ (define-public soprano
|
|||
"soprano-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rg0x7yg0a1cbnxz7kqk52580wla8jbnj4d4r3j7l7g7ajyny1k4"))))
|
||||
"1rg0x7yg0a1cbnxz7kqk52580wla8jbnj4d4r3j7l7g7ajyny1k4"))
|
||||
(patches (list (search-patch "soprano-find-clucene.patch")))))
|
||||
(build-system cmake-build-system)
|
||||
;; FIXME: Add optional dependencies: Redland, odbci.
|
||||
(native-inputs
|
||||
`(("doxygen" ,doxygen)
|
||||
("pkg-config" ,pkg-config)))
|
||||
(inputs
|
||||
`(("clucene" ,clucene) ; is not yet "fully found", but sufficiently
|
||||
; so to allow for compilation...
|
||||
`(("clucene" ,clucene)
|
||||
("qt" ,qt-4)
|
||||
("raptor2" ,raptor2)))
|
||||
(home-page "http://soprano.sourceforge.net/")
|
||||
|
|
Loading…
Reference in a new issue