mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: alsa-lib: fix atomic op declarations for MIPS.
* gnu/packages/patches/alsa-lib-mips-atomic-fix.patch: New file. * gnu/packages/linux.scm (alsa-lib): Add patch. * gnu-system.am (dist_patch_DATA): Add patch.
This commit is contained in:
parent
1475a351f6
commit
bcd94e192a
3 changed files with 45 additions and 1 deletions
|
@ -202,6 +202,7 @@ GNU_SYSTEM_MODULES = \
|
|||
|
||||
patchdir = $(guilemoduledir)/gnu/packages/patches
|
||||
dist_patch_DATA = \
|
||||
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch \
|
||||
gnu/packages/patches/apr-skip-getservbyname-test.patch \
|
||||
gnu/packages/patches/automake-skip-amhello-tests.patch \
|
||||
gnu/packages/patches/avahi-localstatedir.patch \
|
||||
|
|
|
@ -473,7 +473,8 @@ (define-public alsa-lib
|
|||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9"))))
|
||||
"0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9"))
|
||||
(patches (list (search-patch "alsa-lib-mips-atomic-fix.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(home-page "http://www.alsa-project.org/")
|
||||
(synopsis "The Advanced Linux Sound Architecture libraries")
|
||||
|
|
42
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch
Normal file
42
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
Fix the declarations of inlined atomic ops for mips.
|
||||
|
||||
This patch was copied from Debian.
|
||||
|
||||
--- alsa-lib/include/iatomic.h.orig 2013-05-21 04:48:28.000000000 -0400
|
||||
+++ alsa-lib/include/iatomic.h 2013-10-29 13:01:37.055995968 -0400
|
||||
@@ -720,7 +720,7 @@
|
||||
* Atomically adds @i to @v. Note that the guaranteed useful range
|
||||
* of an atomic_t is only 24 bits.
|
||||
*/
|
||||
-extern __inline__ void atomic_add(int i, atomic_t * v)
|
||||
+static __inline__ void atomic_add(int i, atomic_t * v)
|
||||
{
|
||||
unsigned long temp;
|
||||
|
||||
@@ -744,7 +744,7 @@
|
||||
* Atomically subtracts @i from @v. Note that the guaranteed
|
||||
* useful range of an atomic_t is only 24 bits.
|
||||
*/
|
||||
-extern __inline__ void atomic_sub(int i, atomic_t * v)
|
||||
+static __inline__ void atomic_sub(int i, atomic_t * v)
|
||||
{
|
||||
unsigned long temp;
|
||||
|
||||
@@ -763,7 +763,7 @@
|
||||
/*
|
||||
* Same as above, but return the result value
|
||||
*/
|
||||
-extern __inline__ int atomic_add_return(int i, atomic_t * v)
|
||||
+static __inline__ int atomic_add_return(int i, atomic_t * v)
|
||||
{
|
||||
unsigned long temp, result;
|
||||
|
||||
@@ -784,7 +784,7 @@
|
||||
return result;
|
||||
}
|
||||
|
||||
-extern __inline__ int atomic_sub_return(int i, atomic_t * v)
|
||||
+static __inline__ int atomic_sub_return(int i, atomic_t * v)
|
||||
{
|
||||
unsigned long temp, result;
|
||||
|
Loading…
Reference in a new issue