gnu: python: Make the build reproducible.

While Python build was reproducible on a single machine, once multiple file
systems entered the picture, it was no longer true.  The solution adopted by
the upstream (and Debian) was cherry-picked.

More info: <https://github.com/python/cpython/pull/8226>.

* gnu/packages/python.scm (python-3.10) [source]: Apply reproducibility patch.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I0273dc0f8511a7acdcc2b462a26cc29a9756c801
This commit is contained in:
Tomas Volf 2024-01-20 22:59:08 -05:00 committed by Ludovic Courtès
parent 3de22656ad
commit be86f3de1e
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 32 additions and 0 deletions

View file

@ -1970,6 +1970,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-hurd-configure.patch \ %D%/packages/patches/python-3-hurd-configure.patch \
%D%/packages/patches/python-angr-addition-type-error.patch \ %D%/packages/patches/python-angr-addition-type-error.patch \
%D%/packages/patches/python-angr-check-exec-deps.patch \ %D%/packages/patches/python-angr-check-exec-deps.patch \
%D%/packages/patches/python-3-reproducible-build.patch \
%D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \ %D%/packages/patches/python-aionotify-0.2.0-py3.8.patch \
%D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \ %D%/packages/patches/python-argcomplete-1.11.1-fish31.patch \
%D%/packages/patches/python-cross-compile.patch \ %D%/packages/patches/python-cross-compile.patch \

View file

@ -0,0 +1,30 @@
From 6c8ea7c1dacd42f3ba00440231ec0e6b1a38300d Mon Sep 17 00:00:00 2001
From: Inada Naoki <songofacandy@gmail.com>
Date: Sat, 14 Jul 2018 00:46:11 +0900
Subject: [PATCH] Use FLAG_REF always for interned strings
---
Python/marshal.c | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/Python/marshal.c b/Python/marshal.c
index 6d06266c6a8e2e..51db2e3b2e29a2 100644
--- a/Python/marshal.c
+++ b/Python/marshal.c
@@ -275,9 +275,14 @@ w_ref(PyObject *v, char *flag, WFILE *p)
if (p->version < 3 || p->hashtable == NULL)
return 0; /* not writing object references */
- /* if it has only one reference, it definitely isn't shared */
- if (Py_REFCNT(v) == 1)
+ /* If it has only one reference, it definitely isn't shared.
+ * But we use TYPE_REF always for interned string, to PYC file stable
+ * as possible.
+ */
+ if (Py_REFCNT(v) == 1 &&
+ !(PyUnicode_CheckExact(v) && PyUnicode_CHECK_INTERNED(v))) {
return 0;
+ }
entry = _Py_HASHTABLE_GET_ENTRY(p->hashtable, v);
if (entry != NULL) {

View file

@ -435,6 +435,7 @@ (define-public python-3.10
"python-3-deterministic-build-info.patch" "python-3-deterministic-build-info.patch"
"python-3-fix-tests.patch" "python-3-fix-tests.patch"
"python-3-hurd-configure.patch" "python-3-hurd-configure.patch"
"python-3-reproducible-build.patch"
"python-3-search-paths.patch")) "python-3-search-paths.patch"))
(sha256 (sha256
(base32 (base32