Merge branch 'bug-17853'

This commit is contained in:
Ludovic Courtès 2014-07-13 23:44:55 +02:00
commit c3cf9d36e4
14 changed files with 150 additions and 95 deletions

View file

@ -304,8 +304,8 @@ dist_patch_DATA = \
gnu/packages/patches/gd-mips64-deplibs-fix.patch \ gnu/packages/patches/gd-mips64-deplibs-fix.patch \
gnu/packages/patches/glib-tests-desktop.patch \ gnu/packages/patches/glib-tests-desktop.patch \
gnu/packages/patches/glib-tests-homedir.patch \ gnu/packages/patches/glib-tests-homedir.patch \
gnu/packages/patches/glib-tests-newnet.patch \
gnu/packages/patches/glib-tests-prlimit.patch \ gnu/packages/patches/glib-tests-prlimit.patch \
gnu/packages/patches/glib-tests-timer.patch \
gnu/packages/patches/glibc-bootstrap-system.patch \ gnu/packages/patches/glibc-bootstrap-system.patch \
gnu/packages/patches/glibc-ldd-x86_64.patch \ gnu/packages/patches/glibc-ldd-x86_64.patch \
gnu/packages/patches/gnunet-fix-scheduler.patch \ gnu/packages/patches/gnunet-fix-scheduler.patch \
@ -325,6 +325,7 @@ dist_patch_DATA = \
gnu/packages/patches/icu4c-test-date-format.patch \ gnu/packages/patches/icu4c-test-date-format.patch \
gnu/packages/patches/inkscape-stray-comma.patch \ gnu/packages/patches/inkscape-stray-comma.patch \
gnu/packages/patches/kmod-module-directory.patch \ gnu/packages/patches/kmod-module-directory.patch \
gnu/packages/patches/libbonobo-activation-test-race.patch \
gnu/packages/patches/libevent-dns-tests.patch \ gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/libffi-mips-n32-fix.patch \ gnu/packages/patches/libffi-mips-n32-fix.patch \
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \ gnu/packages/patches/liboop-mips64-deplibs-fix.patch \

View file

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU ;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org> ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -60,6 +60,7 @@ (define-public avahi
("libdaemon" ,libdaemon))) ("libdaemon" ,libdaemon)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin")
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(synopsis "Avahi, an mDNS/DNS-SD implementation") (synopsis "Avahi, an mDNS/DNS-SD implementation")
(description (description

View file

@ -106,28 +106,29 @@ (define dbus
(define glib (define glib
(package (package
(name "glib") (name "glib")
(version "2.39.1") (version "2.40.0")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "mirror://gnome/sources/" (uri (string-append "mirror://gnome/sources/"
name "/" (string-take version 4) "/" name "/" (string-take version 4) "/"
name "-" version ".tar.xz")) name "-" version ".tar.xz"))
(sha256 (sha256
(base32 "0lqi6z47068vgh91fm59jn0kq969wf3g2q8k4m33jsb0amprg36h")) (base32 "1d98mbqjmc34s8095lkw1j1bwvnnkw9581yfvjaikjvfjsaz29qd"))
(patches (list (search-patch "glib-tests-homedir.patch") (patches (list (search-patch "glib-tests-homedir.patch")
(search-patch "glib-tests-desktop.patch") (search-patch "glib-tests-desktop.patch")
(search-patch "glib-tests-prlimit.patch") (search-patch "glib-tests-prlimit.patch")
(search-patch "glib-tests-newnet.patch"))))) (search-patch "glib-tests-timer.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(outputs '("out" ; everything (outputs '("out" ; everything
"doc")) ; 20 MiB of GTK-Doc reference "bin" ; glib-mkenums, gtester, etc.; depends on Python
"doc")) ; 20 MiB of GTK-Doc reference
(inputs (inputs
`(("coreutils" ,coreutils) `(("coreutils" ,coreutils)
("libffi" ,libffi) ("libffi" ,libffi)
("zlib" ,zlib) ("zlib" ,zlib)
("tzdata" ,tzdata))) ; for tests/gdatetime.c ("tzdata" ,tzdata))) ; for tests/gdatetime.c
(native-inputs (native-inputs
`(("gettext" ,gnu-gettext) `(("gettext" ,gnu-gettext)
("dbus" ,dbus) ; for GDBus tests ("dbus" ,dbus) ; for GDBus tests
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("python" ,python-wrapper) ("python" ,python-wrapper)
@ -201,6 +202,8 @@ (define gobject-introspection
("glib" ,glib) ("glib" ,glib)
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("python-2" ,python-2))) ("python-2" ,python-2)))
(native-inputs
`(("glib" ,glib "bin")))
(propagated-inputs (propagated-inputs
`(;; In practice, GIR users will need libffi when using `(;; In practice, GIR users will need libffi when using
;; gobject-introspection. ;; gobject-introspection.
@ -318,7 +321,9 @@ (define dbus-glib
(inputs (inputs
`(("dbus" ,dbus) `(("dbus" ,dbus)
("expat" ,expat) ("expat" ,expat)
("glib" ,glib) ("glib" ,glib)))
(native-inputs
`(("glib" ,glib "bin")
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "http://dbus.freedesktop.org/doc/dbus-glib/") (home-page "http://dbus.freedesktop.org/doc/dbus-glib/")
(synopsis "D-Bus GLib bindings") (synopsis "D-Bus GLib bindings")
@ -382,7 +387,8 @@ (define glibmm
(("Gio::init.*$") (("Gio::init.*$")
"return 77;\n"))) "return 77;\n")))
%standard-phases))) %standard-phases)))
(inputs `(("pkg-config" ,pkg-config))) (inputs `(("pkg-config" ,pkg-config)
("glib" ,glib "bin")))
(propagated-inputs (propagated-inputs
`(("libsigc++" ,libsigc++) `(("libsigc++" ,libsigc++)
("glib" ,glib))) ("glib" ,glib)))

View file

@ -42,7 +42,8 @@ (define-module (gnu packages gnome)
#:use-module (gnu packages xml) #:use-module (gnu packages xml)
#:use-module (gnu packages gl) #:use-module (gnu packages gl)
#:use-module (gnu packages compression) #:use-module (gnu packages compression)
#:use-module (gnu packages xorg)) #:use-module (gnu packages xorg)
#:use-module (srfi srfi-1))
(define-public brasero (define-public brasero
(package (package
@ -60,6 +61,7 @@ (define-public brasero
`(("hicolor-icon-theme" ,hicolor-icon-theme))) `(("hicolor-icon-theme" ,hicolor-icon-theme)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(inputs (inputs
`(("glib" ,glib) `(("glib" ,glib)
@ -73,9 +75,6 @@ (define-public brasero
("libnotify" ,libnotify) ("libnotify" ,libnotify)
("libsm" ,libsm) ("libsm" ,libsm)
("libxml2" ,libxml2))) ("libxml2" ,libxml2)))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/brasero/") (home-page "https://projects.gnome.org/brasero/")
(synopsis "CD/DVD burning tool for Gnome") (synopsis "CD/DVD burning tool for Gnome")
(description "Brasero is an application to burn CD/DVD for the Gnome (description "Brasero is an application to burn CD/DVD for the Gnome
@ -173,6 +172,7 @@ (define-public libgnome-keyring
("dbus" ,dbus))) ("dbus" ,dbus)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin")
("intltool" ,intltool))) ("intltool" ,intltool)))
(propagated-inputs (propagated-inputs
;; Referred to in .h files and .pc. ;; Referred to in .h files and .pc.
@ -239,6 +239,7 @@ (define-public evince
("dogtail" ,python2-dogtail))) ("dogtail" ,python2-dogtail)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin")
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page (home-page
"http://www.gnome.org/projects/evince/") "http://www.gnome.org/projects/evince/")
@ -268,6 +269,7 @@ (define-public gsettings-desktop-schemas
`(("glib" ,glib))) `(("glib" ,glib)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://launchpad.net/gsettings-desktop-schemas") (home-page "https://launchpad.net/gsettings-desktop-schemas")
(synopsis (synopsis
@ -402,7 +404,8 @@ (define-public libnotify
("gtk+" ,gtk+) ("gtk+" ,gtk+)
("libpng" ,libpng))) ("libpng" ,libpng)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config))) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin")))
(home-page "https://developer-next.gnome.org/libnotify/") (home-page "https://developer-next.gnome.org/libnotify/")
(synopsis (synopsis
"GNOME desktop notification library") "GNOME desktop notification library")
@ -465,7 +468,8 @@ (define-public gtkglext
("mesa" ,mesa) ("mesa" ,mesa)
("libx11" ,libx11) ("libx11" ,libx11)
("libxt" ,libxt))) ("libxt" ,libxt)))
(native-inputs `(("pkg-config" ,pkg-config))) (native-inputs `(("pkg-config" ,pkg-config)
("glib" ,glib "bin")))
(propagated-inputs `(("pangox-compat" ,pangox-compat))) (propagated-inputs `(("pangox-compat" ,pangox-compat)))
(home-page "https://projects.gnome.org/gtkglext") (home-page "https://projects.gnome.org/gtkglext")
(synopsis "OpenGL extension to GTK+.") (synopsis "OpenGL extension to GTK+.")
@ -595,6 +599,7 @@ (define-public librsvg
%standard-phases))) %standard-phases)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc. ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs (inputs
`(("pango" ,pango) `(("pango" ,pango)
@ -689,33 +694,36 @@ (define-public libbonobo
(version "2.32.1") (version "2.32.1")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append "mirror://gnome/sources/" name "/"
"mirror://gnome/sources/" name "/" (string-take version 4) "/" name "-" (string-join (take (string-split version #\.) 2)
version ".")
".tar.bz2")) "/" name "-" version ".tar.bz2"))
(sha256 (sha256
(base32 "0swp4kk6x7hy1rvd1f9jba31lvfc6qvafkvbpg9h0r34fzrd8q4i")))) (base32 "0swp4kk6x7hy1rvd1f9jba31lvfc6qvafkvbpg9h0r34fzrd8q4i"))
(patches (list (search-patch "libbonobo-activation-test-race.patch")))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
;; The programmer kindly gives us a hook to turn off deprecation warnings ... ;; The programmer kindly gives us a hook to turn off deprecation warnings ...
`(#:configure-flags '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS") `(#:configure-flags
;; ... which they then completly ignore !! '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
#:phases ;; ... which they then completly ignore !!
(alist-cons-before #:phases
'configure 'ignore-deprecations (alist-cons-before
(lambda _ 'configure 'ignore-deprecations
(substitute* "activation-server/Makefile.in" (lambda _
(("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))) (substitute* "activation-server/Makefile.in"
%standard-phases))) (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))
%standard-phases)))
(inputs `(("popt" ,popt) (inputs `(("popt" ,popt)
("libxml2" ,libxml2))) ("libxml2" ,libxml2)))
;; The following are Required by the .pc file ;; The following are Required by the .pc file
(propagated-inputs (propagated-inputs
`(("glib" ,glib) `(("glib" ,glib)
("orbit2" ,orbit2))) ("orbit2" ,orbit2)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("flex" ,flex) ("flex" ,flex)
("bison" ,bison))) ("bison" ,bison)))
(home-page "https://developer.gnome.org/libbonobo/") (home-page "https://developer.gnome.org/libbonobo/")
@ -750,6 +758,7 @@ (define-public gconf
(propagated-inputs `(("orbit2" ,orbit2))) ; referred to in the .pc file (propagated-inputs `(("orbit2" ,orbit2))) ; referred to in the .pc file
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/gconf/") (home-page "https://projects.gnome.org/gconf/")
(synopsis "store application preferences") (synopsis "store application preferences")
@ -818,7 +827,8 @@ (define-public gnome-vfs
("gnome-mime-data" ,gnome-mime-data) ("gnome-mime-data" ,gnome-mime-data)
("zlib" ,zlib))) ("zlib" ,zlib)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("glib" ,glib "bin") ; for glib-mkenums, etc.
("intltool" ,intltool)
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/gnome-vfs/") (home-page "https://developer.gnome.org/gnome-vfs/")
(synopsis "access files and folders in GNOME applications") (synopsis "access files and folders in GNOME applications")
@ -855,7 +865,8 @@ (define-public libgnome
(inputs `(("popt" ,popt) (inputs `(("popt" ,popt)
("libxml2" ,libxml2))) ("libxml2" ,libxml2)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("glib" ,glib "bin") ; for glib-mkenums, etc.
("intltool" ,intltool)
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
;; The following are listed as Required in the .pc file ;; The following are listed as Required in the .pc file
;; (except for libcanberra -- which seems to be oversight on the part ;; (except for libcanberra -- which seems to be oversight on the part
@ -919,6 +930,7 @@ (define-public libgnomecanvas
("gtk+" ,gtk+-2))) ("gtk+" ,gtk+-2)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/libgnomecanvas/") (home-page "https://developer.gnome.org/libgnomecanvas/")
(synopsis "Flexible widget for creating interactive structured graphics") (synopsis "Flexible widget for creating interactive structured graphics")
@ -951,7 +963,8 @@ (define-public libgnomeui
("libxml2" ,libxml2) ("libxml2" ,libxml2)
("libglade" ,libglade))) ("libglade" ,libglade)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("glib" ,glib "bin") ; for glib-mkenums, etc.
("intltool" ,intltool)
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/libgnomeui/") (home-page "https://developer.gnome.org/libgnomeui/")
(synopsis "Additional widgets for applications") (synopsis "Additional widgets for applications")
@ -1004,9 +1017,10 @@ (define-public libgnomeprint
`(("popt" ,popt) `(("popt" ,popt)
("libart-lgpl" ,libart-lgpl) ("libart-lgpl" ,libart-lgpl)
("gtk+" ,gtk+-2) ("gtk+" ,gtk+-2)
("libxml2" ,libxml2))) ("libxml2" ,libxml2)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/gnome-print/home/faq.html") (home-page "https://projects.gnome.org/gnome-print/home/faq.html")
(synopsis "printing framework for GNOME") (synopsis "printing framework for GNOME")
@ -1051,9 +1065,9 @@ (define-public libbonoboui
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append
"mirror://gnome/sources/" name "/" (string-take version 3) "/" name "-" "mirror://gnome/sources/" name "/"
version (string-join (take (string-split version #\.) 2) ".")
".tar.bz2")) "/" name "-" version ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"1kbgqh7bw0fdx4f1a1aqwpff7gp5mwhbaz60c6c98bc4djng5dgs")))) "1kbgqh7bw0fdx4f1a1aqwpff7gp5mwhbaz60c6c98bc4djng5dgs"))))
@ -1081,7 +1095,8 @@ (define-public libbonoboui
("libgnomecanvas" ,libgnomecanvas) ("libgnomecanvas" ,libgnomecanvas)
("libglade" ,libglade))) ("libglade" ,libglade)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("glib" ,glib "bin") ; for glib-genmarshal, etc.
("intltool" ,intltool)
("xorg-server" ,xorg-server) ; For running the tests ("xorg-server" ,xorg-server) ; For running the tests
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/libbonoboui/") (home-page "https://developer.gnome.org/libbonoboui/")

View file

@ -51,6 +51,7 @@ (define-public gstreamer
(native-inputs (native-inputs
`(("bison" ,bison) `(("bison" ,bison)
("flex" ,flex) ("flex" ,flex)
("glib" ,glib "bin")
("perl" ,perl) ("perl" ,perl)
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper))) ("python-wrapper" ,python-wrapper)))
@ -60,7 +61,7 @@ (define-public gstreamer
"GStreamer is a library for constructing graphs of media-handling "GStreamer is a library for constructing graphs of media-handling
components. The applications it supports range from simple Ogg/Vorbis components. The applications it supports range from simple Ogg/Vorbis
playback, audio/video streaming to complex audio (mixing) and video playback, audio/video streaming to complex audio (mixing) and video
(non-linear editing) processing. (non-linear editing) processing.
Applications can take advantage of advances in codec and filter technology Applications can take advantage of advances in codec and filter technology
transparently. Developers can add new codecs and filters by writing a transparently. Developers can add new codecs and filters by writing a
@ -91,6 +92,7 @@ (define-public gstreamer-0.10
("flex" ,flex) ("flex" ,flex)
("perl" ,perl) ("perl" ,perl)
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("glib" ,glib "bin")
("python" ,python-2))))) ("python" ,python-2)))))
(define-public gst-plugins-base (define-public gst-plugins-base
@ -112,6 +114,7 @@ (define-public gst-plugins-base
("gstreamer" ,gstreamer))) ("gstreamer" ,gstreamer)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin")
("python-wrapper" ,python-wrapper))) ("python-wrapper" ,python-wrapper)))
(arguments (arguments
`(#:tests? #f)) `(#:tests? #f))
@ -154,4 +157,5 @@ (define-public gst-plugins-base-0.10
("gstreamer" ,gstreamer-0.10))) ("gstreamer" ,gstreamer-0.10)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("python" ,python-2))))) ("glib" ,glib "bin")
("python" ,python-2)))))

View file

@ -54,6 +54,7 @@ (define-public atk
(inputs `(("glib" ,glib))) (inputs `(("glib" ,glib)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc. ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME accessibility toolkit") (synopsis "GNOME accessibility toolkit")
(description (description
@ -158,6 +159,7 @@ (define-public pango
`(("zlib" ,zlib))) `(("zlib" ,zlib)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc. ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME text and font handling library") (synopsis "GNOME text and font handling library")
(description (description
@ -215,7 +217,8 @@ (define-public gtksourceview
("xorg-server" ,xorg-server) ("xorg-server" ,xorg-server)
("shared-mime-info" ,shared-mime-info))) ("shared-mime-info" ,shared-mime-info)))
(native-inputs (native-inputs
`(("intltool" ,intltool) `(("intltool" ,intltool)
("glib" ,glib "bin") ; for glib-genmarshal, etc.
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(arguments (arguments
`(#:phases `(#:phases
@ -267,6 +270,7 @@ (define-public gdk-pixbuf
("libtiff" ,libtiff))) ("libtiff" ,libtiff)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection", gobject-introspection))) ; g-ir-compiler, etc. ("gobject-introspection", gobject-introspection))) ; g-ir-compiler, etc.
(synopsis "GNOME image loading and manipulation library") (synopsis "GNOME image loading and manipulation library")
(description (description
@ -353,6 +357,7 @@ (define-public gtk+-2
("pango" ,pango))) ("pango" ,pango)))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
("glib" ,glib "bin")
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper))) ("python-wrapper" ,python-wrapper)))
(arguments (arguments
@ -395,6 +400,7 @@ (define-public gtk+
`(("libxml2" ,libxml2))) `(("libxml2" ,libxml2)))
(native-inputs (native-inputs
`(("perl" ,perl) `(("perl" ,perl)
("glib" ,glib "bin")
("pkg-config" ,pkg-config) ("pkg-config" ,pkg-config)
("gobject-introspection" ,gobject-introspection) ("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper) ("python-wrapper" ,python-wrapper)

View file

@ -1298,6 +1298,7 @@ (define-public udev
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config) `(("pkg-config" ,pkg-config)
("gperf" ,gperf) ("gperf" ,gperf)
("glib" ,glib "bin") ; glib-genmarshal, etc.
("perl" ,perl) ; for the tests ("perl" ,perl) ; for the tests
("python" ,python-2))) ; ditto ("python" ,python-2))) ; ditto
(inputs (inputs

View file

@ -41,6 +41,7 @@ (define-module (gnu packages maths)
#:use-module (gnu packages gcc) #:use-module (gnu packages gcc)
#:use-module (gnu packages gd) #:use-module (gnu packages gd)
#:use-module (gnu packages ghostscript) #:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk) #:use-module (gnu packages gtk)
#:use-module (gnu packages less) #:use-module (gnu packages less)
#:use-module (gnu packages lisp) #:use-module (gnu packages lisp)
@ -171,7 +172,8 @@ (define-public pspp
("gtksourceview" ,gtksourceview) ("gtksourceview" ,gtksourceview)
("zlib" ,zlib))) ("zlib" ,zlib)))
(native-inputs (native-inputs
`(("perl" ,perl) `(("glib" ,glib "bin") ;for glib-genmarshal
("perl" ,perl)
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
(home-page "http://www.gnu.org/software/pspp/") (home-page "http://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis") (synopsis "Statistical analysis")

View file

@ -21,10 +21,10 @@ database, the `update-desktop-database' program, which we don't provide.
return g_test_run (); return g_test_run ();
--- glib-2.34.3/gio/tests/contenttype.c 2013-01-16 21:22:29.000000000 +0100 --- glib-2.40.0/gio/tests/contenttype.c 2013-01-16 21:22:29.000000000 +0100
+++ glib-2.34.3/gio/tests/contenttype.c 2013-01-16 21:22:33.000000000 +0100 +++ glib-2.40.0/gio/tests/contenttype.c 2013-01-16 21:22:33.000000000 +0100
@@ -207,13 +207,6 @@ main (int argc, char *argv[]) @@ -207,15 +207,6 @@ main (int argc, char *argv[])
{
g_test_init (&argc, &argv, NULL); g_test_init (&argc, &argv, NULL);
- g_test_add_func ("/contenttype/guess", test_guess); - g_test_add_func ("/contenttype/guess", test_guess);
@ -34,18 +34,21 @@ database, the `update-desktop-database' program, which we don't provide.
- g_test_add_func ("/contenttype/executable", test_executable); - g_test_add_func ("/contenttype/executable", test_executable);
- g_test_add_func ("/contenttype/description", test_description); - g_test_add_func ("/contenttype/description", test_description);
- g_test_add_func ("/contenttype/icon", test_icon); - g_test_add_func ("/contenttype/icon", test_icon);
- g_test_add_func ("/contenttype/symbolic-icon", test_symbolic_icon);
- g_test_add_func ("/contenttype/tree", test_tree);
return g_test_run (); return g_test_run ();
} }
--- glib-2.39.1/gio/tests/desktop-app-info.c 2013-06-07 23:46:28.000000000 +0200 --- glib-2.40.0/gio/tests/desktop-app-info.c 2014-03-19 22:50:45.000000000 -0500
+++ glib-2.39.1/gio/tests/desktop-app-info.c 2013-06-07 23:46:32.000000000 +0200 +++ glib-2.40.0/gio/tests/desktop-app-info.c 2014-06-30 14:27:52.543358331 -0500
@@ -699,6 +699,7 @@ main (int argc, @@ -708,6 +708,8 @@
g_setenv ("XDG_DATA_HOME", basedir, TRUE); g_setenv ("XDG_DATA_HOME", basedir, TRUE);
cleanup_subdirs (basedir); cleanup_subdirs (basedir);
+ return 0; + result = g_test_run ();
+ return result;
g_test_add_func ("/desktop-app-info/delete", test_delete); g_test_add_func ("/desktop-app-info/delete", test_delete);
g_test_add_func ("/desktop-app-info/default", test_default); g_test_add_func ("/desktop-app-info/default", test_default);
g_test_add_func ("/desktop-app-info/fallback", test_fallback); g_test_add_func ("/desktop-app-info/fallback", test_fallback);
@ -81,31 +84,33 @@ because that script depends on python-gobject.
The test below depends on the availability /etc/passwd to dbus-daemon. The test below depends on the availability /etc/passwd to dbus-daemon.
--- glib-2.38.0.orig/gio/tests/gdbus-auth.c 2013-05-07 20:26:07.000000000 +0200 --- glib-2.40.0/gio/tests/gdbus-auth.c 2014-02-03 11:40:41.000000000 -0600
+++ glib-2.38.0/gio/tests/gdbus-auth.c 2013-09-30 19:42:27.000000000 +0200 +++ glib-2.40.0/gio/tests/gdbus-auth.c 2014-06-30 15:08:43.719421893 -0500
@@ -284,6 +284,7 @@ @@ -286,6 +286,8 @@
{ {
gint ret; gint ret;
+ return 0; + g_test_init (&argc, &argv, NULL);
+ return g_test_run();
setlocale (LC_ALL, "C"); setlocale (LC_ALL, "C");
temp_dbus_keyrings_setup (); temp_dbus_keyrings_setup ();
The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see The test dbus-appinfo is dropped as it hangs indefinitely since 2.37.5, see
https://launchpad.net/ubuntu/+source/glib2.0/2.37.5-1ubuntu1 https://launchpad.net/ubuntu/+source/glib2.0/2.37.5-1ubuntu1
--- glib-2.38.0.orig/gio/tests/dbus-appinfo.c 2013-09-05 12:43:41.000000000 +0200 --- glib-2.40.0/gio/tests/dbus-appinfo.c 2014-02-03 11:40:41.000000000 -0600
+++ glib-2.38.0/gio/tests/dbus-appinfo.c 2013-09-30 21:57:21.000000000 +0200 +++ glib-2.40.0/gio/tests/dbus-appinfo.c 2014-06-30 14:44:08.215383632 -0500
@@ -278,6 +278,7 @@ @@ -278,7 +278,7 @@
int
main (int argc, char **argv)
{ {
+ return 0;
g_test_init (&argc, &argv, NULL); g_test_init (&argc, &argv, NULL);
session_bus_up (); - g_test_add_func ("/appinfo/dbusappinfo", test_dbus_appinfo);
+ return g_test_run();
return session_bus_run ();
}
The test below fails for unknown reasons (!). The test below fails for unknown reasons (!).

View file

@ -1,30 +0,0 @@
Since guix-daemon runs in a separate networking name space, the only
interface available is "lo". However its index is incremented by one
at each build, so it can end up being greater than 255, leading to an
assertion failure in 'find_ifname_and_index'.
Work around that by directly querying the index of "lo".
--- glib-2.38.0/gio/tests/network-address.c 2013-09-17 20:47:14.000000000 +0200
+++ glib-2.38.0/gio/tests/network-address.c 2013-10-16 21:52:42.000000000 +0200
@@ -117,7 +117,7 @@ test_parse_host (gconstpointer d)
#define SCOPE_ID_TEST_PORT 99
#ifdef HAVE_IF_INDEXTONAME
-static char SCOPE_ID_TEST_IFNAME[IF_NAMESIZE];
+static char SCOPE_ID_TEST_IFNAME[] = "lo";
static int SCOPE_ID_TEST_INDEX;
#else
#define SCOPE_ID_TEST_IFNAME "1"
@@ -131,11 +131,7 @@ find_ifname_and_index (void)
return;
#ifdef HAVE_IF_INDEXTONAME
- for (SCOPE_ID_TEST_INDEX = 1; SCOPE_ID_TEST_INDEX < 255; SCOPE_ID_TEST_INDEX++) {
- if (if_indextoname (SCOPE_ID_TEST_INDEX, SCOPE_ID_TEST_IFNAME))
- break;
- }
- g_assert_cmpstr (SCOPE_ID_TEST_IFNAME, !=, "");
+ SCOPE_ID_TEST_INDEX = if_nametoindex (SCOPE_ID_TEST_IFNAME);
#endif
}

View file

@ -0,0 +1,26 @@
* On i686 floating-point roundoff errors could sometimes cause this check to
fail depending on the elapsed microseconds. Improve rounding by adding a
fractional bit.
* The /timer/stop test fails if compiler optimizations are enabled, which they
are by default. Disable that test.
--- glib-2.40.0/glib/tests/timer.c 2014-03-05 08:05:42.000000000 -0600
+++ glib-2.40.0/glib/tests/timer.c 2014-07-10 16:33:12.746862822 -0500
@@ -35,7 +35,7 @@
elapsed = g_timer_elapsed (timer, &micros);
g_assert_cmpfloat (elapsed, <, 1.0);
- g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6)) % 1000000);
+ g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6 + 0.5)) % 1000000);
g_timer_destroy (timer);
}
@@ -204,7 +204,6 @@
g_test_init (&argc, &argv, NULL);
g_test_add_func ("/timer/basic", test_timer_basic);
- g_test_add_func ("/timer/stop", test_timer_stop);
g_test_add_func ("/timer/continue", test_timer_continue);
g_test_add_func ("/timer/reset", test_timer_reset);
g_test_add_func ("/timeval/add", test_timeval_add);

View file

@ -0,0 +1,16 @@
The tests in race_empty non-deterministically fail with the error message:
** (process:10183): WARNING **: Async activation error activating 'IDL:Empty:1.0' : 'System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred'
FAILED 3 of 17: async activation
--- a/tests/test-activation/bonobo-activation-test.c 2014-07-01 23:45:10.830466301 -0500
+++ b/tests/test-activation/bonobo-activation-test.c 2014-07-01 23:57:53.122485584 -0500
@@ -299,7 +299,7 @@
g_assert (ORBit_small_get_connection_status (ac) ==
ORBIT_CONNECTION_CONNECTED);
- race_empty (&ev);
+ passed+=2;

View file

@ -69,7 +69,8 @@ (define-public poppler
(package-inputs cairo))))) (package-inputs cairo)))))
("glib" ,glib))) ("glib" ,glib)))
(native-inputs (native-inputs
`(("pkg-config" ,pkg-config))) `(("pkg-config" ,pkg-config)
("glib" ,glib "bin"))) ; glib-mkenums, etc.
(arguments (arguments
`(#:tests? #f ; no test data provided with the tarball `(#:tests? #f ; no test data provided with the tarball
#:configure-flags #:configure-flags

View file

@ -106,6 +106,7 @@ (define-public qemu-headless
("attr" ,attr))) ("attr" ,attr)))
(native-inputs `(("pkg-config" ,pkg-config) (native-inputs `(("pkg-config" ,pkg-config)
("python" ,python-2) ; incompatible with Python 3 according to error message ("python" ,python-2) ; incompatible with Python 3 according to error message
("glib" ,glib "bin") ; gtester, etc.
("texinfo" ,texinfo) ("texinfo" ,texinfo)
("perl" ,perl))) ("perl" ,perl)))
(home-page "http://www.qemu-project.org") (home-page "http://www.qemu-project.org")