mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-27 04:59:27 -05:00
gnu: abseil-cpp: Update to 20200923.3.
* gnu/packages/cpp.scm (abseil-cpp): Update to 20200923.3. [arguments]: Enable external googletest. * gnu/packages/patches/abseil-cpp-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
f08a60bbec
commit
c4d616f7c6
3 changed files with 22 additions and 2 deletions
|
@ -786,6 +786,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/abcl-fix-build-xml.patch \
|
%D%/packages/patches/abcl-fix-build-xml.patch \
|
||||||
%D%/packages/patches/ableton-link-system-libraries-debian.patch \
|
%D%/packages/patches/ableton-link-system-libraries-debian.patch \
|
||||||
%D%/packages/patches/abiword-explictly-cast-bools.patch \
|
%D%/packages/patches/abiword-explictly-cast-bools.patch \
|
||||||
|
%D%/packages/patches/abseil-cpp-fix.patch \
|
||||||
%D%/packages/patches/adb-add-libraries.patch \
|
%D%/packages/patches/adb-add-libraries.patch \
|
||||||
%D%/packages/patches/aegis-constness-error.patch \
|
%D%/packages/patches/aegis-constness-error.patch \
|
||||||
%D%/packages/patches/aegis-perl-tempdir1.patch \
|
%D%/packages/patches/aegis-perl-tempdir1.patch \
|
||||||
|
|
|
@ -678,7 +678,7 @@ (define-public tweeny
|
||||||
(define-public abseil-cpp
|
(define-public abseil-cpp
|
||||||
(package
|
(package
|
||||||
(name "abseil-cpp")
|
(name "abseil-cpp")
|
||||||
(version "20200225.2")
|
(version "20200923.3")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
|
@ -687,11 +687,14 @@ (define-public abseil-cpp
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0dwxg54pv6ihphbia0iw65r64whd7v8nm4wwhcz219642cgpv54y"))))
|
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
|
||||||
|
;; Remove after next googletest release and update.
|
||||||
|
(patches (search-patches "abseil-cpp-fix.patch"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
|
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
|
||||||
"-DABSL_RUN_TESTS=ON"
|
"-DABSL_RUN_TESTS=ON"
|
||||||
|
"-DABSL_USE_EXTERNAL_GOOGLETEST=ON"
|
||||||
;; Needed, else we get errors like:
|
;; Needed, else we get errors like:
|
||||||
;;
|
;;
|
||||||
;; ld: CMakeFiles/absl_periodic_sampler_test.dir/internal/periodic_sampler_test.cc.o:
|
;; ld: CMakeFiles/absl_periodic_sampler_test.dir/internal/periodic_sampler_test.cc.o:
|
||||||
|
|
16
gnu/packages/patches/abseil-cpp-fix.patch
Normal file
16
gnu/packages/patches/abseil-cpp-fix.patch
Normal file
|
@ -0,0 +1,16 @@
|
||||||
|
The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
|
||||||
|
in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
|
||||||
|
a googletest release.
|
||||||
|
|
||||||
|
--- a/absl/container/internal/unordered_map_modifiers_test.h
|
||||||
|
+++ b/absl/container/internal/unordered_map_modifiers_test.h
|
||||||
|
@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
||||||
|
+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
|
||||||
|
GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
|
||||||
|
|
Loading…
Reference in a new issue