mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: DarkIce: Update to 1.4.
* gnu/packages/audio.scm (darkice): Update to 1.4. [source]: Update URL. Remove obsolete patch. * gnu/packages/patches/darkice-workaround-fpermissive-error.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
a933ee5591
commit
c827c52ac3
3 changed files with 6 additions and 69 deletions
|
@ -851,7 +851,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/cvs-CVE-2017-12836.patch \
|
||||
%D%/packages/patches/cyrus-sasl-ac-try-run-fix.patch \
|
||||
%D%/packages/patches/date-output-pkg-config-files.patch \
|
||||
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
|
||||
%D%/packages/patches/datefudge-gettimeofday.patch \
|
||||
%D%/packages/patches/dbacl-include-locale.h.patch \
|
||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||
|
|
|
@ -3930,15 +3930,15 @@ (define-public gnaural
|
|||
(define-public darkice
|
||||
(package
|
||||
(name "darkice")
|
||||
(version "1.3")
|
||||
(version "1.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/darkice/darkice/"
|
||||
version "/darkice-" version ".tar.gz"))
|
||||
(uri (string-append "https://github.com/rafael2k/darkice/releases/"
|
||||
"download/v" version "/darkice-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "1rlxds7ssq7nk2in4s46xws7xy9ylxsqgcz85hxjgh17lsm0y39c"))
|
||||
(patches
|
||||
(search-patches "darkice-workaround-fpermissive-error.patch"))))
|
||||
(base32
|
||||
"05yq7lggxygrkd76yiqby3msrgdn082p0qlvmzzv9xbw8hmyra76"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("pkg-config" ,pkg-config)))
|
||||
(inputs `(("lame" ,lame)
|
||||
|
|
|
@ -1,62 +0,0 @@
|
|||
Copied from Debian:
|
||||
<https://sources.debian.org/data/main/d/darkice/1.3-0.2/debian/patches/0001-Cast-float-in-SRC-lib-calls-to-delete-fpermissive-co.patch>
|
||||
|
||||
From 1e2eb18d349f205c70cb2836232825442359b6e3 Mon Sep 17 00:00:00 2001
|
||||
From: belette <ouack23@yahoo.fr>
|
||||
Date: Wed, 26 Oct 2016 02:43:43 +0200
|
||||
Subject: Cast float* in SRC lib calls to delete fpermissive compilation error
|
||||
|
||||
---
|
||||
darkice/trunk/src/FaacEncoder.cpp | 2 +-
|
||||
darkice/trunk/src/OpusLibEncoder.cpp | 2 +-
|
||||
darkice/trunk/src/VorbisLibEncoder.cpp | 2 +-
|
||||
darkice/trunk/src/aacPlusEncoder.cpp | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
--- a/src/FaacEncoder.cpp
|
||||
+++ b/src/FaacEncoder.cpp
|
||||
@@ -164,7 +164,7 @@ FaacEncoder :: write ( const void * buf,
|
||||
if ( converter ) {
|
||||
unsigned int converted;
|
||||
#ifdef HAVE_SRC_LIB
|
||||
- src_short_to_float_array ((short *) b, converterData.data_in, samples);
|
||||
+ src_short_to_float_array ((short *) b, (float *) converterData.data_in, samples);
|
||||
converterData.input_frames = nSamples;
|
||||
converterData.data_out = resampledOffset + (resampledOffsetSize * channels);
|
||||
int srcError = src_process (converter, &converterData);
|
||||
--- a/src/OpusLibEncoder.cpp
|
||||
+++ b/src/OpusLibEncoder.cpp
|
||||
@@ -403,7 +403,7 @@ OpusLibEncoder :: write ( const void * buf,
|
||||
#ifdef HAVE_SRC_LIB
|
||||
(void)inCount;
|
||||
converterData.input_frames = processed;
|
||||
- src_short_to_float_array (shortBuffer, converterData.data_in, totalSamples);
|
||||
+ src_short_to_float_array (shortBuffer, (float *) converterData.data_in, totalSamples);
|
||||
int srcError = src_process (converter, &converterData);
|
||||
if (srcError)
|
||||
throw Exception (__FILE__, __LINE__, "libsamplerate error: ", src_strerror (srcError));
|
||||
--- a/src/VorbisLibEncoder.cpp
|
||||
+++ b/src/VorbisLibEncoder.cpp
|
||||
@@ -337,7 +337,7 @@ VorbisLibEncoder :: write ( const void * buf,
|
||||
int converted;
|
||||
#ifdef HAVE_SRC_LIB
|
||||
converterData.input_frames = nSamples;
|
||||
- src_short_to_float_array (shortBuffer, converterData.data_in, totalSamples);
|
||||
+ src_short_to_float_array (shortBuffer, (float *) converterData.data_in, totalSamples);
|
||||
int srcError = src_process (converter, &converterData);
|
||||
if (srcError)
|
||||
throw Exception (__FILE__, __LINE__, "libsamplerate error: ", src_strerror (srcError));
|
||||
--- a/src/aacPlusEncoder.cpp
|
||||
+++ b/src/aacPlusEncoder.cpp
|
||||
@@ -155,7 +155,7 @@ aacPlusEncoder :: write ( const void * buf,
|
||||
if ( converter ) {
|
||||
unsigned int converted;
|
||||
#ifdef HAVE_SRC_LIB
|
||||
- src_short_to_float_array ((short *) b, converterData.data_in, samples);
|
||||
+ src_short_to_float_array ((short *) b, (float *) converterData.data_in, samples);
|
||||
converterData.input_frames = nSamples;
|
||||
converterData.data_out = resampledOffset + (resampledOffsetSize * channels);
|
||||
int srcError = src_process (converter, &converterData);
|
||||
--
|
||||
2.11.0
|
||||
|
Loading…
Reference in a new issue