Merge remote-tracking branch 'origin/master' into core-updates

This commit is contained in:
Andreas Enge 2023-04-25 15:19:29 +02:00
commit c919bfefd9
No known key found for this signature in database
GPG key ID: F7D5C9BF765C61E3
19 changed files with 375 additions and 114 deletions

View file

@ -1041,6 +1041,7 @@ dist_patch_DATA = \
%D%/packages/patches/dee-vapi.patch \ %D%/packages/patches/dee-vapi.patch \
%D%/packages/patches/desmume-gcc6-fixes.patch \ %D%/packages/patches/desmume-gcc6-fixes.patch \
%D%/packages/patches/desmume-gcc7-fixes.patch \ %D%/packages/patches/desmume-gcc7-fixes.patch \
%D%/packages/patches/dezyne-add-missing-shebangs.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \ %D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/diffutils-fix-signal-processing.patch \ %D%/packages/patches/diffutils-fix-signal-processing.patch \
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \ %D%/packages/patches/dkimproxy-add-ipv6-support.patch \

View file

@ -329,7 +329,7 @@ (define-public cmh
(define-public giac (define-public giac
(package (package
(name "giac") (name "giac")
(version "1.9.0-43") (version "1.9.0-45")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -341,7 +341,7 @@ (define-public giac
"~parisse/debian/dists/stable/main/source/" "~parisse/debian/dists/stable/main/source/"
"giac_" version ".tar.gz")) "giac_" version ".tar.gz"))
(sha256 (sha256
(base32 "1fqs9nxjj0kimisfsfhscgzfmc470lyzm63hwla7ka2iqq3s7bp3")))) (base32 "0yxsl1vvwcbpwcmzp9v9rfm9djmapab0nhb3gs7zmjv5yvzbgj4d"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
(list (list

View file

@ -14,6 +14,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org> ;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me> ;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -381,3 +382,39 @@ (define-public curlie
on features and performance. All @code{curl} options are exposed with syntax on features and performance. All @code{curl} options are exposed with syntax
sugar and output formatting inspired from @code{httpie}.") sugar and output formatting inspired from @code{httpie}.")
(license license:expat))) (license license:expat)))
(define-public trurl
(package
(name "trurl")
(version "0.5")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/curl/trurl")
(commit (string-append name "-" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1mvkpjs6wnz5hzmp2iglik85zljrzglsa6fm839l78fhw89dg3w6"))))
(build-system gnu-build-system)
(arguments
(list
#:test-target "test"
#:make-flags #~(list (string-append "CC=" #$(cc-for-target))
(string-append "PREFIX=" #$output))
#:phases
#~(modify-phases %standard-phases
(delete 'configure))))
(native-inputs (list python))
;; Tests failed on older curl version
;; (see https://github.com/curl/trurl/pull/165)
(inputs (list curl-7.84.0))
(home-page "https://curl.se/trurl/")
(synopsis "Command line tool for URL parsing and manipulatio")
(description "@code{trurl} is a tool in a similar spirit of @code{tr} but
for URLs. Here, @code{tr} stands for translate or transpose.
@code{trurl} is a command line tool that parses and manipulates URLs, designed
to help shell script authors everywhere.")
(license (license:non-copyleft "file://COPYING"
"See COPYING in the distribution."))))

View file

@ -22,6 +22,7 @@ (define-module (gnu packages dezyne)
#:use-module ((guix licenses) #:prefix license:) #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix gexp) #:use-module (guix gexp)
#:use-module (guix packages) #:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages base) #:use-module (gnu packages base)
#:use-module (gnu packages bash) #:use-module (gnu packages bash)
#:use-module (gnu packages guile) #:use-module (gnu packages guile)
@ -37,6 +38,7 @@ (define-public dezyne
(method url-fetch) (method url-fetch)
(uri (string-append "https://dezyne.org/download/dezyne/" (uri (string-append "https://dezyne.org/download/dezyne/"
name "-" version ".tar.gz")) name "-" version ".tar.gz"))
(patches (search-patches "dezyne-add-missing-shebangs.patch"))
(sha256 (sha256
(base32 "1v0anwr0iic26ck796b29dfyj1dxkjf935g134z98s95hvzzrhm3")))) (base32 "1v0anwr0iic26ck796b29dfyj1dxkjf935g134z98s95hvzzrhm3"))))
(inputs (list bash-minimal (inputs (list bash-minimal

View file

@ -582,7 +582,7 @@ (define-public openboard
(define-public fet (define-public fet
(package (package
(name "fet") (name "fet")
(version "6.8.7") (version "6.9.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -591,7 +591,7 @@ (define-public fet
(list (string-append directory base) (list (string-append directory base)
(string-append directory "old/" base)))) (string-append directory "old/" base))))
(sha256 (sha256
(base32 "0wcl2scgqf1vj0zy5an7hhhmsl5j1y605fcz0d7ylbzw5ixnbf1m")))) (base32 "1lnw58ga1ldhqfznclmk9l21698pg152w3slq2cwmr69ywqr5wys"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
(list (list

View file

@ -3715,14 +3715,14 @@ (define-public emacs-async
(define-public emacs-auctex (define-public emacs-auctex
(package (package
(name "emacs-auctex") (name "emacs-auctex")
(version "13.1.10") (version "13.2.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/" (uri (string-append "https://elpa.gnu.org/packages/"
"auctex-" version ".tar")) "auctex-" version ".tar"))
(sha256 (sha256
(base32 "0vxf3aw7j73d0cbfh8d5fp5gyi7vxq9vb7fqxmxxs24pvdnlym15")))) (base32 "1jk05cca7lrwykj3by4s7c198bffam0mga7hgwmcz5bgxl79ijvf"))))
(build-system emacs-build-system) (build-system emacs-build-system)
;; We use 'emacs' because AUCTeX requires dbus at compile time ;; We use 'emacs' because AUCTeX requires dbus at compile time
;; ('emacs-minimal' does not provide dbus). ;; ('emacs-minimal' does not provide dbus).
@ -17700,14 +17700,14 @@ (define-public emacs-mini-frame
(define-public emacs-posframe (define-public emacs-posframe
(package (package
(name "emacs-posframe") (name "emacs-posframe")
(version "1.4.1") (version "1.4.2")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/" (uri (string-append "https://elpa.gnu.org/packages/"
"posframe-" version ".tar")) "posframe-" version ".tar"))
(sha256 (sha256
(base32 "02kw3d6760015q61sryw8k3zqdnzhcwwyfjfysbfs07cljkqpjnh")))) (base32 "0ca43wgbr0n5ri7cyxjmn7blq59xq43rx9z9q02a2j4yn05w8nss"))))
(build-system emacs-build-system) (build-system emacs-build-system)
;; emacs-minimal does not include the function font-info. ;; emacs-minimal does not include the function font-info.
(arguments (arguments
@ -20964,26 +20964,26 @@ (define-public emacs-ergoemacs-mode
(license license:gpl3+))) (license license:gpl3+)))
(define-public emacs-password-store (define-public emacs-password-store
(let ((commit "918992c19231b33b3d4a3288a7288a620e608cb4")
(revision "1"))
(package (package
(name "emacs-password-store") (name "emacs-password-store")
;; The emacs package version does not match the password-store version, ;; The emacs package version does not match the password-store version,
;; even though it is part of the same repository. When updating, look ;; even though it is part of the same repository. When updating, look at
;; at the version declared in password-store.el. ;; the version declared in password-store.el.
(version (git-version "2.1.4" revision commit)) (version "2.3.0")
(source (origin (source
(origin
(method git-fetch) (method git-fetch)
(uri (git-reference (uri (git-reference
(url "git://git.zx2c4.com/password-store") (url "git://git.zx2c4.com/password-store")
(commit commit))) (commit "26d2dae04bb76a87be6960861c10432820cd5d55")))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 (base32
"0ni62f4pq96g0i0q66bch1dl9k4zqwhg7xaf746k3gbbqxcdh3vi")))) "1pkx6pgkkpddxrshzq3x8ilfwqjw9gawnbbskcbssxc88wrpbcjb"))))
(build-system emacs-build-system) (build-system emacs-build-system)
(arguments (arguments
(list #:phases (list
#:phases
#~(modify-phases %standard-phases #~(modify-phases %standard-phases
(add-after 'unpack 'extract-el-file (add-after 'unpack 'extract-el-file
(lambda _ (lambda _
@ -21001,13 +21001,13 @@ (define-public emacs-password-store
(inputs (inputs
(list password-store)) (list password-store))
(propagated-inputs (propagated-inputs
(list emacs-auth-source-pass emacs-s emacs-with-editor)) (list emacs-s emacs-with-editor))
(home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs") (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
(synopsis "Password store (pass) support for Emacs") (synopsis "Password store (pass) support for Emacs")
(description (description
"This package provides functions for working with pass (\"the "This package provides functions for working with pass (\"the
standard Unix password manager\").") standard Unix password manager\").")
(license license:gpl3+)))) (license license:gpl3+)))
(define-public emacs-password-store-otp (define-public emacs-password-store-otp
(package (package
@ -24950,7 +24950,7 @@ (define-public emacs-eshell-bookmark
(define-public emacs-eshell-syntax-highlighting (define-public emacs-eshell-syntax-highlighting
(package (package
(name "emacs-eshell-syntax-highlighting") (name "emacs-eshell-syntax-highlighting")
(version "0.4") (version "0.5")
(source (source
(origin (origin
(method git-fetch) (method git-fetch)
@ -24959,7 +24959,7 @@ (define-public emacs-eshell-syntax-highlighting
(commit (string-append "v" version)))) (commit (string-append "v" version))))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "1ib46fs70grx7rmw45i817v1dyvcj0b8xdmndvaz7papiimf6vrj")))) (base32 "1la604vdj56s934j16yz8rlvzhd69433rrbgfyw9c7njxqldwcs7"))))
(build-system emacs-build-system) (build-system emacs-build-system)
(home-page "https://github.com/akreisher/eshell-syntax-highlighting") (home-page "https://github.com/akreisher/eshell-syntax-highlighting")
(synopsis "Add syntax highlighting to Eshell") (synopsis "Add syntax highlighting to Eshell")
@ -35141,6 +35141,31 @@ (define-public emacs-rocket-chat
service.") service.")
(license license:expat)))) (license license:expat))))
(define-public emacs-xonsh-mode
;; There is no tagged release yet.
(let ((commit "7fa581524533a9b6b770426e4445e571a69e469d")
(revision "0"))
(package
(name "emacs-xonsh-mode")
(version (git-version "0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/seanfarley/xonsh-mode")
(commit commit)))
(sha256
(base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
(build-system emacs-build-system)
(home-page "https://github.com/seanfarley/xonsh-mode")
(synopsis "Emacs major mode for editing Xonsh files")
(description
"This package implements a major mode for Xonsh scripts. The basic
functionality includes syntax highlight for Xonsh operators. Files with the
@file{.xonshrc} or @file{.xsh} extension are automatically opened with this
mode.")
(license license:gpl3+))))
(define-public emacs-monokai-theme (define-public emacs-monokai-theme
(package (package
(name "emacs-monokai-theme") (name "emacs-monokai-theme")

View file

@ -1152,6 +1152,83 @@ (define-public cowsay
tired of cows, a variety of other ASCII-art messengers are available.") tired of cows, a variety of other ASCII-art messengers are available.")
(license license:gpl3+))) (license license:gpl3+)))
(define-public deal
(package
(name "deal")
(version "3.1.11")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/gtwilliams/deal")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1wcrx3yq5ycnkdnygcq80ljpgc9iwyrr8zayprzvbibvj77hdm0c"))))
(build-system gnu-build-system)
(arguments
(list
#:test-target "test"
#:make-flags
#~(let* ((tcl #$(this-package-input "tcl"))
(tcl-version #$(version-major+minor (package-version tcl))))
(list "CPPFLAGS += -O3"
(string-append "CC=" #$(cc-for-target))
(string-append "TCL_INCL=" tcl "/include")
(string-append "LDFLAGS=-L" tcl "/lib"
" -ltcl" tcl-version
" -lm")
(string-append "DATA_DIR=" #$output "/share/deal/")))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'locate-pod2man
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile"
(("/usr/bin/pod2man")
(search-input-file inputs "/bin/pod2man")))))
(delete 'configure) ;no configure script
;; Prevent the error: "Makefile:248: Make.dep: No such file
;; or directory".
(add-before 'build 'create-Make.dep
(lambda _
(call-with-output-file "Make.dep" (const #t))))
;; There is no install target. Do everything manually.
(replace 'install
(lambda _
(let ((bin (string-append #$output "/bin"))
(man (string-append #$output "/share/man/man6"))
(data (string-append #$output "/share/deal")))
(install-file "deal" bin)
(install-file "deal.6" man)
(install-file "deal.tcl" data)
(for-each (lambda (d)
(let ((target (string-append data "/" d)))
(mkdir-p target)
(copy-recursively d target)))
'("ex" "format" "input" "lib")))))
;; Tests need to happen once the data is properly installed
;; because the "deal.tcl" script file location is hard-coded
;; in the "deal" binary.
(delete 'check)
(add-after 'install 'check
(assoc-ref %standard-phases 'check)))))
(native-inputs
(list perl))
(inputs
(list tcl))
(home-page "https://bridge.thomasoandrews.com/deal/")
(synopsis "Bridge hand generator")
(description
"This program generates bridge hands. It can be told to generate only
hands satisfying conditions like being balanced, having a range of
High Cards Points (HCP), controls, or other user-definable properties.
Hands can be output in various formats, like PBN for feeding to other
bridge programs, Deal itself, or split up into a file per player for
practise.")
(license (list license:gpl2+
license:gpl1+ ;ansidecl.h
license:bsd-3)))) ;random.c
(define-public falltergeist (define-public falltergeist
(package (package
(name "falltergeist") (name "falltergeist")
@ -1993,7 +2070,7 @@ (define-public ltris
(define-public nethack (define-public nethack
(package (package
(name "nethack") (name "nethack")
(version "3.6.6") (version "3.6.7")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -2001,7 +2078,7 @@ (define-public nethack
(string-append "https://www.nethack.org/download/" version "/nethack-" (string-append "https://www.nethack.org/download/" version "/nethack-"
(string-join (string-split version #\.) "") "-src.tgz")) (string-join (string-split version #\.) "") "-src.tgz"))
(sha256 (sha256
(base32 "1liyckjp34j354qnxc1zn9730lh1p2dabrg1hap24z6xnqx0rpng")))) (base32 "1cmc596x8maixi2bkx9kblp3daxw156ahnklc656dygbdpgngkwq"))))
(native-inputs (native-inputs
(list bison flex)) (list bison flex))
(inputs (inputs
@ -8646,7 +8723,8 @@ (define-public slimevolley
;; missing from command line". ;; missing from command line".
#:configure-flags (list "-DCMAKE_EXE_LINKER_FLAGS=-lm"))) #:configure-flags (list "-DCMAKE_EXE_LINKER_FLAGS=-lm")))
(native-inputs (native-inputs
`(("gettext" ,gettext-minimal))) `(("gcc-7" ,gcc-7)
("gettext" ,gettext-minimal)))
(inputs (inputs
`(("sdl" ,(sdl-union (list sdl sdl-image sdl-net sdl-ttf))))) `(("sdl" ,(sdl-union (list sdl sdl-image sdl-net sdl-ttf)))))
(home-page "https://slime.tuxfamily.org/") (home-page "https://slime.tuxfamily.org/")

View file

@ -9769,8 +9769,8 @@ (define-public ecl-trivial-macroexpand-all
(sbcl-package->ecl-package sbcl-trivial-macroexpand-all)) (sbcl-package->ecl-package sbcl-trivial-macroexpand-all))
(define-public sbcl-serapeum (define-public sbcl-serapeum
(let ((commit "fbfd2a219fb22c70c1c5b86910c5106fd0f9b447") (let ((commit "ce6c3b320cde38767caea2b86afa87ff280b9c11")
(revision "8")) (revision "9"))
(package (package
(name "sbcl-serapeum") (name "sbcl-serapeum")
(version (git-version "0.0.0" revision commit)) (version (git-version "0.0.0" revision commit))
@ -9783,7 +9783,7 @@ (define-public sbcl-serapeum
(commit commit))) (commit commit)))
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 "0gz70hwlsyawmm7j85yjg449hpy57w5jdd7rkal6lhmmfnl0nsbp")))) (base32 "0vpxgvxniyn12wkhmav2iq4x4bj12hjrsf2ajwcapp0sh06qg1j9"))))
(build-system asdf-build-system/sbcl) (build-system asdf-build-system/sbcl)
(inputs (inputs
(list sbcl-alexandria (list sbcl-alexandria
@ -26307,7 +26307,7 @@ (define-public ecl-nkeymaps
(define-public sbcl-njson (define-public sbcl-njson
(package (package
(name "sbcl-njson") (name "sbcl-njson")
(version "0.2.3") (version "1.0.0")
(source (origin (source (origin
(method git-fetch) (method git-fetch)
(uri (git-reference (uri (git-reference
@ -26316,12 +26316,12 @@ (define-public sbcl-njson
(file-name (git-file-name "cl-njson" version)) (file-name (git-file-name "cl-njson" version))
(sha256 (sha256
(base32 (base32
"11s6qq719zlrpy0kb1id9qnrm73yrc3xi560k4s8cj79fy4nj0ib")))) "1apwccrvivrq57rlrw6vffrn3a5hikk10s0dndszjw5ri29b3qyd"))))
(build-system asdf-build-system/sbcl) (build-system asdf-build-system/sbcl)
(inputs (list sbcl-cl-json)) (inputs (list sbcl-cl-json))
(native-inputs (list sbcl-lisp-unit2)) (native-inputs (list sbcl-lisp-unit2))
(arguments (arguments
'(#:asd-systems '("njson" "njson/aliases" "njson/cl-json"))) '(#:asd-systems '("njson" "njson/cl-json")))
(home-page "https://github.com/atlas-engineer/njson") (home-page "https://github.com/atlas-engineer/njson")
(synopsis "JSON handling framework for Common Lisp") (synopsis "JSON handling framework for Common Lisp")
(description (description
@ -26333,7 +26333,6 @@ (define-public sbcl-njson
Conveniences that NJSON provides are: Conveniences that NJSON provides are:
@itemize @itemize
@item @code{encode} and @code{decode} as single entry points for JSON reading @item @code{encode} and @code{decode} as single entry points for JSON reading
and writing, be it from streams/string/files, or from those. and writing, be it from streams/string/files, or from those.

View file

@ -53,6 +53,7 @@
;;; Copyright © 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de> ;;; Copyright © 2023 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2023 Antero Mejr <antero@mailbox.org> ;;; Copyright © 2023 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com> ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -205,14 +206,14 @@ (define-module (gnu packages music)
(define-public audacious (define-public audacious
(package (package
(name "audacious") (name "audacious")
(version "4.2") (version "4.3")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://distfiles.audacious-media-player.org/" (uri (string-append "https://distfiles.audacious-media-player.org/"
"audacious-" version ".tar.bz2")) "audacious-" version ".tar.bz2"))
(sha256 (sha256
(base32 "1cq4brifp992dhg0sbf180jjdv137g5wk8ac7hmzx0d4f3j09czy")))) (base32 "14chrsh1dacw5r2qpzw0rhg2lchpbya90y96r6w0vry78p44sn17"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:configure-flags `(#:configure-flags
@ -256,7 +257,7 @@ (define-public audacious
(uri (string-append "https://distfiles.audacious-media-player.org/" (uri (string-append "https://distfiles.audacious-media-player.org/"
"audacious-plugins-" version ".tar.bz2")) "audacious-plugins-" version ".tar.bz2"))
(sha256 (sha256
(base32 "0zs1k91z272ql49qr7kxlxb0lajamc9ra41pgj3ynh8h7afgd83g")))) (base32 "1ilzz2fv0mirlfhzhrcbccv996slj65z1ifibzrx0w5xqk4gcbk6"))))
("gettext" ,gettext-minimal) ("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for gdbus-codegen ("glib:bin" ,glib "bin") ; for gdbus-codegen
("pkg-config" ,pkg-config))) ("pkg-config" ,pkg-config)))
@ -290,6 +291,7 @@ (define-public audacious
mesa mesa
mpg123 mpg123
neon neon
opusfile
pulseaudio pulseaudio
sdl2 sdl2
soxr soxr
@ -4139,7 +4141,7 @@ (define-public milkytracker
(define-public schismtracker (define-public schismtracker
(package (package
(name "schismtracker") (name "schismtracker")
(version "20190805") (version "20221201")
(source (origin (source (origin
(method git-fetch) (method git-fetch)
(uri (git-reference (uri (git-reference
@ -4148,26 +4150,27 @@ (define-public schismtracker
(file-name (git-file-name name version)) (file-name (git-file-name name version))
(sha256 (sha256
(base32 (base32
"0qqps20vvn3rgpg8174bjrrm38gqcci2z5z4c1r1vhbccclahgsd")) "11yy5zrdfvnwzwdwmc3s3lx1ymwiyp1si5mmv4h9qxipd9j96ijp"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
;; Remove use of __DATE__ and __TIME__ for reproducibility. ;; Remove use of __DATE__ and __TIME__ for reproducibility.
`(begin #~(substitute* "schism/version.c"
(substitute* "schism/version.c"
(("Schism Tracker built %s %s.*$") (("Schism Tracker built %s %s.*$")
(string-append "Schism Tracker version " ,version "\") ;"))) (string-append
#t)))) "Schism Tracker version " #$version "\") ;"))))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:phases (list #:configure-flags #~(list "--with-flac=yes" "--with-x11=no")
(modify-phases %standard-phases #:phases #~(modify-phases %standard-phases
(add-before 'configure 'link-libm (add-before 'configure 'link-libm
(lambda _ (setenv "LIBS" "-lm") #t))))) (lambda _
(setenv "LIBS" "-lm"))))))
(native-inputs (native-inputs
(list autoconf automake python)) (list autoconf automake python))
(inputs (inputs
(list alsa-lib ; for asound dependency (list alsa-lib ; for asound dependency
libx11 libxext sdl)) flac
sdl2))
(home-page "https://schismtracker.org") (home-page "https://schismtracker.org")
(synopsis "Oldschool sample-based music composition tool") (synopsis "Oldschool sample-based music composition tool")
(description (description

View file

@ -1377,8 +1377,8 @@ (define-public gwl/next
"0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc"))))))) "0k9zkdyyzir3fvlbcfcqy17k28b51i20rpbjwlx2i1mwd2pw9cxc")))))))
(define-public guix-build-coordinator (define-public guix-build-coordinator
(let ((commit "2efcd8b11954708f0b2f26ce6eb9d785e2f6aae4") (let ((commit "6a4e827f304178d3d20c2037b4f1bf62e969ddce")
(revision "78")) (revision "79"))
(package (package
(name "guix-build-coordinator") (name "guix-build-coordinator")
(version (git-version "0" revision commit)) (version (git-version "0" revision commit))
@ -1389,7 +1389,7 @@ (define-public guix-build-coordinator
(commit commit))) (commit commit)))
(sha256 (sha256
(base32 (base32
"1s7q3bn1cccbafd5b4dk0xn2r5qjabl7rclbwf7hfjj7csv8ag2i")) "1w4iqmv493rs94dc2h6l3dnhx2513pz1fknzl6a643d2z6bkb7zj"))
(file-name (string-append name "-" version "-checkout")))) (file-name (string-append name "-" version "-checkout"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments

View file

@ -0,0 +1,61 @@
Upstream status: Taken from upstream development.
From aace425e41247c1dd6b16eb7eabce50be7310d15 Mon Sep 17 00:00:00 2001
From: Janneke Nieuwenhuizen <janneke@gnu.org>
Date: Mon, 24 Apr 2023 16:58:32 +0200
Subject: [PATCH] DRAFT test: Add missing shebangs to run scripts.
This fixes `make check' on current ci.guix.gnu.org.
* test/all/parse_import_order/run,
test/all/parse_locations/run,
test/all/parse_peg_locations/run: Add #! /bin/sh.
---
test/all/parse_import_order/run | 3 ++-
test/all/parse_locations/run | 3 ++-
test/all/parse_peg_locations/run | 3 ++-
3 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/test/all/parse_import_order/run b/test/all/parse_import_order/run
index 6e231de4f9..c383e4f223 100755
--- a/test/all/parse_import_order/run
+++ b/test/all/parse_import_order/run
@@ -1,6 +1,7 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
-# Copyright © 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2022, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
diff --git a/test/all/parse_locations/run b/test/all/parse_locations/run
index 0b092b26dd..6c48ee1392 100755
--- a/test/all/parse_locations/run
+++ b/test/all/parse_locations/run
@@ -1,7 +1,8 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
# Copyright © 2021 Paul Hoogendijk <paul@dezyne.org>
-# Copyright © 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2020, 2021, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
diff --git a/test/all/parse_peg_locations/run b/test/all/parse_peg_locations/run
index 5b5ced0bb4..5206a23db6 100755
--- a/test/all/parse_peg_locations/run
+++ b/test/all/parse_peg_locations/run
@@ -1,6 +1,7 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
-# Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2020, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
--
2.39.2

View file

@ -34,13 +34,13 @@ (define-module (gnu packages purescript)
(define-public purescript (define-public purescript
(package (package
(name "purescript") (name "purescript")
(version "0.15.7") (version "0.15.8")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (hackage-uri "purescript" version)) (uri (hackage-uri "purescript" version))
(sha256 (sha256
(base32 "1krjkgmxpfqf5a1jqs7qbg6r7ball1464zw6vgrdfzl9057c6l4f")))) (base32 "1h5d5hjc9hrlk718lf62qzaq1l6ppr0l2b3fl78csyh86cihh750"))))
(build-system haskell-build-system) (build-system haskell-build-system)
(properties '((upstream-name . "purescript"))) (properties '((upstream-name . "purescript")))
(inputs (list ghc-aeson (inputs (list ghc-aeson

View file

@ -1090,38 +1090,29 @@ (define-public python-re-assert
(define-public python-pytest-trio (define-public python-pytest-trio
(package (package
(name "python-pytest-trio") (name "python-pytest-trio")
(version "0.8.0") (version "0.7.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (pypi-uri "pytest-trio" version)) (uri (pypi-uri "pytest-trio" version))
(sha256 (sha256
(base32 "0bmmdyjqj5v4a637i4rzm55crv6v3nj268as6x9nr7m76rixnqw3")))) (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
(build-system python-build-system) (build-system python-build-system)
(arguments (arguments
`(#:phases `(#:phases
(modify-phases %standard-phases (modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
(substitute* "setup.py"
(("pytest >= 7.2.0")
"pytest"))))
(replace 'check (replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys) (lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests? (when tests?
(invoke (add-installed-pythonpath inputs outputs)
"pytest" "-W" "error" "-ra" "-v" "--pyargs" (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
"pytest_trio" "--verbose" "--cov" "-k" "pytest_trio" "--verbose" "--cov" "-k"
(string-append (string-append
;; These tests require network. ;; Needs network
"not test_async_yield_fixture_with_nursery" "not test_async_yield_fixture_with_nursery"
" and not test_try" " and not test_try"
;; No keyboard interrupt in our build environment. ;; No keyboard interrupt in our build environment.
"and not test_actual_test " " and not test_actual_test"))))))))
;; These tests fail due to unclean teardown (see:
;; https://github.com/python-trio/pytest-trio/issues/122).
"and not crashed_teardown "
"and not test_error_collection "))))))))
(native-inputs (native-inputs
(list python-hypothesis python-pytest python-pytest-cov)) (list python-hypothesis python-pytest python-pytest-cov))
(propagated-inputs (propagated-inputs

View file

@ -136,6 +136,7 @@
;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com> ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu> ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com> ;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -20800,6 +20801,30 @@ (define-public python-translate-toolkit
several utilities, as well as an API for building localization tools.") several utilities, as well as an API for building localization tools.")
(license license:gpl2+))) (license license:gpl2+)))
(define-public python-gtts
(package
(name "python-gtts")
(version "2.3.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "gTTS" version))
(sha256
(base32
"1jsg1prpzr7gj5sn385mkv2v1i8xfc83ycm87hvsi2j0y366plps"))))
(build-system pyproject-build-system)
(arguments
;; Disable tests that require internet.
(list #:test-flags '(list "-k" "not net")))
(native-inputs
(list python-pytest python-testfixtures python-click python-requests))
(home-page "https://github.com/pndurette/gTTS")
(synopsis "Google Translate text-to-speech interface")
(description
"Google Text-to-Speech (gTTS) is a Python library and CLI tool to
interface with the Google Translate text-to-speech API. It lets you write
spoken MP3 data to a file, a file-like object (bytestring) for further audio
manipulation, or @code{stdout}.")
(license license:expat)))
(define-public python-packaging (define-public python-packaging
(package/inherit python-packaging-bootstrap (package/inherit python-packaging-bootstrap
@ -24698,13 +24723,13 @@ (define-public python-outcome
(define-public python-trio (define-public python-trio
(package (package
(name "python-trio") (name "python-trio")
(version "0.22.0") (version "0.21.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (pypi-uri "trio" version)) (uri (pypi-uri "trio" version))
(sha256 (sha256
(base32 "1kxa9v0cds0xnklvzppv4ix4xg81r73p5pm4qlvv2iqa832z2s6f")))) (base32 "04qwzy4295ajxpns0hrmn3asma80sjpimzpb3i877vwynsvkjgsj"))))
(build-system python-build-system) (build-system python-build-system)
(arguments (arguments
`(#:phases `(#:phases
@ -24737,6 +24762,8 @@ (define-public python-trio
" and not test_locals_destroyed_promptly_on_cancel" " and not test_locals_destroyed_promptly_on_cancel"
" and not test_ipython_exc_handler" " and not test_ipython_exc_handler"
" and not test_for_leaking_fds" " and not test_for_leaking_fds"
;; Signals dont work in the build sandbox.
" and not test_open_signal_receiver"
;; These try to raise KeyboardInterrupt which does not work ;; These try to raise KeyboardInterrupt which does not work
;; in the build environment. ;; in the build environment.
" and not test_ki_self" " and not test_ki_self"

View file

@ -421,14 +421,14 @@ (define-public fsearch
(define-public recoll (define-public recoll
(package (package
(name "recoll") (name "recoll")
(version "1.32.7") (version "1.34.0")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://www.lesbonscomptes.com/recoll/" (uri (string-append "https://www.lesbonscomptes.com/recoll/"
"recoll-" version ".tar.gz")) "recoll-" version ".tar.gz"))
(sha256 (sha256
(base32 "1fkx6dk8s808ay4hf7ycfcs38kywmavsjqm02pwrnl8bpgsac26a")))) (base32 "0s26b737brxp5hpqcwfxg19z40w6acnnr63ghrnzzjwxqz1ambkv"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
`(#:configure-flags `(#:configure-flags
@ -436,6 +436,7 @@ (define-public recoll
"--disable-python-module" "--disable-python-module"
"--without-systemd" "--without-systemd"
"--with-inotify" "--with-inotify"
"--enable-recollq"
(string-append "QMAKEPATH=" (assoc-ref %build-inputs "qtbase") (string-append "QMAKEPATH=" (assoc-ref %build-inputs "qtbase")
"/bin/qmake")) "/bin/qmake"))
#:phases #:phases

View file

@ -807,14 +807,14 @@ (define-public pdsh
(define-public python-asyncssh (define-public python-asyncssh
(package (package
(name "python-asyncssh") (name "python-asyncssh")
(version "2.11.0") (version "2.13.1")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (pypi-uri "asyncssh" version)) (uri (pypi-uri "asyncssh" version))
(sha256 (sha256
(base32 (base32
"0mkvyv2fmbdfnfdh7g2im0gxnp8hwxv5g1xdazfsipd9ggknrhsr")))) "11zq9ywzgyljzihdygawzad0ydly0l32zvz11liwyi8bbk087fzb"))))
(build-system python-build-system) (build-system python-build-system)
(propagated-inputs (propagated-inputs
(list python-cryptography python-pyopenssl python-gssapi (list python-cryptography python-pyopenssl python-gssapi

View file

@ -1450,6 +1450,10 @@ (define-public alacritty
(lambda* (#:key inputs outputs #:allow-other-keys) (lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "alacritty_terminal/Cargo.toml" (substitute* "alacritty_terminal/Cargo.toml"
(("0.22.0") "^0.23.0")))) (("0.22.0") "^0.23.0"))))
(add-after 'unpack 'patch-xdg-open
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "alacritty/src/config/ui_config.rs"
(("xdg-open") (search-input-file inputs "/bin/xdg-open")))))
(add-after 'configure 'add-absolute-library-references (add-after 'configure 'add-absolute-library-references
(lambda* (#:key inputs cargo-inputs vendor-dir #:allow-other-keys) (lambda* (#:key inputs cargo-inputs vendor-dir #:allow-other-keys)
(let* ((glutin-name ,(package-name rust-glutin-0.26)) (let* ((glutin-name ,(package-name rust-glutin-0.26))
@ -1547,6 +1551,7 @@ (define-public alacritty
("rust-unicode-width" ,rust-unicode-width-0.1) ("rust-unicode-width" ,rust-unicode-width-0.1)
("rust-wayland-client" ,rust-wayland-client-0.28) ("rust-wayland-client" ,rust-wayland-client-0.28)
("rust-winapi" ,rust-winapi-0.3) ("rust-winapi" ,rust-winapi-0.3)
("xdg-utils" ,xdg-utils)
("wayland" ,wayland))) ("wayland" ,wayland)))
(native-search-paths (native-search-paths
;; FIXME: This should only be located in 'ncurses'. Nonetheless it is ;; FIXME: This should only be located in 'ncurses'. Nonetheless it is

View file

@ -26,6 +26,7 @@
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com> ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org> ;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com> ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; ;;;
;;; This file is part of GNU Guix. ;;; This file is part of GNU Guix.
;;; ;;;
@ -8972,6 +8973,36 @@ (define-public texmaker
develop documents with LaTeX, in a single application.") develop documents with LaTeX, in a single application.")
(license license:gpl2+))) (license license:gpl2+)))
(define-public texstudio
(package
(name "texstudio")
(version "4.5.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/texstudio-org/texstudio")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
"0bzdcsc0273809hx04zqd2famq05q9rpvqcbqhkjqnqp9vxbisig"))))
(build-system qt-build-system)
(arguments
`(#:tests? #f)) ;tests work only with debug build
(native-inputs
(list pkg-config
poppler-qt5
qtdeclarative-5
qtsvg-5
qttools-5))
(home-page "https://www.texstudio.org/")
(synopsis "Feature-packed LaTeX editor")
(description
"TeXstudio is an integrated writing environment for creating LaTeX
documents. It makes writing LaTeX comfortable by providing features such as
syntax-highlighting, an integrated viewer and reference checking.")
(license license:gpl3)))
(define-public dvisvgm (define-public dvisvgm
(package (package
(name "dvisvgm") (name "dvisvgm")

View file

@ -703,7 +703,7 @@ (define-public nyxt
(define-public lagrange (define-public lagrange
(package (package
(name "lagrange") (name "lagrange")
(version "1.15.5") (version "1.15.8")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -711,7 +711,7 @@ (define-public lagrange
(string-append "https://git.skyjake.fi/skyjake/lagrange/releases/" (string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
"download/v" version "/lagrange-" version ".tar.gz")) "download/v" version "/lagrange-" version ".tar.gz"))
(sha256 (sha256
(base32 "187h42qqddf7595bzf0wb2vc9yd76ad99vbwl9sdhmy8d6qma6gs")) (base32 "0ss1d522f4nnzwhjix58qfbmva9w5j6y6lhlqmjrshv18b1ay4bm"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
'(begin '(begin