mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: sbcl-geco: Fix build.
* gnu/packages/patches/sbcl-geco-fix-organism-class.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/lisp-xyz.scm (sbcl-geco)[source]: Use it.
This commit is contained in:
parent
9c69fec08e
commit
c94367eaaf
3 changed files with 17 additions and 2 deletions
|
@ -20,7 +20,7 @@
|
|||
# Copyright © 2018, 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
|
||||
# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
|
||||
# Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
# Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
|
||||
# Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
|
||||
# Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
|
||||
# Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
|
||||
# Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
|
||||
|
@ -1572,6 +1572,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/rust-reproducible-builds.patch \
|
||||
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
|
||||
%D%/packages/patches/rxvt-unicode-escape-sequences.patch \
|
||||
%D%/packages/patches/sbcl-geco-fix-organism-class.patch \
|
||||
%D%/packages/patches/sbcl-graph-asdf-definitions.patch \
|
||||
%D%/packages/patches/scalapack-blacs-mpi-deprecations.patch \
|
||||
%D%/packages/patches/scheme48-tests.patch \
|
||||
|
|
|
@ -14186,7 +14186,8 @@ (define-public sbcl-geco
|
|||
(uri (string-append "https://common-lisp.net/project/geco/download/"
|
||||
"geco-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0kk0bzr1019cfmf2b1jl1rk9shv3gx5z1znifxllg9mb98yqsgw0"))))
|
||||
(base32 "0kk0bzr1019cfmf2b1jl1rk9shv3gx5z1znifxllg9mb98yqsgw0"))
|
||||
(patches (search-patches "sbcl-geco-fix-organism-class.patch"))))
|
||||
(build-system asdf-build-system/sbcl)
|
||||
(home-page "https://common-lisp.net/project/geco/")
|
||||
(synopsis "Genetic algorithm toolkit for Common Lisp")
|
||||
|
|
13
gnu/packages/patches/sbcl-geco-fix-organism-class.patch
Normal file
13
gnu/packages/patches/sbcl-geco-fix-organism-class.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fix the ORGANISM class so that SBCL >= 2.0.9 can compile it without error.
|
||||
|
||||
--- a/classes.lisp 2020-10-28 12:11:10.725659464 +0100
|
||||
+++ b/classes.lisp 2020-10-31 17:34:36.822752447 +0100
|
||||
@@ -148,7 +148,7 @@
|
||||
:accessor score
|
||||
:initarg :score
|
||||
:initform 'nil
|
||||
- :type number)
|
||||
+ :type (or number null))
|
||||
(NORMALIZED-SCORE
|
||||
:accessor normalized-score
|
||||
:initarg :normalized-score
|
Loading…
Reference in a new issue