mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: glibc: Add 2.27 supported locales patch.
The 'glibc-supported-locales.patch' was updated for glibc 2.29, breaking compatibility with 2.27. Add a 2.27-specific supported locales patch. * gnu/packages/patches/glibc-2.27-supported-locales.patch: New file. * gnu/packages/base.scm (glibc-2.27)[source](patches): Use 'glibc-2.27-supported-locales.patch' instead. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
bcfc54fff8
commit
ca3757e1c2
3 changed files with 35 additions and 1 deletions
|
@ -876,6 +876,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/glibc-2.28-supported-locales.patch \
|
||||
%D%/packages/patches/glibc-2.29-git-updates.patch \
|
||||
%D%/packages/patches/glibc-supported-locales.patch \
|
||||
%D%/packages/patches/glibc-2.27-supported-locales.patch \
|
||||
%D%/packages/patches/glusterfs-use-PATH-instead-of-hardcodes.patch \
|
||||
%D%/packages/patches/glog-gcc-5-demangling.patch \
|
||||
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
|
|
|
@ -854,7 +854,7 @@ (define-public glibc-2.27
|
|||
"glibc-versioned-locpath.patch"
|
||||
"glibc-allow-kernel-2.6.32.patch"
|
||||
"glibc-reinstate-prlimit64-fallback.patch"
|
||||
"glibc-supported-locales.patch"
|
||||
"glibc-2.27-supported-locales.patch"
|
||||
"glibc-CVE-2018-11236.patch"
|
||||
"glibc-CVE-2018-11237.patch"))))
|
||||
(properties `((lint-hidden-cve . ("CVE-2017-18269")))))) ; glibc-2.27-git-fixes
|
||||
|
|
33
gnu/packages/patches/glibc-2.27-supported-locales.patch
Normal file
33
gnu/packages/patches/glibc-2.27-supported-locales.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
This patch is taken from debian's glibc package (generate-supported.mk).
|
||||
It install the localedata/SUPPORTED file of the glibc. This file lists
|
||||
all the supported locales of the glibc.
|
||||
|
||||
diff --git a/localedata/Makefile.old b/localedata/Makefile
|
||||
index 34877c0..a61d9b9 100644
|
||||
--- a/localedata/Makefile.old
|
||||
+++ b/localedata/Makefile
|
||||
@@ -91,7 +91,8 @@ endif
|
||||
# Files to install.
|
||||
install-others := $(addprefix $(inst_i18ndir)/, \
|
||||
$(addsuffix .gz, $(charmaps)) \
|
||||
- $(locales))
|
||||
+ $(locales)) \
|
||||
+ $(inst_i18ndir)/SUPPORTED
|
||||
|
||||
tests: $(objdir)/iconvdata/gconv-modules
|
||||
|
||||
@@ -195,6 +196,14 @@ endif
|
||||
|
||||
include SUPPORTED
|
||||
|
||||
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
|
||||
+ for locale in $(SUPPORTED-LOCALES); do \
|
||||
+ [ $$locale = true ] && continue; \
|
||||
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
|
||||
+ done
|
||||
+ $(make-target-directory)
|
||||
+ $(INSTALL_DATA) LOCALES $@
|
||||
+
|
||||
INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
|
||||
|
||||
# Sometimes the whole collection of locale files should be installed.
|
Loading…
Reference in a new issue