mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 13:58:15 -05:00
gnu: meson: Update to 0.47.1.
* gnu/packages/build-tools.scm (meson): Update to 0.47.1. * gnu/packages/patches/meson-for-build-rpath.patch: Adjust to file rename and indendation change.
This commit is contained in:
parent
94eb59fb4a
commit
cb8f7d6d2f
2 changed files with 19 additions and 18 deletions
|
@ -100,7 +100,7 @@ (define-public bear
|
|||
(define-public meson
|
||||
(package
|
||||
(name "meson")
|
||||
(version "0.46.1")
|
||||
(version "0.47.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/mesonbuild/meson/"
|
||||
|
@ -108,7 +108,7 @@ (define-public meson
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0y7f5hhy16q99l7x06x8sid9p9dbg6d7i60zs7c07cz5ww1plj8r"))))
|
||||
"19mdap2ncvczajx220bd73xmwhd8x906382y18cn9c5syxwxwwyn"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
|
||||
|
|
|
@ -4,15 +4,16 @@ meson-build-system.
|
|||
|
||||
Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
||||
|
||||
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
|
||||
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
|
||||
@@ -391,14 +391,6 @@
|
||||
--- meson-0.42.0/mesonbuild/minstall.py.orig 2017-09-09 01:49:39.147374148 +0200
|
||||
+++ meson-0.42.0/mesonbuild/minstall.py 2017-09-09 01:51:01.209134717 +0200
|
||||
@@ -436,15 +436,6 @@
|
||||
print("Symlink creation does not work on this platform. "
|
||||
"Skipping all symlinking.")
|
||||
printed_symlink_error = True
|
||||
- if os.path.isfile(outname):
|
||||
- try:
|
||||
- depfixer.fix_rpath(outname, install_rpath, False)
|
||||
- depfixer.fix_rpath(outname, install_rpath, final_path,
|
||||
- install_name_mappings, verbose=False)
|
||||
- except SystemExit as e:
|
||||
- if isinstance(e.code, int) and e.code == 0:
|
||||
- pass
|
||||
|
@ -20,4 +21,4 @@ Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
|||
- raise
|
||||
|
||||
def run(args):
|
||||
global install_log_file
|
||||
parser = buildparser()
|
||||
|
|
Loading…
Reference in a new issue