mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: ceph: Update to 12.0.2.
* gnu/packages/storage.scm (ceph): Update to 12.0.2. [arguments]<#:phases>: Disable new test. * gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Adjust.
This commit is contained in:
parent
011b858b94
commit
ce09f04ea0
2 changed files with 9 additions and 6 deletions
|
@ -15,16 +15,16 @@ don't add anything for i686.
|
|||
#
|
||||
# SIMD_COMPILE_FLAGS
|
||||
#
|
||||
@@ -56,7 +51,7 @@
|
||||
if(HAVE_ARM_NEON)
|
||||
@@ -73,7 +68,7 @@
|
||||
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
|
||||
endif()
|
||||
|
||||
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
|
||||
+elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
|
||||
set(HAVE_INTEL 1)
|
||||
CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
|
||||
if(HAVE_INTEL_SSE)
|
||||
@@ -66,24 +61,4 @@
|
||||
@@ -83,26 +78,6 @@
|
||||
if(HAVE_INTEL_SSE2)
|
||||
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse2")
|
||||
endif()
|
||||
|
@ -48,4 +48,6 @@ don't add anything for i686.
|
|||
- if(HAVE_INTEL_SSE4_2)
|
||||
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.2")
|
||||
- endif()
|
||||
endif()
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "(powerpc|ppc)64le")
|
||||
set(HAVE_PPC64LE 1)
|
||||
message(STATUS " we are ppc64le")
|
||||
|
|
|
@ -48,14 +48,14 @@ (define-module (gnu packages storage)
|
|||
(define-public ceph
|
||||
(package
|
||||
(name "ceph")
|
||||
(version "12.0.1")
|
||||
(version "12.0.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1mgd7iqx9zgwims2bb8dbzhzv0p6z9vjxavbv8dampa34fzac3xc"))
|
||||
"0l9v072ba28i984y5rwny9i11nmpyx5bl7awxg48plyadm2l3g14"))
|
||||
(patches
|
||||
(search-patches "ceph-skip-unittest_blockdev.patch"
|
||||
"ceph-skip-collect-sys-info-test.patch"
|
||||
|
@ -223,6 +223,7 @@ (define-public ceph
|
|||
(substitute* "src/test/osd/CMakeLists.txt"
|
||||
(("^add_ceph_test\\(osd-bench\\.sh.*$") "\n")
|
||||
(("^add_ceph_test\\(osd-config\\.sh.*$") "\n")
|
||||
(("add_ceph_test\\(osd-dup\\.sh.*$") "\n")
|
||||
(("^add_ceph_test\\(osd-markdown\\.sh.*$") "\n")
|
||||
(("^add_ceph_test\\(osd-reactivate\\.sh.*$") "\n")
|
||||
(("^add_ceph_test\\(osd-reuse-id\\.sh.*$") "\n")
|
||||
|
|
Loading…
Reference in a new issue