gnu: abseil-cpp: Remove googletest patch.

* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/cpp.scm (abseil-cpp)[source]: Remove patch.

Co-authored-by: Greg Hogan <code@greghogan.com>
This commit is contained in:
Maxim Cournoyer 2021-10-08 22:40:30 -04:00
parent fd980bbf2f
commit ce92aba5c7
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 1 additions and 21 deletions

View file

@ -817,7 +817,6 @@ dist_patch_DATA = \
%D%/packages/patches/abcl-fix-build-xml.patch \
%D%/packages/patches/ableton-link-system-libraries-debian.patch \
%D%/packages/patches/abiword-explictly-cast-bools.patch \
%D%/packages/patches/abseil-cpp-fix-gtest.patch \
%D%/packages/patches/abseil-cpp-fix-strerror_test.patch \
%D%/packages/patches/adb-add-libraries.patch \
%D%/packages/patches/adb-libssl_11-compatibility.patch \

View file

@ -754,11 +754,8 @@ (define-public abseil-cpp
(sha256
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
;; Remove after next googletest release and update.
(patches
(search-patches
"abseil-cpp-fix-gtest.patch"
"abseil-cpp-fix-strerror_test.patch"))))
(search-patches "abseil-cpp-fix-strerror_test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"

View file

@ -1,16 +0,0 @@
The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
a googletest release.
--- a/absl/container/internal/unordered_map_modifiers_test.h
+++ b/absl/container/internal/unordered_map_modifiers_test.h
@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
}
};
+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
+#endif
TYPED_TEST_SUITE_P(UniquePtrModifiersTest);