mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-08 20:30:05 -05:00
gnu: abseil-cpp: Remove googletest patch.
* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/cpp.scm (abseil-cpp)[source]: Remove patch. Co-authored-by: Greg Hogan <code@greghogan.com>
This commit is contained in:
parent
fd980bbf2f
commit
ce92aba5c7
3 changed files with 1 additions and 21 deletions
|
@ -817,7 +817,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/abcl-fix-build-xml.patch \
|
||||
%D%/packages/patches/ableton-link-system-libraries-debian.patch \
|
||||
%D%/packages/patches/abiword-explictly-cast-bools.patch \
|
||||
%D%/packages/patches/abseil-cpp-fix-gtest.patch \
|
||||
%D%/packages/patches/abseil-cpp-fix-strerror_test.patch \
|
||||
%D%/packages/patches/adb-add-libraries.patch \
|
||||
%D%/packages/patches/adb-libssl_11-compatibility.patch \
|
||||
|
|
|
@ -754,11 +754,8 @@ (define-public abseil-cpp
|
|||
(sha256
|
||||
(base32
|
||||
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
|
||||
;; Remove after next googletest release and update.
|
||||
(patches
|
||||
(search-patches
|
||||
"abseil-cpp-fix-gtest.patch"
|
||||
"abseil-cpp-fix-strerror_test.patch"))))
|
||||
(search-patches "abseil-cpp-fix-strerror_test.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
|
||||
in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
|
||||
a googletest release.
|
||||
|
||||
--- a/absl/container/internal/unordered_map_modifiers_test.h
|
||||
+++ b/absl/container/internal/unordered_map_modifiers_test.h
|
||||
@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
|
||||
}
|
||||
};
|
||||
|
||||
+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
|
||||
GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
|
||||
+#endif
|
||||
|
||||
TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
|
||||
|
Loading…
Reference in a new issue